ReShade no longer works with "Monster Hunter: World"

More
6 months 2 weeks ago - 6 months 2 weeks ago #1 by Maulclaw
MHW had its latest update today. Not only did it break a couple of popular mods, it also broke ReShade. It was working perfectly fine as of last night. But now it just refuses to open. The game has two modes: DirectX11 and DirectX12. Whilst playing on DirectX11, changing the .dll file from dxgi.dll to d3d11.dll seems to do the trick. However, anyone who is playing on DirectX12... has no way to trigger it, not even when renaming the file d3d12.dll.

This is affecting everyone who uses ReShade on this game. Having older or newer versions of NVIDIA drivers and/or ReShade leads to the same results.
Last edit: 6 months 2 weeks ago by Maulclaw.
The following user(s) said Thank You: dotLead

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago #2 by chespinecks
yea, same issue for me

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago #3 by Xaltra
Having the same issue here. MHWI's recent update disabled all Reshade functionality. Posting here to build up numbers so that this can be seen by others.

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago #4 by crosire
That is not something ReShade has any influence over. If the game bypasses loading D3D from the game directory and instead loads it directly from the system directory (which is likely what was done here, as a anti-cheat mechanism), then you are out of luck loading ReShade that way. Only solution then is to use an injector to inject ReShade into the process. E.g. using reshade.me/downloads/inject64.exe (there is a tutorial on how to use is at framedsc.github.io/ReshadeGuides/reshadeuwp.htm). Use at your own risk.

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago #5 by Dandaedre
Can confirm that injecting the dll works for me (win10 64bit). It's a ugly hassle, then again the Nvidia filter just don't cut it for me.
Any plan to have something more generic for games that misbehave ?

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago #6 by gpdx
For me, the DirectX11 method worked. I set a launch option in steam for -dx11 and renamed the Reshade .dll file to d3d11.dll and the menu and tutorial appeared in game. Obviously, not an ideal solution when running on DX12 might be preferred.

Please Log in or Create an account to join the conversation.

More
6 months 2 weeks ago #7 by dotLead
I've been trying out the "launch with DirectX 11" solution (changed the game launch option to -dx11 in Steam, changed the dxgi.dll Reshade file into d3d11.dll) but it still hasn't worked out for me. Since I'm all out of options, why is injecting an ugly hassle?

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #8 by Wicked Sick
So, I was not the only one...

Please Log in or Create an account to join the conversation.

More
2 months 6 days ago #9 by midu
Hello Guys,
the problem can be resolve if you go to ->Options->display and trun off Activate Directx12 API.
May the app does not consider if this property is turn on.
Or you use the mod "www.nexusmods.com/monsterhunterworld/mods/4869?tab=description" which have a solution for this specific problem and the modder has the source published.

I hope it helps.

Please Log in or Create an account to join the conversation.