Unexpected error in assetto corsa

More
9 months 2 days ago - 9 months 2 days ago #1 by Thecrazyninja
Unexpected error in assetto corsa was created by Thecrazyninja
So I wanted to have a reshade (4.8.2). Downloaded it, installed it and tried to get it working. After a few minutes of trying I launched the game and it worked ONCE. When i wanted to play again my game didn't want to boot up and there was an "Unexpected error". I tried reinstalling the whole game, reinstalling csp, changing version of csp, reinstalling sol, reinstalling reshade, changing "dxgi.dll" into "d3d11.dll" and "d3d9.dll" but I still can't get it working. I'm sure that i installed csp and SOL properly beacouse i could play before without reshade.
Also the CM says that might be something wrong with this:
AC\kgl.cpp (642): kglSwapBuffers
AC\graphicsmanager.cpp (383): GraphicsManager::endScene
AC\game.cpp (166): Game::onIdle
AC\game.cpp (210): Game::run
AC\acs.cpp (477): wWinMain
f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c (618): __tmainCRTStartup
Last edit: 9 months 2 days ago by Thecrazyninja.

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #2 by ibrahim_ok
Replied by ibrahim_ok on topic Unexpected error in assetto corsa
+1

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago - 7 months 1 week ago #3 by Maddo03
Replied by Maddo03 on topic Unexpected error in assetto corsa
I have been getting the same issue in Assetto Corsa.
Have installed SOL and CSP via the content manager application.

When I install Reshade it works great, once.
I found that I have to rename or move my preset ini file in order to get the game to launch.
It seems maybe the game is trying to do too much at launch and is causing the crash.

Is it possible to set a delay on the shader activating, or set reshade to not load a preset on launch?

Getting these errors using Reshade 4.9.1:
Failed operation `d3d::device()-> *constructor)(data.data(),
data.size(), nullptr, &ret)`, error: 0x887a0005, device removed:
0x887a0006

File: source\ac_classes\KGLShader.cpp
Function: try_create_shader
Line: 111

and

Cannot create CBuffer (slot: 11, size: 1008)

File: source\dx\cbuffer_perobject.cpp
Function: initialize
Line: 60
Last edit: 7 months 1 week ago by Maddo03.

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #4 by Maddo03
Replied by Maddo03 on topic Unexpected error in assetto corsa
I have found a work around for this, as I suspected the game is doing too much at startup when launching via Content Manager with mods.

Browse to the root directory of Assetto Corsa, example N:\Games\SteamLibrary\steamapps\common\assettocorsa and open Reshade.ini
Under [GENERAL] add the line:

NoReloadOnInit=1

This will stop reshade from compiling shaders at launch and will allow the game to load. Once in game and ready to drive, press your assigned hotkey to enable your preset.
This can be assigned by pressing Home, then selecting the settings tab at the top.

Not perfect, but certainly workable.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #5 by Maddo03
Replied by Maddo03 on topic Unexpected error in assetto corsa
I have been getting the same issue in Assetto Corsa.
Have installed SOL and CSP via the content manager application.

When I install Reshade it works great, once.
I found that I have to rename or move my preset ini file in order to get the game to launch.
It seems maybe the game is trying to do too much at launch and is causing the crash.

Is it possible to set a delay on the shader activating, or set reshade to not load a preset on launch?

Getting these errors using Reshade 4.9.1:
https://imgur.com/HmSIgVe
[img]<blockquote class="imgur-embed-pub" lang="en" data-id="a/t3I78KF" data-context="false" ><a href="//imgur.com/a/t3I78KF"></a></blockquote><script async src="//s.imgur.com/min/embed.js" charset="utf-8"></script>[/img]

Please Log in or Create an account to join the conversation.