Lut shader running twice after app loses focus

More
1 week 1 day ago #1 by fustercluck
Hi,

I'm running into the following problem:

I've got reshade installed on an OpenGL-based app. I'm using the LUT shader, with a custom LUT.

Initially, when the app in question has focus, it works as expected -- the LUT performs the desired color correction. However, when a window from another app gets focus, the color correction seems to be applied twice, i.e. seemingly source image->lut->corrected image->lut->over-corrected image.

Would very much appreciate and suggestions what might be going on or how to track this down.

Thanks!

Dan

 

Please Log in or Create an account to join the conversation.

More
1 week 15 hours ago #2 by fustercluck
Replied by fustercluck on topic Lut shader running twice after app loses focus
Update...

As it turns out, it's a bit more complicated than just shaders running twice, and seems to happen with *any* shader.

I'm seeing effects sometimes run, even when they are not selected in the menu (though were previously).

When the effect is selected, sometimes it is running twice. (For example, if I enable the tint shader, sometimes it tints the original amount, sometimes 2x) and if deselected, I still see the tint.

Any suggestions would be very much appreciated. Maybe something to look for in the logs??

Please Log in or Create an account to join the conversation.

More
5 days 12 hours ago #3 by fustercluck
Replied by fustercluck on topic Lut shader running twice after app loses focus
Thanks, but I'm not sure I follow; this isn't an HDR display. Also, I've seen this effect with shaders other than LUT.fx (e.g. tint).

Please Log in or Create an account to join the conversation.