can not compile api_trace

More
7 months 3 weeks ago #1 by lefuneste can not compile api_trace was created by lefuneste
Hello, at first some include files were missing : imgui.h, imconfig.h
Wehn I copy them form imgui repo, I had the following error message:

Build started...
1>
Build started: Project: 01-api_trace, Configuration: Debug x64
1>api_trace.cpp
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(265,54): error C2061: syntax error: identifier 'ImGuiDockNodeFlags'
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(267,50): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(267,50): error C2143: syntax error: missing ',' before '*'
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(694,59): error C2061: syntax error: identifier 'ImGuiDockNodeFlags'
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(694,185): error C2065: 'flags': undeclared identifier
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(694,192): error C2065: 'window_class': undeclared identifier
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(696,55): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(696,55): error C2143: syntax error: missing ',' before '*'
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(696,125): error C2065: 'window_class': undeclared identifier
1>Done building project "api_trace.vcxproj" -- FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

 

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago - 7 months 3 weeks ago #2 by crosire Replied by crosire on topic can not compile api_trace
Please read the documentation at crosire.github.io/reshade-docs/index.html , it has a link to the right imgui.h you need.
Last edit: 7 months 3 weeks ago by crosire.

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago #3 by lefuneste Replied by lefuneste on topic can not compile api_trace
Hello
Thanks, I did not see the link at first glance...
So I downloaded the package from github.com/ocornut/imgui/tree/v1.86 , unzip it in the same level than reshade main, put imconfig.h and imgui.h in the "include" folder in reshade-main, go to reshade-main\examples, open Examples.sln with visual studio 2022, launch the build of 01-api_trace and still had the following message:
Build started...
1>
Build started: Project: 01-api_trace, Configuration: Debug x64
1>api_trace.cpp
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(265,54): error C2061: syntax error: identifier 'ImGuiDockNodeFlags'
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(267,50): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(267,50): error C2143: syntax error: missing ',' before '*'
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(694,59): error C2061: syntax error: identifier 'ImGuiDockNodeFlags'
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(694,185): error C2065: 'flags': undeclared identifier
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(694,192): error C2065: 'window_class': undeclared identifier
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(696,55): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(696,55): error C2143: syntax error: missing ',' before '*'
1>K:\utils\Repos\reshade-main\include\reshade_overlay.hpp(696,125): error C2065: 'window_class': undeclared identifier
1>Done building project "api_trace.vcxproj" -- FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Sorry if I'm doing some stupid things, but I am not a professional of Visual Studio environment..

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago #4 by crosire Replied by crosire on topic can not compile api_trace
Mmh, forgot that it's refering to some types from the imgui docking branch, rather than the main branch.
This one should work: github.com/ocornut/imgui/blob/15b4a064f9...b615fb394321/imgui.h

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago #5 by crosire Replied by crosire on topic can not compile api_trace
It's changed now ( github.com/crosire/reshade/commit/d52c29...f415a12f9e1a1809926b ), so you can build with the v1.86 header from the main branch too.

Please Log in or Create an account to join the conversation.

More
7 months 3 weeks ago #6 by lefuneste Replied by lefuneste on topic can not compile api_trace
Thanks, it is working now. I'll dig deeper, but on first look I'm not able to mach shader reference in "API trace" and shader hash produced by "dump_shader" ?

Please Log in or Create an account to join the conversation.

We use cookies

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.