5.0 breaking lighting/shadows in The Sims 4

More
3 months 3 weeks ago #1 by amoebae
There's a problem with 5.0 and lighting/shadows in The Sims 4. It's breaking some shadows entirely (they don't appear), others are weaker, and whatever lighting is controlled by what I'm guessing is the game's own post-processing is left flat and washed-out.

I've tried 5.0.0, 5.0.1, and 5.0.2 in a vanilla game, new save, with up-to-date drivers. Everyone else I've spoken to is having the same problem. Reverting to 4.9.1 fixes it, so it's not a game update issue.

Screenshots for examples:

The following user(s) said Thank You: Isatumble

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #2 by BraveNewWorldMag
Replied by BraveNewWorldMag on topic 5.0 breaking lighting/shadows in The Sims 4
omg ive been searching for days !! i have the same issue did you just went back to 4.9.1 after all ?

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #3 by amoebae
Replied by amoebae on topic 5.0 breaking lighting/shadows in The Sims 4
Yes, I've gone back to 4.9.1. There's no solution yet that I know of. I don't know if it's something crosire will look into or not, I expect he's fighting lots of fires with the new release. At least 4.9.1 is stable and works well. Make sure you keep a backup of your 4.9.1 shaders in case you need to reinstall that version again in the future.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #4 by BraveNewWorldMag
Replied by BraveNewWorldMag on topic 5.0 breaking lighting/shadows in The Sims 4
thank you and yes i went back to the 4.9.1 version too

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #5 by amoebae
Replied by amoebae on topic 5.0 breaking lighting/shadows in The Sims 4
Any word on a fix for this yet? I've seen people have the same problem in a couple of other dx9 games too since 5.0.

Please Log in or Create an account to join the conversation.