[SOLVED] Sleeping Dogs not working with latest Reshade

  • Quentin-Tarantino
  • Quentin-Tarantino's Avatar Topic Author
  • Offline
  • Posts: 351
5 years 6 days ago #1 by Quentin-Tarantino
Renaming the .dlls and drag and drop is not working with the latest Reshade + Framework or MasterFX in Sleeping Dogs!
Only when i run the ReShade Setup installer that comes with the lastest SFX 2.0 and find the Sleeping Dogs exe then it works!

So where can i find the last version of Reshade + Framework that had the installer included?
I made a preset with that a while ago but with a new install i lost every thing!
So it would be great if someone could pass us the the last version of Reshade + Framework that had the installer included

Thanks :)

Please Log in or Create an account to join the conversation.

  • Posts: 504
5 years 6 days ago - 5 years 6 days ago #2 by Wicked Sick
I've tested with 0.19.2 and it worked on Definitive Edition, DX11 and 64bit. But if I recall well, I have read Lucifer writing something to someone about the changes brought to the Framework would make it a bit hard to use the old configuration files. You would have to make everything by hand since their structure are a bit different now, and that was why it did not load.

Here is my stuff unchanged, except for the 0.19.1. The 0.17 still had the old setup.exe

www.dropbox.com/sh/iitidx3jknmqnpm/AAAbI...xoU2x4qqS0LpLna?dl=0
The following user(s) said Thank You: Quentin-Tarantino

Please Log in or Create an account to join the conversation.

  • Quentin-Tarantino
  • Quentin-Tarantino's Avatar Topic Author
  • Offline
  • Posts: 351
5 years 6 days ago - 5 years 6 days ago #3 by Quentin-Tarantino

Wicked Sick wrote: I've tested with 0.19.2 and it worked on Definitive Edition, DX11 and 64bit. But if I recall well, I have read Lucifer writing something to someone about the changes brought to the Framework would make it a bit hard to use the old configuration files. You would have to make everything by hand since their structure are a bit different now, and that was why it did not load.

Here is my stuff unchanged, except for the 0.19.1. The 0.17 still had the old setup.exe

Now i just tried ReShade 0.18.7 Public Beta with Framework and it only hooks if i run the installer!
So it is very strange why if i rename the .dlls with old or new Reshade and just drop the files into Sleeping Dogs game folder it won't work
But when i run the installer to hook it to Sleeping Dogs it works like a charm.
This is the only game i had this problem with apart from The Stanley Parable where it wouldn't hook unless i ran the installer.

So Newest is out of the ? with Sleeping Dogs for me because it ain't got a installer

Anyway thanks again mate :)

Please Log in or Create an account to join the conversation.

  • Posts: 3741
5 years 5 days ago - 5 years 5 days ago #4 by crosire
Just put the old installer in the folder you downloaded and install the newest ReShade version with it. =)

Again, ReShade (injector) is NOT ReShade Framework (shaders), they are developed independently, and the version number 0.19.2 indicates the ReShade version, which only means the DLLs. The ReShade with Framework and ReShade with SweetFX packages are provided only for convenience, so one does not have to download ReShade and those shader packs separatly. The setup tool was removed from the newer framework packages, because Lucifers mediator tool provides a similar installation option now, which made it obsolete, but that doesn't mean you can no longer use it.
The following user(s) said Thank You: Quentin-Tarantino

Please Log in or Create an account to join the conversation.

  • Quentin-Tarantino
  • Quentin-Tarantino's Avatar Topic Author
  • Offline
  • Posts: 351
5 years 5 days ago #5 by Quentin-Tarantino

crosire wrote: Just put the old installer in the folder you downloaded and install the newest ReShade version with it. =)

Again, ReShade (injector) is NOT ReShade Framework (shaders), they are developed independently, and the version number 0.19.2 indicates the ReShade version, which only means the DLLs. The ReShade with Framework and ReShade with SweetFX packages are provided only for convenience, so one does not have to download ReShade and those shader packs separatly. The setup tool was removed from the newer framework packages, because Lucifers mediator tool provides a similar installation option now, which made it obsolete, but that doesn't mean you can no longer use it.


Ah i see lol. How did i not think or of trying that :) Thanks man.

Please Log in or Create an account to join the conversation.