[SOLVED] ReShade 0.19.2 Public Beta with SweetFX 2.0 Beta 8

More
5 years 3 months ago #1 by dazed
Cant get it to work with BF4 constantly crashing, i was using an older version (don't remember which one) that worked fine i thought updating to the latest version was a good idea but now the game doesn't start. Can anyone help?

dxgi.log
11/07/2015 14:59:40:644 [01164] | INFO  | Initializing Crosire's ReShade version '0.19.2.905' built on '2015-07-04 14:33:40' loaded from "F:\Origin Games\Battlefield 4\dxgi.dll" to "F:\Origin Games\Battlefield 4\bf4.exe" ...
11/07/2015 14:59:40:693 [01164] | INFO  | Registering hooks for "C:\Windows\system32\d3d8.dll" ...
11/07/2015 14:59:40:693 [01164] | INFO  | > Delayed.
11/07/2015 14:59:40:693 [01164] | INFO  | Registering hooks for "C:\Windows\system32\d3d9.dll" ...
11/07/2015 14:59:40:693 [01164] | INFO  | > Delayed.
11/07/2015 14:59:40:693 [01164] | INFO  | Registering hooks for "C:\Windows\system32\d3d10.dll" ...
11/07/2015 14:59:40:694 [01164] | INFO  | > Delayed.
11/07/2015 14:59:40:694 [01164] | INFO  | Registering hooks for "C:\Windows\system32\d3d10_1.dll" ...
11/07/2015 14:59:40:694 [01164] | INFO  | > Delayed.
11/07/2015 14:59:40:694 [01164] | INFO  | Registering hooks for "C:\Windows\system32\d3d11.dll" ...
11/07/2015 14:59:40:694 [01164] | INFO  | > Delayed.
11/07/2015 14:59:40:694 [01164] | INFO  | Registering hooks for "C:\Windows\system32\dxgi.dll" ...
11/07/2015 14:59:40:694 [01164] | INFO  | > Delayed.
11/07/2015 14:59:40:694 [01164] | INFO  | Registering hooks for "C:\Windows\system32\opengl32.dll" ...
11/07/2015 14:59:40:694 [01164] | INFO  | > Libraries loaded.
11/07/2015 14:59:40:697 [01164] | INFO  | > Found 360 match(es). Installing ...
11/07/2015 14:59:45:035 [01164] | INFO  | > Installed 360 hook(s).
11/07/2015 14:59:45:035 [01164] | INFO  | Registering hooks for "C:\Windows\system32\user32.dll" ...
11/07/2015 14:59:45:035 [01164] | INFO  | > Libraries loaded.
11/07/2015 14:59:45:046 [01164] | INFO  | > Found 5 match(es). Installing ...
11/07/2015 14:59:45:105 [01164] | INFO  | > Installed 5 hook(s).
11/07/2015 14:59:45:105 [01164] | INFO  | Registering hooks for "C:\Windows\system32\ws2_32.dll" ...
11/07/2015 14:59:45:105 [01164] | INFO  | > Delayed.
11/07/2015 14:59:45:105 [01164] | INFO  | Initialized.
11/07/2015 14:59:45:111 [01164] | INFO  | Installing delayed hooks for "C:\Windows\system32\d3d9.dll" (Just loaded via 'LoadLibraryW("d3d9.dll")') ...
11/07/2015 14:59:45:111 [01164] | INFO  | > Found 9 match(es). Installing ...
11/07/2015 14:59:45:220 [01164] | INFO  | > Installed 9 hook(s).
11/07/2015 14:59:45:233 [05672] | INFO  | Installing delayed hooks for "C:\Windows\system32\dxgi.dll" ...
11/07/2015 14:59:45:233 [05672] | INFO  | > Found 7 match(es). Installing ...
11/07/2015 14:59:45:233 [05672] | INFO  | > Installed 7 hook(s).
11/07/2015 14:59:45:235 [04380] | INFO  | Redirecting 'Direct3DCreate9(32)' ...
11/07/2015 14:59:45:250 [04380] | INFO  | Redirecting 'IDirect3D9::CreateDevice(0000000000285BE0, 0, 4, 00000000000A0D5A, 0x840, 00000000020DFE80, 00000000020DFED0)' ...
11/07/2015 14:59:45:271 [04380] | WARN  | > Skipping device due to device type being 'D3DDEVTYPE_NULLREF'.
11/07/2015 14:59:46:357 [01164] | INFO  | Installing delayed hooks for "C:\Windows\system32\d3d11.dll" (Just loaded via 'LoadLibraryA("d3d11.dll")') ...
11/07/2015 14:59:46:357 [01164] | INFO  | > Found 2 match(es). Installing ...
11/07/2015 14:59:46:382 [01164] | INFO  | > Installed 2 hook(s).
11/07/2015 14:59:46:386 [01164] | INFO  | Installing delayed hooks for "C:\Windows\system32\ws2_32.dll" (Just loaded via 'LoadLibraryA("WS2_32.dll")') ...
11/07/2015 14:59:46:388 [01164] | INFO  | > Found 8 match(es). Installing ...
11/07/2015 14:59:46:488 [01164] | INFO  | > Installed 8 hook(s).
11/07/2015 14:59:53:064 [10152] | INFO  | Redirecting 'CreateDXGIFactory1({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 0000000034416120)' ...
11/07/2015 14:59:53:244 [01164] | INFO  | Redirecting 'RegisterClassExA(000000000013F120)' ...
11/07/2015 14:59:53:244 [01164] | INFO  | > Adding 'CS_OWNDC' window class style flag to 'Battlefield 4'.
11/07/2015 15:00:11:610 [10152] | INFO  | Redirecting 'RegisterRawInputDevices(00000000020DF8F0, 1, 16)' ...
11/07/2015 15:00:11:610 [10152] | INFO  | Redirecting 'D3D11CreateDevice(00000000041D4AA0, 0, 0000000000000000, 0x80, 00000000020DF6F0, 1, 7, 00000000020DF6E8, 00000000020DF6E0, 00000000020DF6F8)' ...
11/07/2015 15:00:11:610 [10152] | INFO  | > Passing on to 'D3D11CreateDeviceAndSwapChain':
11/07/2015 15:00:11:610 [10152] | INFO  | Redirecting 'D3D11CreateDeviceAndSwapChain(00000000041D4AA0, 0, 0000000000000000, 0x80, 00000000020DF6F0, 1, 7, 0000000000000000, 0000000000000000, 00000000020DF6E8, 00000000020DF6E0, 00000000020DF6F8)' ...
11/07/2015 15:00:11:619 [10152] | INFO  | Redirecting 'IDXGIFactory::CreateSwapChain(0000000000280650, 0000000004124850, 00000000020DF7F0, 000000003441A990)' ...
11/07/2015 15:00:11:629 [10152] | INFO  | Recreated effect environment on runtime 000000000267EEE0.
11/07/2015 15:00:19:173 [02416] | INFO  | Loading effect from "F:\Origin Games\Battlefield 4\ReShade.fx" ...

Please Log in or Create an account to join the conversation.

More
5 years 3 months ago - 5 years 3 months ago #2 by dazed
Found the solution on reddit

00Serval 3 points 6 months ago
Do you have Razer Synapse installed? A recent update to that made mine start running a bunch of background processes, one of which (razeringameengine, I think) caused that error. Updating it again made it stop running all those processes (I never told it to run any of the features that require them, anyway) and everything went back to normal.
If you have m/any other programs that put an overlay on the screen, they might be conflicting in a similar manner.

Source

Fucking Razer, i dont even remember enabling the stats/heatmap thing but sure enough once disabled Reshade worked fine :)
Last edit: 5 years 3 months ago by dazed.
The following user(s) said Thank You: rapt0r

Please Log in or Create an account to join the conversation.

More
5 years 3 months ago #3 by crosire
Happy to hear you got it sorted out =). It will hopefully help others who run into the same issue.

Please Log in or Create an account to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #4 by rapt0r
Wow, I just want to say thanks to 'dazed' for finding out about the 'RazerIngameEngine.exe' issue. Been trying to figure out why BF3 wouldn't work with SweetFX all of a sudden for about a month now. Tried everything I could think of, every version of Reshade and SweetFX standalone but nothing worked until today I finally stumbled upon this thread so a huge thankyou to 'dazed 'as I can now play BF3 again with colors that arn't drab and dreary and sharpness applied.

*edit*
just a note to myself incase I need this again, SweetFX 2.0 (Preview 8 | ReShade 1.0.0) let me play for about 5 mins before being kicked by PB, after switching to SweetFX 1.4 by CeeJay.dk - Version 1.4 (which is what I was always using anyway) no PB kick and all is well again.
Last edit: 5 years 1 month ago by rapt0r. Reason: edit

Please Log in or Create an account to join the conversation.