Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Anachronox: black screen

Anachronox: black screen 1 year 10 months ago #1

Hey there! Tried to run Anachronox with the freshly downloaded 0.12.0. The hook itself works, it displays all the messages and the transition effect. However, enabling any effects except splitscreen results in completely black output (aside from the debugging messages). The only effect that doesn't cause it is splitscreen and other effects wipe even the left side of the screen even when it's on.

I think I've managed to get some output with that swapped opengl colors bug, but I couldn't reproduce it with any combinations of options. It seems to be intermittent somehow.

The game is using a modified Quake 2 engine and OpenGL output. Same happens with the original binaries and the unofficial widescreen patch for the game. I'm using Windows 7 with freshly updated NVidia drivers. This version of Reshade worked for me on other, at least d3d games.

The log file

Any ideas?
Last Edit: 1 year 10 months ago by qptain Nemo.
The administrator has disabled public write access.

Anachronox: black screen 1 year 10 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
I'm aware of this, but couldn't yet figure out why it happens, because other shaders/shaderpacks (MasterEffect for instance, there's a thread in the presentation section) do not have this problem.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: qptain Nemo

Anachronox: black screen 1 year 10 months ago #3

Wow, I just assumed it won't work with other shader packs either. It actually works with Master Effect, which is more than satisfactory.

Thank you for your work, Crosire, you've fulfilled yet another man's dream.

This topic can be considered solved as far as I'm concerned.
The administrator has disabled public write access.
The following user(s) said Thank You: crosire