Welcome, Guest.
Username: Password: Remember me

TOPIC: Start the game with reshade off

Start the game with reshade off 1 year 3 months ago #1

Hello.

I would like to ask.
Is there any way to set reshade to start turned off at game launch?
And then If I wanted it on, I could just use the enable/disable key (scroll lock) and then all the shaders would load.

Tried a bit of googling, but "unlucky".

Thanks for any answers :)
Last Edit: 1 year 3 months ago by Neoony.
The administrator has disabled public write access.

Start the game with reshade off 1 year 3 months ago #2

The source code is up, you can do it yourself... I would send you mine that already does this, but I don't want to anger Crosire :D
The administrator has disabled public write access.
The following user(s) said Thank You: Neoony

Start the game with reshade off 1 year 3 months ago #3

Ok, if there isnt any way to do it in config or so, then thats all the info I need :)

Now, Iam not a coder, but I already tried compiling Reshade for other reasons.

Maybe you could share the piece of code I need to change? Or atleast PM?
Or atleast point me to it?

I mean its open source now and I probably wont be the only one asking for such thing.
So I dont see a reason why not paste it public here, so that others can find it too? :)

Anyways, Thanks :)
The administrator has disabled public write access.

Start the game with reshade off 1 year 3 months ago #4

This is the code snippet that I wrote (it's quick and dirty, sorry).

This is all in "Runtime.cpp", btw.
bool modified = false;
modified |= ImGui::Checkbox("Toggle Effects", &_effects_enabled);

This will add a toggle button under a tab of your choosing (I put mine in a custom header in the "Settings" tab). If you don't know how to make a custom header, just look at the "User Interface" header and it's options.
Example:


After that, add this to this line:


Then add this to this line:


Compile, and if done correctly, you should have this option in the config file:
Last Edit: 1 year 3 months ago by NoMansReshade.
The administrator has disabled public write access.
The following user(s) said Thank You: Neoony