Welcome, Guest.
Username: Password: Remember me

TOPIC: ReShade 3 start with effects disabled

ReShade 3 start with effects disabled 4 months 1 week ago #1

Hi

Is this possible? I have found some solution for older ReShade versions, but for ReShade 3, is it possible to start reshade turned off, and the turn it on in the game, with some hotkey?

I look that, because the ReShade config which is ok for the game itself (3D game) is not for the 2D menus, etc...

Thanks
The administrator has disabled public write access.

ReShade 3 start with effects disabled 4 months 1 week ago #2

Yes. Relevant setting in the config file (one of d3d9/dxgi/opengl32/ReShade.ini):
[GENERAL]
NoReloadOnInit=1
Cheers, crosire =)
The administrator has disabled public write access.

ReShade 3 start with effects disabled 4 months 1 week ago #3

Thanks! I have tried it, and indeed the shaders are not applied at game start, but there are some problems:

I can't activate the shaders of my .ini config file with the hotkey I had associated to them (I have linked the same hotkey to all shaders I have used in my setting), moreover, if I open the console (shf+f2 by default) I see, in the first tab, my config file selected at the top but below there is no shaders, nor selected or unselected, the list is empty! I have to select another time my config file, and then it is applied and all the shaders appear in the list (after reading all installed shaders regardless of being in Performance mode).

Is that normal? I hope not.

There is another problem, just few seconds after game starts normally, the screen becomes over-bright and with double image. The only way to remove this, is to open the console of ReShade and select a configuration profile, as explained.

Everything is the same if I select my profile, exit game and re-start it, or if I use Reshade in configuration mode. EDIT: if I use it in Configuration Mode everything is the same, except that I can't activate my profile (neither make appear the list of all shaders in the console) even if I select my profile in the profile selector box, up in the Reshade console window. If I do, Reshade simply do nothing, ignores the move.

Do you have some idea what is wrong ? Tx!
Last Edit: 4 months 1 week ago by Darkbluesky.
The administrator has disabled public write access.

ReShade 3 start with effects disabled 4 months 1 week ago #4

Yes, that's the intended effect. "NoReload" won't load the shaders as the name implies. You cannot currently start with effects loaded but disabled globally.
Cheers, crosire =)
The administrator has disabled public write access.

ReShade 3 start with effects disabled 4 months 1 week ago #5

And the over-bright effect...do you have some idea, or is also a foreseen consequence of the NoReload option? EDIT: this effect is like a copy of the screen but width-stretched and brighter, and put on top of the current screen...it is strange.

BTW, could it be done, that ReShade would load the shaders at game start but right after it finishes loading them, do not apply the shaders (or deactivate them)? Like if when it would finish to load the shaders I'd press the hotkey to disable them. This seems doable, I guess.
Last Edit: 4 months 1 week ago by Darkbluesky.
The administrator has disabled public write access.