Welcome, Guest.
Username: Password: Remember me

TOPIC: 4.3

4.3 5 months 2 weeks ago #61

@cunningStunts You need depth buffer access in order for SSDO to work.

reshade.me/forum/shader-discussion/4810-...s-in-displaydepth-fx
The topic has been locked.

4.3 5 months 1 week ago #62

Probably this is minor, but.
The topic has been locked.
The following user(s) said Thank You: crosire, seri14

4.3 5 months 1 week ago #63

ApxuBbI wrote:
Probably this is minor, but.

Thanks it works, but why mouse worked fine with all reshade version since 3.x and 4.2 and now it doesn't ?

How can I change the order of the shaders, I can't move them up or down which is a must.
Last Edit: 5 months 1 week ago by x8009.
The topic has been locked.

4.3 5 months 1 week ago #64

x8009 wrote:
How can I change the order of the shaders, I can't move them up or down which is a must.
You just click and drag them. You can also right-click and sort to top, and then drag to order, which makes it easier when managing large lists of shaders.
The topic has been locked.
The following user(s) said Thank You: moh111

4.3 5 months 1 week ago #65

Tried with SOFTR and got the crashes described above.

I could get the game running with Reshade on, first time I tried activating SMAA and the game froze, second time I tried Quint SSR and the game crashed.

Reshade doesn't seem to work with Dolphin anymore. Set to DX12 (or any other) reshade doesn't show up when you start the emulation.
The topic has been locked.

4.3 5 months 1 week ago #66

It seems that this update broke the interaction with Yamagi Quake 2 port (OpenGL).

Quakespasm, Reshade has invisible letters(OpenGL)
The topic has been locked.

4.3 5 months 1 week ago #67

Martigen wrote:
x8009 wrote:
How can I change the order of the shaders, I can't move them up or down which is a must.
You just click and drag them. You can also right-click and sort to top, and then drag to order, which makes it easier when managing large lists of shaders.
But I don't have a cursor, that's the issue... The game does not have a cursor at all or mouse support, it worked with all 3.x and 4.2.1 till now 4.3


Taken from the Reshade guide
Quote : - Unable to move mouse
Some games prevent free mouse movement by steadily resetting its position. You need to get something that lets you use your mouse first when in game, like opening an inventory or going into a pause menu, then you can open ReShade's interface.
Keep in mind that you can also use your keyboard to navigate through the interface.

Keyboard Controls:
Arrow keys: Move
Spacebar: Confirm
Esc button: Undo
Ctrl + Tab: Switch tabs

There is no way to move shaders with keyboard
Last Edit: 5 months 1 week ago by x8009.
The topic has been locked.

4.3 5 months 1 week ago #68

we need more like reflections and lens flare and dynamic lighting ...etc
The topic has been locked.

4.3 5 months 1 week ago #69

Strange issue with MXAO. If enabled in Divinity original Sin EE as the first shader it flickers like hell. If there is another shader on the first place it works but opening an inventory or another UI in game disables MXAO on specific camera angles. How to fix it pls?
Last Edit: 5 months 1 week ago by p6kocka.
The topic has been locked.

4.3 5 months 1 week ago #70

cunningStunts wrote:
Quick note - EasyAntiCheat has finally white flagged this update! Working in The Division 2, however I'm not entirely sure to tell how to see if the DX12 parts are working.

With DX12 rendering enabled in-game, PPFX Bloom and Godrays both work, but I cannot see any difference when toggling SSDO (but maybe that's intended? still kind of a nub to this stuff). Happy day.

same here. everything works perfectly (MXAO, DOF's) except the SSDO. In debug mode, only a gray screen is shown
Last Edit: 5 months 1 week ago by alien41.
The topic has been locked.

4.3 5 months 6 days ago #71

if it really works w/d3d12 - how can i donate u?
The topic has been locked.

4.3 5 months 6 days ago #72

dude my Reshade doesnt want to save preset, I always must start over, only I have this issue ?
The topic has been locked.

4.3 5 months 5 days ago #73

Hi guys, so im new to all this reshade thing :lol: and i didnt read the entire post but is SMAA still broken? i cant get it to work properly.

It apparently works, but in the moment i activate some lights in the game (American Truck Simulator) all the zone around those lights become completely jagged, even more than if SMAA wasnt activated at all lol. Its impossible to play in that state. Is this an issue of SMAA? i can use brute antialiasing from nvidia inspector and everything looks great, but of course i cant play at all due to low fps. So i was happy to find something like reshade.. until now. Any news on this?
The topic has been locked.

Windows 10 Version 1903 Update Broke ReShade 5 months 5 days ago #74

UPDATE: I tried installing ReShade DX9 instead of DX11 and now the Sims 4 works with ReShade. This is really weird because before I upgraded windows to 1903 ReShade was working just fine with DX11. It's really hard to know if this game uses DX9 or DX11 because RivaTuner overlay doesn't work in this game, and there's hardly any information if you do a google search either.

I updated last night to the latest 1903 update for Windows 10 and now ReShade is no longer working for The Sims 4. I've also done a google search and people are reporting ReShade also breaking in Metro Exodus, GTA V, as well as many other games. This is a serious issue that needs to be addressed because this big windows update is going to be rolled out to nearly everyone by the end of this month. @crosire any idea what may be causing this?

dxgi log file
21:10:17:958 [04400] | INFO  | Initializing crosire's ReShade version '4.3.0.563' (64-bit) built on '2019-05-25 19:00:11' loaded from "D:\GAMES\The Sims 4\Game\Bin\dxgi.dll" to "D:\GAMES\The Sims 4\Game\Bin\TS4_x64.exe" ...
21:10:18:034 [04400] | INFO  | Registering hooks for "user32.dll" ...
21:10:18:034 [04400] | INFO  | > Libraries loaded.
21:10:18:035 [04400] | INFO  | > Found 13 match(es). Installing ...
21:10:18:054 [04400] | INFO  | Registering hooks for "ws2_32.dll" ...
21:10:18:054 [04400] | INFO  | > Libraries loaded.
21:10:18:054 [04400] | INFO  | > Found 8 match(es). Installing ...
21:10:18:073 [04400] | INFO  | Registering hooks for "C:\WINDOWS\system32\d3d9.dll" ...
21:10:18:073 [04400] | INFO  | > Libraries loaded.
21:10:18:073 [04400] | INFO  | > Found 9 match(es). Installing ...
21:10:18:093 [04400] | INFO  | Registering hooks for "C:\WINDOWS\system32\d3d10.dll" ...
21:10:18:093 [04400] | INFO  | > Delayed.
21:10:18:093 [04400] | INFO  | Registering hooks for "C:\WINDOWS\system32\d3d10_1.dll" ...
21:10:18:093 [04400] | INFO  | > Delayed.
21:10:18:093 [04400] | INFO  | Registering hooks for "C:\WINDOWS\system32\d3d11.dll" ...
21:10:18:093 [04400] | INFO  | > Delayed.
21:10:18:093 [04400] | INFO  | Registering hooks for "C:\WINDOWS\system32\d3d12.dll" ...
21:10:18:093 [04400] | INFO  | > Delayed.
21:10:18:093 [04400] | INFO  | Registering hooks for "C:\WINDOWS\system32\dxgi.dll" ...
21:10:18:093 [04400] | INFO  | > Delayed until first call to an exported function.
21:10:18:093 [04400] | INFO  | Registering hooks for "C:\WINDOWS\system32\opengl32.dll" ...
21:10:18:093 [04400] | INFO  | > Libraries loaded.
21:10:18:093 [04400] | INFO  | > Found 360 match(es). Installing ...
21:10:18:118 [04400] | INFO  | Initialized.
21:10:18:118 [04400] | INFO  | Redirecting CreateDXGIFactory({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 000000000014E938) ...
21:10:18:118 [04400] | INFO  | > Passing on to CreateDXGIFactory1:
21:10:18:118 [04400] | INFO  | Redirecting CreateDXGIFactory1({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 000000000014E938) ...
21:10:18:118 [04400] | INFO  | Installing export hooks for "C:\WINDOWS\system32\dxgi.dll" ...
21:10:18:118 [04400] | INFO  | > Found 7 match(es). Installing ...
21:10:18:121 [04400] | INFO  | Exiting ...
21:10:18:121 [04400] | INFO  | Uninstalling 405 hook(s) ...
21:10:18:142 [04400] | INFO  | Exited.
Last Edit: 5 months 5 days ago by a1chera_.
The topic has been locked.
The following user(s) said Thank You: Ruslan2310, szanne7000

4.3 5 months 5 days ago #75

Well i discovered that it doesnt matter if i use FXAA or SMAA i get the same problem. So im thinking that its a problem of reshade itself? on the other hand, i tried other games and it is not happening.. so definitely it is the game. Probably. :unsure:
Last Edit: 5 months 5 days ago by n3mes1s.
The topic has been locked.

4.3 5 months 4 days ago #76

Hi, new forum member here.

First off, big thanks for including support for dx12, that's a huge deal.
I've been using Reshade (and previously SweetFX) for years, and it's become an absolute must for me.

Bug report:
Metro Exodus dx12, Windows 10 (1809), Geforce 2080ti (driver 430.86)
When turning on/off shader effects in the Reshade menu in Metro Exodus, or ticking on/off Performance mode - the entire game crashes. Otherwise things work fine afaik (only tested a few minutes of gameplay).

PS: Great to finally have Reshade in Metro Exodus. Thanks again for adding dx12 support (hopefully Vulkan support is also yet to come)! :)
Last Edit: 5 months 4 days ago by Carl_P.
The topic has been locked.
The following user(s) said Thank You: zero001

4.3 5 months 3 days ago #77

Quoting myself but yamagi answered about it and it because of SDL
github.com/yquake2/yquake2/issues/410
The topic has been locked.

Windows 10 Version 1903 Update Broke ReShade 5 months 1 day ago #78

Different versions of Windows 10 act differently with ReShade and ENB. I don't know why either.
The topic has been locked.

Windows 10 Version 1903 Update Broke ReShade 5 months 1 day ago #79

Underlying changes to the core of the OS is probably more extensive than what these feature highlights and blog announcements for builds like to showcase I would imagine though I don't know the in-depth changes from the Threshold to Redstone to the current 1903 and insider 20H1 builds much at all though there's been work on anything from DirectX to the kernel to security such as Defender and probably much much more as features are removed, replaced or updated and changed around with the occasional regression or bug.

Sometimes fixed in a later cumulative, sometimes fixed in a new build entirely.

From a comment about DXVK and hooking it seems ReShade has a thing about hooking it's own .DLL too in the initialization routine but that's something I don't understand very well either though it could act up with other proxy loaders although it's not Win10 related as such.
github.com/doitsujin/dxvk/issues/1057
(Though it got solved with this: github.com/doitsujin/dxvk/commit/8cae607...ecb9c53229581be78aba )

Don't know ENB very well either though, last I used it was for Skyrim almost a decade back now I think, nice to see Boris still keeping at it though if it's still around. :)
Last Edit: 5 months 1 day ago by JBeckman.
The topic has been locked.

4.3 4 months 2 weeks ago #80

Help please, when you start the game Rust with ReShade , a black screen appears and writes that the application is not responding. What to do?
The topic has been locked.