Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade 2.0.3f1 Performance (Assetto Corsa 1.5)

Reshade 2.0.3f1 Performance (Assetto Corsa 1.5) 7 months 2 weeks ago #1

Hello, :)
First of all thanks for the the update in Reshade Injector 2.0, it's Great !
I really appreciate your dedication and work on this.
Recently I started to tweak Reshade 2.0.3 with Assetto Corsa v1.5 and the game became to looks amazing, BUT i'm having significant FPS losses right now (about 40% in average), this is normal ?

a) Effects enabled:
[LUMASHARPEN]+[VIBRANCE] by Ceejay
[AMBIENT LIGHT]+[BLOOM]+[LENS DIRT] by Ganossa


b) Reshade Performance
Reshade disable: Average FPS : 90
Reshade enable: Average FSP : 50

#runing on DX11 (dxgi)
## Win 10 64 bits

I don't know how to configure the depth buffer to this game, neither if this game is now optimized to Reshade, please can you guys help me on this ?
Thanks again !
The administrator has disabled public write access.

Reshade 2.0.3f1 Performance (Assetto Corsa 1.5) 7 months 2 weeks ago #2

  • ShoterXX
  • ShoterXX's Avatar
  • Offline
  • Posts: 53
  • Thank you received: 9
You're probably running short of VRAM. What are your PC specs?
The administrator has disabled public write access.

Reshade 2.0.3f1 Performance (Assetto Corsa 1.5) 7 months 2 weeks ago #3

ShoterXX wrote:
You're probably running short of VRAM. What are your PC specs?

My specs are:
OS: Win 10 64
Graphics Card : AMD Radeon R9 390 (8Gb)
Processor: i7 2600k 3.4GHz
Ram: 8GB

# Assetto Corsa: running on 2560x1440 on high quality
Last Edit: 7 months 2 weeks ago by Moiker.
The administrator has disabled public write access.

Reshade 2.0.3f1 Performance (Assetto Corsa 1.5) 7 months 2 weeks ago #4

  • ShoterXX
  • ShoterXX's Avatar
  • Offline
  • Posts: 53
  • Thank you received: 9
Hmm, probably not VRAM then. Try turning Ambient Light off, and see if it gets better (by a large margin).
The administrator has disabled public write access.

Reshade 2.0.3f1 Performance (Assetto Corsa 1.5) 7 months 2 weeks ago #5

ShoterXX wrote:
Hmm, probably not VRAM then. Try turning Ambient Light off, and see if it gets better (by a large margin).

Yes, without Ambient Light have a better performance, up to 65 frames, but anyway still a significant drop.
do you know if this performances impact can be caused by the game optimization too or is just related to my hardware ?
Is there some alternatives in Reshade configurations to get a better performance ?

Thanks man
Last Edit: 7 months 2 weeks ago by Moiker.
The administrator has disabled public write access.

Reshade 2.0.3f1 Performance (Assetto Corsa 1.5) 7 months 2 weeks ago #6

  • ShoterXX
  • ShoterXX's Avatar
  • Offline
  • Posts: 53
  • Thank you received: 9
AFAIK, your PC specs should be fine(?). I have no experience with either AMD or Assetto Corsa, neither am I that tech-savy, so I can't say what the fault is either. I tried the Ambient Light because it's usually what hits my FPS most, but to be honest, it wasn't as bad as expected.

I poked around, and at that resolution, it seems the game requires around ~2.5 GB of VRAM @ Ultra 4xMSAA, so VRAM-wise, you should be safe.

However, always expect a large FPS percentage drop whatever your settings may be, even though it seems a bit too much in this case.
The administrator has disabled public write access.
The following user(s) said Thank You: Moiker