Welcome, Guest.
Username: Password: Remember me

TOPIC: [MXAO] Clipped blacks/no falloff PUBG

[MXAO] Clipped blacks/no falloff PUBG 9 months 3 weeks ago #1

I cant seem to figure out how I could fix this issue? Im trying to get MXAO to work in PUBG strictly offline and in replay mode, unfortunately something is bugging out the shader. I've gotten other depth-based effects to work and display depth looks ok to me. Any tips would be appreciated :)

Screenshots below with a few different settings and the depth buffer
https://imgur.com/a/yJGg3
Last Edit: 9 months 3 weeks ago by Vanishingpoint.
The administrator has disabled public write access.

[MXAO] Clipped blacks/no falloff PUBG 9 months 3 weeks ago #2

I know this issue exists, I have it on GTASA as well, but I have exactly 0 clue why it's happening and I get a feeling it is not 100% code related but a ReShade bug as it happens on a dramatically different AO version I developed as well. Maybe crosire could chime in... what I know about it:

-happens with all MXAO versions
-did not happen on W7 for me on GTASA, on W10 it does
-seems to happen after AO pass, as the output of the AO pass is totally fine.
-to debug, I replaced all consecutive passes after AO pass with a dummy pass that only reads backbuffer and writes to it again. Bug is present there as well. So AO pass writes to backbuffer: ok. Pass after that, which only reads and writes to backbuffer: bug shows up.
-values are rounded to 0, 0.5 or 1.0.

Sorry to be not more helpful but I have no clue what's happening and why it's happening. I tried literally everything in code but was forced to switch to Witcher 3 as development sandbox because I couldn't resolve it on GTASA, hoping no one would have this bug.
Last Edit: 9 months 3 weeks ago by Marty McFly.
The administrator has disabled public write access.

[MXAO] Clipped blacks/no falloff PUBG 9 months 3 weeks ago #3

Ahhh no problem. I've noticed that the indirect illumination works I believe as intended. Perhaps there could be some workaround by inverting the matte for now or if this just helps you isolate the bug in general. For now thanks for all your great work :)

The administrator has disabled public write access.