Welcome, Guest.
Username: Password: Remember me

TOPIC: Relative paths

Relative paths 2 months 3 weeks ago #1

Hi,

there's some posts here that gives some info about the problem. Unfortunately i didn't find a working solution so i decided to open a new topic. I apologize if i did something wrong.

I'd like to apply my personal shader/texture settings using relative paths, without editing them everytime i switch to a different game.

I've tried to edit Effectsearchpaths Texturesearchpaths Screenshotpath Presetfiles parameters by using .\ command (or "=.\reshade-shaders\shaders" for example), and then apply them to Reshade D3d9 Dxgi Opengl32 ini files, with no result. Where am i doing wrong?
Last Edit: 2 months 2 weeks ago by Lenz.
The administrator has disabled public write access.

Relative paths 2 weeks 5 days ago #2

This should work fine. I can load effects with a relative path like your example in the latest version.
Cheers, crosire =)
The administrator has disabled public write access.

Relative paths 1 week 5 days ago #3

I have the same issue than Lenz here. Relative path won't work with DX10 or DX11 games (when I use dxgi.dll).

But it works fine with DX9 (d3d9.dll).
This work for exemple :
EffectSearchPaths=.\reshade-shaders\Shaders
TextureSearchPaths=.\reshade-shaders\Textures

Maybe "dxgi.dll" is working differently than "d3d9.dll" when it comes to relative path ?
Or could there be another reason for that ?
Last Edit: 1 week 5 days ago by Lemmi.
The administrator has disabled public write access.

Relative paths 1 week 4 days ago #4

Nevermind, I tested with other DX10 or DX11 game and it works sometimes.
So far "the Witcher 3" or "Prey (2017)" don't work with relative path. I can't really figure out why...

If someone have any idea or can make it work, let us know :)
The administrator has disabled public write access.

Relative paths 1 week 1 day ago #5

Ok, I figured it out !

Using the method Lenz talked about will work most of the time when you put the reshade files in the same folder than the .exe of the game.

But, in some cases, the origin folder for reshade, let's call it the "Hook folder", is not the same as the .exe.
Sometime it's from the same folder as the reshade dll. And sometime, it's neither !!

For exemple, in The Witcher 3, even if the game .exe, the reshade.dll (dxgi.dll in this case) and reshade.ini are in the same folder (The Witcher 3\bin\x64), it's not the "hook folder" for reshade.

So using this, doesn't work
.\reshade-shaders\Textures

The "hook folder" is the parent folder, so this works :
.\x64\reshade-shaders\Textures

I guess there a bit a trial and error. You have to work your way up (or down) the folders until it works.

Here is another exemple for Prey :
.\Binaries\Danielle\x64\Release\reshade-shaders\Textures
Last Edit: 1 week 1 day ago by Lemmi.
The administrator has disabled public write access.

Relative paths 1 week 1 day ago #6

That is the game changing the working directory to something other then the executable directory. In theory ReShade should ignore that, but looks like there is a bug somewhere that causes that to not work.
Cheers, crosire =)
The administrator has disabled public write access.