Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade with Fullscreen Optimization Disabled

Reshade with Fullscreen Optimization Disabled 2 weeks 4 hours ago #1

Now I know something's wrong with the latest version of Windows 10 that make's reshade incompatible with Fullscreen optimizations disabled and you might wonder why do I want to even disable FS Optimization. Well the answer is Scanline Sync. This new syncing method allows users to get adaptive vsync experience without the input lag of adaptive vsync.

Unfortunately, if Fullscreen Optimization is enabled, then scanline Vsync doesn't work with downsampled resolutions. Infact, Vsync off doesn't work at all. Windows 10's DWM takes over and prevents screen tearing on games but unlike regular Vsync, windows 10's DWM works like Open Gl's Triple Buffer/ Nvidia's Fast sync but adds severe input lag [Which makes it worthless]. Also, since it doesn't work like regular Vsync, the frame times aren't synchronized and results in microstutters/ skipping and stutters just like Fast sync. It is possible to at least prevent the stutters by enabling Vsync and using FPS limiter to even out the frame times. But it defeats the purpose of scanline sync.


So far, the only way to use Scanline Vsync/ Adaptive Vsync on Fullscreen with downsampled resolutions is by disabling FS Optimization but that means Reshade can't be used. However, Nvidia DSR doesn't suffer from this issue. But downsampling using custom resolution is a lot better since the filtering method by DSR is garbage and only looks okay on 4x multiples of the native resolutions.

I don't know if it can be fixed, hopefully it won't be that hard. Then again, it's windows 10's and Nvidia's fault for not fixing their shit. I've already posted about these issues on Geforce forums but like always, Nvidia won't be bothered to fix anything. I will post more info if I figure out anything.
The administrator has disabled public write access.

Reshade with Fullscreen Optimization Disabled 1 week 6 days ago #2

Reshade works with FSO disabled. All my games are FSO disabled -- have to, I use SLI :)

What makes you think it doesn't? What games are you having a problem with?

Edit: I'm on 1803 fwiw, and you say 'latest version of Windows 10' are you on 1809?
The administrator has disabled public write access.

Reshade with Fullscreen Optimization Disabled 1 week 3 days ago #3

Martigen wrote:
What makes you think it doesn't? What games are you having a problem with?

What makes me think? You are saying that I just think it doesn't work without actually trying it?



Let me see what didn't run:

-House of Dead 3
-FiFA 10
-FiFA 09
-Sega Model 2 emulator
-kega Fusion
-FiFA 15


Basically anything I try. The games wont even start.
The administrator has disabled public write access.

Reshade with Fullscreen Optimization Disabled 1 week 3 days ago #4

What makes me think? You are saying that I just think it doesn't work without actually trying it?
Dude... drop the snark. There's no need for that.

Logic should tell you the problem is on your end if you're BOTH on 1803 and you're having issues and he isn't.
Last Edit: 1 week 3 days ago by TreyM.
The administrator has disabled public write access.

Reshade with Fullscreen Optimization Disabled 1 week 2 days ago #5

TreyM wrote:
What makes me think? You are saying that I just think it doesn't work without actually trying it?
Dude... drop the snark. There's no need for that.

Logic should tell you the problem is on your end if you're BOTH on 1803 and you're having issues and he isn't.

FS Optimization issue isn't only affecting me. I've seen it on other threads [Example: reshade.me/forum/troubleshooting/4574-cr...aunch-with-dx9-games]
The administrator has disabled public write access.