Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Deponia 2 fail

Deponia 2 fail 1 year 3 months ago #1

Deponia 2 is not working with the error in the log
Your graphics card does not seem to support OpenGL 4.3. Initialization failed.

However Deponia 1 is working perfectly!

I've tried all recent versions of the moderator/reshade/sweetFX on the exact same system, The exact same system (Win8.1 64 bit) and latest NVIDIA drivers.
Deponia 1 always works and Deponia 2 always fails. Why?
The administrator has disabled public write access.

Deponia 2 fail 1 year 3 months ago #2

Adding more details, I've tried Deponia 2 with:
1. ReShade Framework 1.0.0
2. ReShade 0.19.2 Public Beta with SweetFX 2.0 Beta 8
3. ReShade 0.19.1 Public Beta

It didn't work with any of them while Deponia 1 works with all of them.
It's very strange because Deponia 2 and Deponia 1 are basically the exact same game using the same engine.

Help please ? :)
The administrator has disabled public write access.

Deponia 2 fail 1 year 3 months ago #3

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2451
  • Thank you received: 1390
What GPU you have and which driver version? Is it a multi-GPU system (like a laptop, with both an onboard Intel and a NVIDIA/AMD card)?
Cheers, crosire =)
The administrator has disabled public write access.

Deponia 2 fail 1 year 3 months ago #4

Yes it is!
I don't have the exact specs now coz I am not at home, but the GPU is an Nvidia gtx760m and the onboard is an Intel (don't remember the spec now).

Are you thinking that Deponia 1 is running with the GPU while Deponia 2 is running with the onboard intel one?
That would be strange since both games are practically identical, but it's possible.
I will check when I get home.

I can also get the driver versions for you later.

Any other ideas of what I could try?
The administrator has disabled public write access.

Deponia 2 fail 1 year 3 months ago #5

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2451
  • Thank you received: 1390
shadilahham wrote:
Are you thinking that Deponia 1 is running with the GPU while Deponia 2 is running with the onboard intel one?
That would be strange since both games are practically identical, but it's possible.
Yes. Because most onboard Intel cards don't have support for the more recent OpenGL features (which is why you get that error). The NVIDIA control panel has an option to force the NVIDIA GPU for specific games. Try that.
Cheers, crosire =)
The administrator has disabled public write access.

Deponia 2 fail 1 year 3 months ago #6

crosire wrote:
shadilahham wrote:
Are you thinking that Deponia 1 is running with the GPU while Deponia 2 is running with the onboard intel one?
That would be strange since both games are practically identical, but it's possible.
Yes. Because most onboard Intel cards don't have support for the more recent OpenGL features (which is why you get that error). The NVIDIA control panel has an option to force the NVIDIA GPU for specific games. Try that.

Yes that was the reason. Thanks!
It's kinda strange that NVidia control panel decided that Deponia 1 needs a powerful GPU while Deponia 2 can run on the onboard one, but good to know for future reference.

Now I know to better check my settings before bothering the forum, but maybe my experience will be useful for other people.

Thanks again for the quick reply and help :)
The administrator has disabled public write access.