Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED]Guild Wars 2 CRASH with reshade

[SOLVED]Guild Wars 2 CRASH with reshade 1 year 2 months ago #1

Hi, i have been trying to install reshader for my guild wars 2, i install everything correctly but yet my guildwars crashes. the d3d9.dll 32-bit is what is causing the crash. i have tried the 64 bit and the 32 bit for directx9 and 10 and my game will run with every other variation but reshade wont run. i know i am installing it correctly because i did it on my laptop and it worked no problems 1st try.
any help please??? im desperate here, ive uninstalled the game in 2 differnt hard drives and its the same issue. im reinstalling it now on my ssd as my final test since there is literally nothing else i know of that i can do. HELP!
Last Edit: 1 year 2 months ago by themrtaco.
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #2

  • JBeckman
  • JBeckman's Avatar
  • Online
  • Posts: 162
  • Thank you received: 36
What version of ReShade, I'm using it currently and it's working fine here.
(Was using GeDoSaTo since it's a D3D9 game and it's 32-bit too but it causes some minor issues to the UI.)

Could be that you placed the files in the wrong location too.

You place the ReShade files here where the CoherentUI_Host.exe file is:
C:\Games\Guild Wars 2\bin

And not here, this won't work even though this is where GW2.exe is located:
C:\Games\Guild Wars 2\
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #3

1.0.0.7z
and yes i put the game in the right place, as i said i did it on my laptop as well to make sure i was doing it right and it worked on my laptop. i dont know what else to do for my pc
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2438
  • Thank you received: 1385
Disable any sort of game overlays, game boosters, screen recording, streaming or similar software.
Cheers, crosire =)
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #5

I did. Nothing else was running.
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #6

alright update..i tried it on the SSD, at first it wasnt crashing but then it kept doing the same old thing. i tried having the 32 bit file in both dx9 and dx10 and even tried them together but no results. my game just keeps crashing. i could copy the error results anet gives me if you would like. i cant think of any other thing i can try.
i tested it out on my WD caviar black, WD caviar green, and my SSD(forgot what brand it was.) anyway, like i said im out of ideas. my laptop still runs it fine and it uses windows 10 and everything pretty much the same as my desktop so yea i dont know
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #7

i did JB, i placed it in the bin file, i even tried on the regular folder where the .exe is just in case but yes, i tired it
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #8

  • Apocalypso
  • Apocalypso's Avatar
  • Offline
  • Posts: 28
  • Thank you received: 23
Gw2's dx9 32 bit, so use the right files. You may be using some of the Razer hardware with that software (Synapse) that conflicts with Reshade. The game itself doesn't have any conflict with Reshade, it should work perfectly.
The administrator has disabled public write access.
The following user(s) said Thank You: themrtaco

Guild Wars 2 CRASH with reshade 1 year 2 months ago #9

thank you, thats what it was, for some reason synapse effects my desktop but not my laptop. thats what it was. thank you for the help!
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #10

  • JBeckman
  • JBeckman's Avatar
  • Online
  • Posts: 162
  • Thank you received: 36
themrtaco wrote:
thank you, thats what it was, for some reason synapse effects my desktop but not my laptop. thats what it was. thank you for the help!

I'm not sure what Synapse is but I assume it's some type of overlay then? (Razer Synapse? Some driver software for e.g keyboards/mice?) I'm pretty sure it's been mentioned in a few threads with similar compatibility issues where turning it off resolved the problem though I wonder what the core problem with it and ReShade is, if it was something like a overlay such as Fraps or Afterburner wouldn't it be compatible with ReShade? (It definitively shouldn't cause the application to crash though it might interfere with ReShade hooking into the game and thus it might not activate but as I said I'm unsure what Synapse is so I could be completely wrong on how it might work.)

EDIT: Could it be that?
reshade.me/forum/troubleshooting/886-sol...etfx-2-0-beta-8#7185
(Running some additional processes in the background even if you might not have used said features of the software so it causes conflicts with other software?)
Last Edit: 1 year 2 months ago by JBeckman.
The administrator has disabled public write access.

Guild Wars 2 CRASH with reshade 1 year 2 months ago #11

synapse is razr's program to edit settings and keybinds and macros, ect. for their keyboard and mice and such. im not sure what exactly it was about it that broke it but yea. i closed it and unplugged my house and just used my corsair mouse (i only use my razr one for this game since it has buttons on side for binds) and it ran perfectly, then i started up synapse again and its worked everytime at start up. i guess something about synapse messed it up when youre starting it for the 1st time. im not sure if this answered your question but yea.
The administrator has disabled public write access.