[SOLVED] Star Wars: Republic Commando crashes on level load

  • Posts: 25
5 years 6 months ago #1 by Koklusz
Hi.

When I try ReShade (no matter which version, including 0.13) game crashes when starting/loading level.

Here's the log from ReShade:

pastebin.com/BCV0tpKD

Here's crashdump file:

www.dropbox.com/s/w2uzxbvhmpc7ah6/SWRepu...do.exe.4928.dmp?dl=0

Please Log in or Create an account to join the conversation.

  • Posts: 3751
5 years 6 months ago #2 by crosire
Indeed, I can reproduce that with the game demo. D3D8 to D3D9 shader conversion doesn't work so well there, I'll investigate that. Thanks for reporting =)

Please Log in or Create an account to join the conversation.

  • Posts: 3751
5 years 6 months ago #3 by crosire
Fixing the game shader manually solves the crash, game loads fine then. Now I need to find a good way to do that on a generic level without breaking other games.
The following user(s) said Thank You: Koklusz

Please Log in or Create an account to join the conversation.

  • Posts: 25
5 years 6 months ago - 5 years 6 months ago #4 by Koklusz
I'm not sure if latest version was suppose to fix shader conversion for RC, but now game crashes right after ReShade is loaded. Here's the log

Please Log in or Create an account to join the conversation.

  • Posts: 3751
5 years 6 months ago - 5 years 6 months ago #5 by crosire
It was, but I accidently broke it at another point. Found and fixed, should be finally settled with the next version. =)
The following user(s) said Thank You: Koklusz

Please Log in or Create an account to join the conversation.

  • Posts: 25
5 years 6 months ago - 5 years 6 months ago #6 by Koklusz
Latest version works, aside from depthbuffer, so no AO or DOF :( . Thank you for help Crosire, guess you can close this topic now.

Please Log in or Create an account to join the conversation.