Welcome, Guest.
Username: Password: Remember me

TOPIC: [solved] Mediator issues with Win10?

[solved] Mediator issues with Win10? 1 year 10 months ago #1

  • LasseB
  • LasseB's Avatar
  • Offline
  • Posts: 10
  • Thank you received: 1
Every time I try to run the Mediator while on Win10, it crashes ("Mediator has stopped working") just after having created a profile when setting up a new game on a "fresh unzip" of the whole ReShade 1.0 package. Also, it crashes immediately on startup when it seemingly loads a profile I carried over from Win8.1. Needless to say the Mediator works without a hitch on Win8.1.

Any ideas on what's up with this? Anything I can do to fix it or help tracking down the cause for the crashes?

Btw, here's the log file entry from Windows:

Fault bucket , type 0
Event Name: BEX
Response: Not available
Cab Id: 0

Problem signature:
P1: Mediator.exe
P2: 1.0.0.0
P3: 55c8a895
P4: StackHash_9788
P5: 0.0.0.0
P6: 00000000
P7: PCH_7A_FROM_wpfgfx_v0400+0x0005F8CA
P8: c0000005
P9: 00000008
P10:

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_Mediator.exe_34a3558f60c65f857af3baf813f12f7bd069f557_c0bfcdf6_152a48d8

Analysis symbol:
Rechecking for solution: 0
Report Id: 0c02da43-450f-4db5-a07e-79934c9f9108
Report Status: 100
Hashed bucket:
Last Edit: 1 year 10 months ago by LasseB. Reason: found the issue
The administrator has disabled public write access.

Mediator issues with Win10? 1 year 10 months ago #2

  • Ganossa
  • Ganossa's Avatar
  • Offline
  • 최정장군
  • Posts: 790
  • Thank you received: 840
We are planning to release the new ReShade version together with mediator updates very shortly and I would ask you to wait until then and if possible give another feedback at that time :) I too have an alternative w10 installation, so I am sure we can find the cause for that problem in case it still comes up.
The administrator has disabled public write access.

Mediator issues with Win10? 1 year 10 months ago #3

  • LasseB
  • LasseB's Avatar
  • Offline
  • Posts: 10
  • Thank you received: 1
The new mediator still crashes for me, right after it says "Application preset files have been created" in the status section.

PS:
I'm getting two error messages in Windows Logs, one saying "Exception code: 0xc0000409" and the other saying "Exception code: 0xc0000005". While the latter indicates that mediator.exe tried accessing a portion of the RAM that it's not supposed to, the former indicates a buffer overflow. When I went looking whether or not mediator.exe was trying to access something I haven't (yet) installed, Process Monitor showed lots of buffer overflow entries near the end of the log.
Last Edit: 1 year 10 months ago by LasseB.
The administrator has disabled public write access.

Mediator issues with Win10? 1 year 10 months ago #4

  • LasseB
  • LasseB's Avatar
  • Offline
  • Posts: 10
  • Thank you received: 1
Bumping with an update, in case someone else has run into similar problems:

Turned out that the cause for the Mediator.exe crashes was RivaTuner Statistics Server. After I made a profile in RTSS for the mediator.exe and set "Application detection level" to "None" everything works decently again.
The administrator has disabled public write access.