Fallout 4 + ReShade = Crash

  • Posts: 4
4 years 1 month ago #21 by dwelsh99

Black_Viper wrote: Hmm i still can't seem to pass the redirecting D3D11CreateDeviceAndSwapChain, it always stops here then freezes me when i switch back to the game everytime.


I am also having this issue, made a post last night about it here in these forums.

I read 'kyd462' fix, but I do not have a "PrecisionXServerHooks_x64.dll" file on my system.

Please Log in or Create an account to join the conversation.

  • Posts: 1
4 years 1 month ago - 4 years 1 month ago #22 by wkduffy
Sorry if I'm a bit late on this, but thought I'd add in: Exact same issue here as described by everyone else in this thread. But I fixed it, for me anyway:

After immediate crashes, I found in the dxgi.log (in the Fallout game directory) an error that in effect said: Reshade was expecting 1 instance of the dll but found 2.

I then read this same issue was happening with The Witcher using Reshade, and the fix in some instances was to actually delete d3d11.dll in the game's directory, because it already (also) contains dxgi.dll--and these two files are essentially the same thing (or at least that's what I've come to assume?). After deleting d3d11.dll (and leaving dxgi.dll alone), Reshade compiled everything fine (or at least that's what the message says) and game ran correctly. I'm not sure if having both d3d11.dll and dxgi.dll in the folder was a fault of mine--or if actually both are needed and I'm not actually using Reshade (although the compile message runs at game's startup, so...). Anyway, there you have something.

Please Log in or Create an account to join the conversation.

  • Posts: 1
4 years 1 week ago #23 by Dmendez
Hi, I am Relatively new to modding. so I start up Fallout 4 with the configuration tool and the opening please stand by slide shows for a few seconds and then the application closes, your name and this website were on here and I was wondering if you could help. this was after installing reshade and mediator and sweet fx, and cinematic excellence. I searched everything titled reshade and mediator, etch and deleted them in hopes to bring the game to it's previous state but so far no luck

Please Log in or Create an account to join the conversation.

  • Posts: 133
4 years 1 week ago #24 by SpinelessJelly
@Dmendez: The mediator has installed one of reshade's .dlls in your game's folder and renamed it either d3d9.dll or dxgi.dll (or, rarely, d3d11.dll), you need to remove that too.

Please Log in or Create an account to join the conversation.

  • Posts: 2
3 years 11 months ago - 3 years 11 months ago #25 by turkoid
Hi,

I'm at a complete loss. I recently did a fresh install of win10 pro. Before the refresh I was happily playing fallout 4 with this preset: Enhanced Wasteland Preset . At the time i was using the 2.0 (fine text) version. Now when I try to start Fallout 4, i see the watermark in the top left, but it just stalls, doesn't crash (longest I left it going was overnight).

I've tried all the steps, that I could listed in this post. (DirectX runtimes, disabling MSI afterburner, actually uninstalling it, made sure shadowplay wasn't running, closed dxtory, disable the steam overlay, made sure i wasn't running Steam Beta.) I should note that before the windows refresh, i was successfully running MSI afternburner, shadowplay, and the steam overlay with the preset. Dxtory would actually crash the game, which was fine.

I also attempted to rename the dll to d3d11.dll . I tried the 3.0 preset for the same link as above, and got the same stalling.

Here is my dxgi.log:
Warning: Spoiler! [ Click to expand ]


Here is the tracelog (i truncated this one, there were no ERRORS, or WARNs:
Warning: Spoiler! [ Click to expand ]


I did attempt to use Reshade 2.0 with just the default preset. This loaded just fine. So I either have to wait till the original author updates his files to be 2.0 compatible, or I would appreciate a location where I can read up on migrating 1.1 presets to 2.0. I saw there was some kind of import tool in the Assistant, but the instructions aren't very clear.

Better yet, If someone knows why it's just stuck on "Loading effect" or "Running preprocessor", that would be great.

Thanks!

Please Log in or Create an account to join the conversation.

  • Posts: 3
3 years 9 months ago - 3 years 9 months ago #26 by kkthebeast
I load use the older version of Reshade with GREAT results with FO4, aka SweetFX 2.0 (ReShade+1.1.0+with+SweetFX+2.0.7)
Rename the dll dxgi.dll (IF using it in tandem with ENB) ELSE rename the dll d3d11.dll
ENBseries v0.293 running in Enboost mode only
enblocal.ini
[GLOBAL]
ApplyStabilityPatch=true
UsePatchSpeedhackWithoutGraphics=true
using d3d11.dll

also this older version works with shadow boost (if you're in to that)

Note: I use AMD 7970m CF (AMD's SLI) and had to "downgrade" to the current Official release of the driver. 16.3.2 Windows 10 x64. the newest beta 16.4.2 CTDs FO4 on game load, where as 16.4.1 worked perfectly. So for you nVidia guys, Try an older version of the driver as well if you are having CTDs. Sometimes when the fix something for one game, the inadvertently break something in another game. Go figure.

lastly using d3d9.dll won't work, as this is a DX11 game. and only looks for and load the DX11 related files. =)

I hope this info is on point and finds you well. If it doesn't help my apologies.

Please Log in or Create an account to join the conversation.

  • Posts: 1
3 years 8 months ago #27 by Daniell
Hi,

I am having the same issue as everyone else regarding the CTD from the Bethesda Logo screen (Fallout 4).
I have read the thread, as well as, any other fixes via the FalloutNexus thread (I am using the 'Enhanced Wasteland Preset' ), but to no avail. Any suggestions are greatly appreciated..

Please Log in or Create an account to join the conversation.

  • Posts: 1
3 years 8 months ago #28 by Battlestar1965
Hi,

i am guessing you are using "Shadow Boost". Turns out Reshade 2.0 and Shadow Boost don't play nice with each other. Try disabeling "Shadow Boost" and The "Enhanced Wasteland Preset 4.0" should work, even with F4SE. That, at least, was my experience.

Please Log in or Create an account to join the conversation.

  • Posts: 1
3 years 5 months ago #29 by dragonballz4
Hey can you help me what up with this orange tint did i do something wrong?

imgur.com/a/iYebD

Please Log in or Create an account to join the conversation.

  • Posts: 1
3 years 5 months ago - 3 years 5 months ago #30 by ohblaargag
I am trying to run Clean Light ENB for Fallout 4 which combines ENB and Reshade. Whenever I boot up Fallout 4 it just crashes to desktop. I have done the following but to no avail:

-Rename the Reshade64.dll file to dxgi.dll
-Set the following in my enblocal.ini file:

[PROXY]
EnableProxyLibrary=true
InitProxyFunctions=false
ProxyLibrary=dxgi.dll

-Downloaded the DirectX Runtime 2010 files

I will be thankful to anyone who can provide me a working solution to this problem.

P.S. I am running Windows 10 on my PC. Also if you need it to help troubleshoot the problem here's what the dxgi.log file says:

10/09/2016 17:10:26:484 [00260] | INFO | Initializing crosire's ReShade version '3.0.0.91' (64-bit) built on '2016-09-07 23:48:56' loaded from 'C:\Program Files (x86)\Steam\steamapps\common\Fallout 4\dxgi.dll' to 'C:\Program Files (x86)\Steam\steamapps\common\Fallout 4\Fallout4.exe' ...
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\d3d8.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\d3d9.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\d3d10.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\d3d10_1.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\d3d11.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\d3d12.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\dxgi.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\opengl32.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\vulkan-1.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Delayed.
10/09/2016 17:10:26:547 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\user32.dll' ...
10/09/2016 17:10:26:547 [00260] | INFO | > Libraries loaded.
10/09/2016 17:10:26:547 [00260] | INFO | > Found 11 match(es). Installing ...
10/09/2016 17:10:26:719 [00260] | INFO | > Installed 11 hook(s).
10/09/2016 17:10:26:719 [00260] | INFO | Registering hooks for 'C:\WINDOWS\system32\ws2_32.dll' ...
10/09/2016 17:10:26:719 [00260] | INFO | > Libraries loaded.
10/09/2016 17:10:26:719 [00260] | INFO | > Found 8 match(es). Installing ...
10/09/2016 17:10:26:828 [00260] | INFO | > Installed 8 hook(s).
10/09/2016 17:10:26:828 [00260] | INFO | Initialized.
10/09/2016 17:10:28:484 [00260] | INFO | Installing delayed hooks for 'C:\WINDOWS\system32\dxgi.dll' ...
10/09/2016 17:10:28:484 [00260] | INFO | > Found 7 match(es). Installing ...
10/09/2016 17:10:28:484 [00260] | INFO | > Installed 7 hook(s).
10/09/2016 17:10:30:344 [00260] | INFO | Redirecting 'RegisterClassA(0000006A3E2FF450)' ...
10/09/2016 17:10:30:344 [00260] | INFO | > Adding 'CS_OWNDC' window class style flag to 'Fallout4'.
10/09/2016 17:10:30:344 [00260] | INFO | Redirecting 'RegisterRawInputDevices(0000006A3E2FE870, 2, 16)' ...
10/09/2016 17:10:30:359 [00260] | INFO | Redirecting 'CreateDXGIFactory({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 0000006A3E2FF230)' ...
10/09/2016 17:10:30:375 [00260] | INFO | Installing delayed hooks for 'C:\WINDOWS\system32\d3d11.dll' (Just loaded via 'LoadLibraryA("C:\WINDOWS\system32\d3d11.dll")') ...
10/09/2016 17:10:30:375 [00260] | INFO | > Found 2 match(es). Installing ...
10/09/2016 17:10:30:422 [00260] | INFO | > Installed 2 hook(s).
10/09/2016 17:10:30:422 [00260] | INFO | Redirecting 'D3D11CreateDeviceAndSwapChain(00000194DB007730, 0, 0000000000000000, 0x20, 0000000000000000, 0, 7, 0000006A3E2FF260, 00007FF607B8C000, 00007FF607B8BFD8, 0000006A3E2FF478, 00007FF607B8BFE0)' ...
10/09/2016 17:10:30:453 [00260] | INFO | Redirecting 'IDXGIFactory::CreateSwapChain(00000194DB007550, 00000194DAC3E770, 0000006A3E2FF260, 00007FF607B8C000)' ...
10/09/2016 17:10:30:453 [00260] | INFO | Starting input capture for window 0000000000780352 ...
10/09/2016 17:10:30:469 [00260] | INFO | Recreated runtime environment on runtime 00000195BEF5F710.
10/09/2016 17:10:30:469 [00260] | INFO | Compiling effect files ...
10/09/2016 17:10:34:875 [00260] | INFO | Redirecting 'IDXGISwapChain::SetFullscreenState(00000194DAC412E0, TRUE, 0000000000000000)' ...
10/09/2016 17:10:34:875 [00260] | INFO | Redirecting 'D3D11CreateDevice(00000195D70D3860, 0, 0000000000000000, 0xa0, 0000006A3E2FEDB0, 1, 7, 0000006A3E2FED60, 0000000000000000, 0000000000000000)' ...
10/09/2016 17:10:34:875 [00260] | INFO | > Passing on to 'D3D11CreateDeviceAndSwapChain':
10/09/2016 17:10:34:875 [00260] | INFO | Redirecting 'D3D11CreateDeviceAndSwapChain(00000195D70D3860, 0, 0000000000000000, 0xa0, 0000006A3E2FEDB0, 1, 7, 0000000000000000, 0000000000000000, 0000006A3E2FED60, 0000000000000000, 0000000000000000)' ...

Please Log in or Create an account to join the conversation.