Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] RaiderZ, how do I hook the game not the launcher?

RaiderZ, how do I hook the game not the launcher? 2 years 7 months ago #1

Essentially reshade hooks onto launcher EXE and not the game itself

Game is DX10/11 @ x86, setup reshade, game shows hook intro dialog when opening launcher -- then launch game and there is nothing

Two exes
Raiderz Launcher.exe
Raiderz.exe

Is there a way to delay the hook for the second EXE?
The administrator has disabled public write access.

RaiderZ, how do I hook the game not the launcher? 2 years 7 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2782
  • Thank you received: 1584
ReShade should hook both as long as both load it. It may fail to write that to the log because the launcher opened the log file first and is now blocking access from the game executable. Do other injectors (i.e. InjectSMAA) work? MMORPGs tend to have heavy protections again those.
Cheers, crosire =)
Last Edit: 2 years 7 months ago by crosire.
The administrator has disabled public write access.

RaiderZ, how do I hook the game not the launcher? 2 years 7 months ago #3

  • JPulowski
  • JPulowski's Avatar
  • Offline
  • Posts: 95
  • Thank you received: 87
You might want to give ENB injector a try. I already explained how here. Just make sure dll's name stays the same as the original (ReShade32.dll). Otherwise it will load automatically every time, regardless of if the injector is working or not.
The administrator has disabled public write access.

RaiderZ, how do I hook the game not the launcher? 2 years 7 months ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2782
  • Thank you received: 1584
Tried myself and the problem is that the game isn't actually using D3D11, it's using D3D9, which is why the game never loads "dxgi.dll" (the launcher does, but for different reasons). Rename ReShade to "d3d9.dll" and you are good to go =)
Cheers, crosire =)
Last Edit: 2 years 7 months ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: strelokgunslinger