Welcome, Guest.
Username: Password: Remember me

TOPIC: FSX stoped responding when entering fullscreen

FSX stoped responding when entering fullscreen 4 months 6 days ago #1

First thanks for this amazing tool. I've seen a lot of videos using the Sweetfx, and it looks absolute amazing.

But sadly after I tried it myself, it doesn't work. Every time I enter the FSX steam version under Windows 10, the welcome window shows as normal. I can also see the ReShade information on the corner of my "preview" window under "free flight".

When I click the Fly Now button, the window goes off and the game stops responding.

I've tried this for days without luck. Finally I figured out what i did that causes the problem. I guess this happened because the switching of game windows, or the fullscreen mode.

I've fully closed steam overlay, and no recording software in the background only Nvidia Experience.

Here is my dxgi.log . Again, Thanks a lot!!!
Warning: Spoiler! [ Click to expand ]
Last Edit: 4 months 6 days ago by Deserts.
The administrator has disabled public write access.

FSX stoped responding when entering fullscreen 4 months 6 days ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2438
  • Thank you received: 1385
Try replacing the ReShade 1.1 binary (installed as dxgi.dll) with the one from 2.0.

EDIT: I updated the SweetFX package to use ReShade 2.0.3 instead of the outdated 1.1: reshade.me/sweetfx
Cheers, crosire =)
Last Edit: 4 months 6 days ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: Deserts

FSX stoped responding when entering fullscreen 4 months 6 days ago #3

Thanks for your help.

I've tried, but sadly still no luck :(

Here is the log file:

Warning: Spoiler! [ Click to expand ]


I've also tried to copy the ReShade32.dll (from 2.0.3) into SweetFx install folder and replace. Installed and still not working. :(
Last Edit: 4 months 6 days ago by Deserts.
The administrator has disabled public write access.

FSX stoped responding when entering fullscreen 4 months 6 days ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2438
  • Thank you received: 1385
Is the game running in Dx9 or Dx10 mode? If the latter, try the former.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Deserts

FSX stoped responding when entering fullscreen 4 months 6 days ago #5

Thanks for your help.

Unfortunately, still not working, only this time it froze at very beginning.

tried:
1. choose FSX setting to DX9, then reinstalled SweetFx with ReShade 1.1.0 using DX9 Mode. no luck
2. Replaced d3d9.dll with the one from 2.0.3, still no luck

here is the log file:
Warning: Spoiler! [ Click to expand ]
The administrator has disabled public write access.

FSX stoped responding when entering fullscreen 4 months 6 days ago #6

After several attempts, I guess the problem is about fullscreen or overlays.

I tried once without opening the free flight menu ( so that there is no little "preview" window) and directly went into the gameplay in window mode, it opened normally with ReShade Information on the corner. But when i opened up the Knee board in game, the information went into the knee board window, then i clicked the gameplay it froze.

So I guess the problem only shows if I start or switch to an other game window. I hope this can help. :P
The administrator has disabled public write access.