Welcome, Guest.
Username: Password: Remember me

TOPIC: Reshade Directx selection not available

Reshade Directx selection not available 3 months 1 week ago #1

So, when I start Reshade app I can't select DX11, or any other dx at that matter, so it's only autodetect, which always choses dx9, and I want dx11, as my World of Warcraft is DX11 and GPU aswell. Does anyone knows why I can't select DX11? And renaming d3d9.dll to d3d11.dll doesn't work. It just kicks me out of the game at launch. But after I install DirectX 9.0c it works. Any explanations? Thanks.

The administrator has disabled public write access.

Reshade Directx selection not available 3 months 1 week ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2453
  • Thank you received: 1393
Squickly wrote:
But after I install DirectX 9.0c it works. Any explanations? Thanks.
ReShade requires the June 2010 DirectX runtime (for the D3DCompiler component), which is not part of Windows 10 by default, but the DirectX 9.0c setup likely installs it. So that's why it won't work before, has nothing to do with DirectX 9 itself.

Newer versions of the setup tool let you choose a different API once the game was analysed. You seem to have an old version. But it doesn't matter, just rename the DLL to "dxgi.dll" and things work. The setup tool does nothing else.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Squickly

Reshade Directx selection not available 3 months 1 week ago #3

Yeh, I'm using old version. Tried this 2.0 but I'm confused with Mediator app. And this is what I get when I choose the game with reshade old version, this is what I get inside wow folder.
The administrator has disabled public write access.

Reshade Directx selection not available 3 months 1 week ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2453
  • Thank you received: 1393
So? What's the problem? As said, rename d3d9.dll to dxgi.dll ...
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Squickly