[SOLVED] Second Life crash

  • Posts: 39
4 years 11 months ago - 4 years 11 months ago #1 by GERgta
Hello people :) Today I wanted to try reshade with Second Life, but...

Well, it loads. And right where the login should pop up (I see the big window, but it's white) it just closes. I don't get any crashdump :(
However, I have the tracelog right here: pastebin.com/cNSX3KAG

Please Log in or Create an account to join the conversation.

  • Posts: 39
4 years 11 months ago #2 by GERgta
Oh, SL has it's own internal CrashDumps! Here: dl.dropboxusercontent.com/u/49668400/033...916-808f42055879.dmp

Please Log in or Create an account to join the conversation.

  • Posts: 3639
4 years 11 months ago #3 by crosire
Can reproduce, happens because of ReShade's DLL compression (uncompressed version works). Same issue some other OpenGL games have, they however luckily have D3D renderers too.
The following user(s) said Thank You: GERgta

Please Log in or Create an account to join the conversation.

  • Posts: 39
4 years 11 months ago #4 by GERgta
Uhuh! Interesting :huh:

Is there a possibility to get hands on the "uncompressed version" and use it with SL? If not; is there any possible fix for this problem in the forseeable future?

Please Log in or Create an account to join the conversation.

  • Posts: 3639
4 years 11 months ago #5 by crosire
After quite a bit of testing I figured out it's related to my use of TLS in the OpenGL hooks. Came up with an alternative which doesn't make use of TLS and that works now. So this is fixed with the next update. =)
The following user(s) said Thank You: GERgta

Please Log in or Create an account to join the conversation.

  • Posts: 39
4 years 11 months ago #6 by GERgta
Thank you very much! ~♥

Please Log in or Create an account to join the conversation.