Reshade FSX problem: 'Need sRGB'

  • Posts: 1
3 years 1 week ago #1 by frig2
Just testing out ReShade with FSX (DX10 enabled) and I keep getting an error log on startup and none of the SweetFX settings seem to be applied. I downloaded a preset from the site which is supposed to work with DX10.

According to the log, all the errors refer to the main.h file in the Shader folder, and says "Preprocessor error: redefinition of 'Need_sRBG'"

Anyone ever encountered this error before?

I haven't done anything except install ReShade with the SweetFX preset.

Thanks in advance.

Please Log in or Create an account to join the conversation.

  • Posts: 3741
3 years 1 week ago #2 by crosire
There should be no SweetFX installed if you want to use ReShade, nor do you use SweetFX presets with ReShade. It is fully self-contained. What's happening is ReShade is trying to load old SweetFX shaders in your game folder which doesn't work since they were written in HLSL and not the ReShade FX shading language. Remove SweetFX if you want to use ReShade 3.0

Please Log in or Create an account to join the conversation.