[SOLVED] PCxs2 Emualtor reshade .16 crash

  • Posts: 14
5 years 3 months ago - 5 years 3 months ago #1 by Tidias
PCxs2 Emulator Reshade .16 crashes with directx 11.

Edit:
Apparently Reshade 0.16 will run with pcsx2 in directX 11 (software) rendering,but Crashes in directX 11 (Hardware) Rendering.

Tracelog

Please Log in or Create an account to join the conversation.

  • Posts: 1
5 years 3 months ago #2 by QxiR
I have the same issue. Software rendering works but hardware rendering does not.

Tracelog

Please Log in or Create an account to join the conversation.

  • Posts: 73
5 years 3 months ago - 5 years 3 months ago #3 by paxton676
Yep, 0.16 crashes on me too.

Here is crash dump and tracelog

dropcanvas.com/6tt42

Please Log in or Create an account to join the conversation.

  • Posts: 3740
5 years 3 months ago #4 by crosire
Fixed in 0.17. =)
The following user(s) said Thank You: Tidias, QxiR, kmoney2315

Please Log in or Create an account to join the conversation.

  • Posts: 33
5 years 3 months ago #5 by Cloudbill
I still can't get reshade to work with DX11 hardware. It works fine with software but doesn't want to initialize with hardware.Doesn't crash PCSX2 just wont work with DX11 hardware.

Please Log in or Create an account to join the conversation.

  • Posts: 3740
5 years 3 months ago #6 by crosire

Cloudbill wrote: I still can't get reshade to work with DX11 hardware. It works fine with software but doesn't want to initialize with hardware.Doesn't crash PCSX2 just wont work with DX11 hardware.

I'm unable to reproduce that unfortunately. Here's what I did:
  1. Downloaded and installed PCXS2.
  2. Copied ReShade32.dll to the folder where pcxs2.exe is in and renamed it to dxgi.dll.
  3. Bootet PCXS2, went to Configuration > Video > Plugin Settings and chose "Default Hardware Device" as adapter and "Direct3D11 (Hardware)" as renderer, then pressed OK.
  4. Loaded up some ROM and voilĂ , ReShade overlay appeared.
The following user(s) said Thank You: Cloudbill

Please Log in or Create an account to join the conversation.

  • Posts: 33
5 years 3 months ago #7 by Cloudbill
I switched the adapter from "AMD R7 Series" to "Default Hardware Device" and Reshade started working. That seems a little weird considering I have an MSI AMD R7 265 OC. It also seems that I can't toggle the effects on/off with the "scroll lock" key. I haven't changed any of the key assignments

Please Log in or Create an account to join the conversation.

  • Posts: 73
5 years 3 months ago #8 by paxton676
As far as I know, there is no shader effects toggle with Reshade 0.17.

Please Log in or Create an account to join the conversation.

  • Posts: 3740
5 years 3 months ago #9 by crosire
There is, but the input system is buggy.
The following user(s) said Thank You: Cloudbill

Please Log in or Create an account to join the conversation.

  • Posts: 47
5 years 3 months ago - 5 years 3 months ago #10 by Boulotaur2024
Is depth buffer access working at all for you guys ?
I remember trying really hard to get that working with GeDoSaTo in dx9 but no dice. It might be different in DX11 who knows... ?

EDIT : -answering my own question- No it doesn't work, as expected. Gsdx has a weird way of handling depth textures as far as I can remember.

Please Log in or Create an account to join the conversation.

  • Posts: 33
5 years 3 months ago #11 by Cloudbill
It appears to be working in DX11. I haven't run into any issues with it. I only use it about once a week though so I haven't thoroughly check it.

Please Log in or Create an account to join the conversation.