Welcome, Guest.
Username: Password: Remember me

TOPIC: Properly installed; Doesn't load for Minecraft

Properly installed; Doesn't load for Minecraft 1 year 1 month ago #1

(I did indeed search the forums first and read Minecraft related results, such as this one.)
OS: Win10 Pro 64bit
GPU: Radeon R9 390 (various driver versions)
Java: 64bit 1.8.0_121 [C:\Program Files\Java\jre1.8.0_121\bin\]
Minecraft: 1.8 and 1.11.2 (with and without OptiFine mod)
ReShade: v3.0.8. v3.0.6, v2.x (was using Win7x64 back then)

Files installed in the Java Bin folder: opengl32.ini, ReShade.dll renamed to opengl32.dll, the same 2 but called ogl32.ini/.dll
Texture/Shader folders are on my desktop, with the correct directory mapping in the opengl32.dll
The Preset is in the main (default) .minecraft folder, correctly mapped in opengl32.dll

I have tried calling the preset: Minecraft.ini, Java.ini, Javaw.ini, no help.
I have tried with and without OptiFine, thus modded AND vanilla Minecraft, still ReShade does not load.
While I am indeed using a non-Mojang launcher (MagicLauncher) to start Minecraft, using their own still doesn't work.
I have tried the 32bit and 64bit ReShade DLLs, but no change.
Set the Java.exe and Javaw.exe to "Run as Administrator", nothin again.
Took ownership of the Java folder and sub-folders, still nope!
I have tried putting the opengl32/ogl32 files inside the specific Minecraft version folder next to the jar file, no help.
I even put them in the "Natives" folder where it loads a bunch of other JWGL dll files, nothing...
[NOTE: What I mean by "Doesn't load", is the ReShade overlay doesn't even show up upon game start like in other games]

The only thing I hadn't tried was using Java 32bit, which I painstakingly downloaded
right now, but... You guessed it... still didn't load! :(
I know that ReShade works, and more importantly, that my above configuration works, because
I have used it successfully with Mass Effect 1 and 2 on this computer.
While not getting ReShade to work with Minecraft definitely isn't the end of the world, I've longed
to try it using SMAA in it :P There's also the simpler fact that MC Shaders have the worst
performance, so it'd be nice to see what a person could achieve using ReShade. ;)

Using Process Hacker I peeked at the "Modules" loaded, which seems to indicate thar the
problem lies with Java not loading the opengl32.dll in the Bin directory; however, I have no
clue how to rectify this...

As you can see, it's indeed calling opengl32.dll. just from the SysWOW64 folder instead.
(which I believe is a failsafe in Windows when a file is not signed/properly signed?)


Config Files:
opengl32.ini [ Click to expand ]


Minecraft.ini (copied from MassEffect.ini, blank/missing is no help) [ Click to expand ]
Last Edit: 1 year 1 month ago by Formula350.
The administrator has disabled public write access.

Properly installed; Doesn't load for Minecraft 1 year 1 month ago #2

Minecraft doesn't use your Java installation anymore, but rather downloads its own Java environment. Check the path that "java.exe" process was launched from. Also make sure you install the 32-bit ReShade DLL, since the game seems to run off a 32-bit Java environment (or else it wouldn't load DLLs from SysWOW64).
Cheers, crosire =)
The administrator has disabled public write access.

Properly installed; Doesn't load for Minecraft 1 year 1 month ago #3

Guess I should've mentioned that as well... I do NOT use the Stand-alone Minecraft (I understand the reason for it, but prefer not to use it). Mine's all old-school, and does indeed run off the Java in Program Files.

(Ignore that -Dsun-opengl32-path thing. I was just trying something out, which clearly didn't work)
Though I did mention that I have indeed tried both ReShade32.dll and ReShade64.dll renamed to opengl32.dll. I tried both inside the Java 64bit BIN folder, and the 32bit inside the Java 32bit BIN folder. No luck any of the times.

Not much of a 64bit Java install if it's still calling 32bit versions of code :\ Minecraft's LWJGL is 64bit.
Actually, the only time I ever managed to get SOME kind of life from ReShade was when I renamed the 32 and 64bit LWJGL files and replaced them with the 32 and 64 ReShade files. It just crashed Minecraft before loading, but... it at least produced a log file :P More than I can say for any other attempt!
Last Edit: 1 year 1 month ago by Formula350.
The administrator has disabled public write access.

Properly installed; Doesn't load for Minecraft 1 year 1 month ago #4

Strange. Looks like the DLL search is circumvented and instead they load opengl32.dll straight from the system folder. What you can do instead is inject ReShade with something like ENBInjector (or an equivalent injector tool for 64-bit, see Google): set the target process to java.exe and have it inject ReShade's DLL at startup.
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Formula350

Properly installed; Doesn't load for Minecraft 1 year 1 month ago #5

Well this is confusing and annoying...

As I mentioned I don't use the vanilla Minecraft launcher, I use a 3RD party one (MagicLauncher) that's a little more user friendly with mods, allowing you to run them without having to actually install them.

Nevertheless, it would see that the problem lies there. When I used the default launcher, ReShade worked and loaded! So I'll have to take it up with the MagicLauncher dev.

Now, if only I could figure out why ReShade reports weird FPS, I'd be golden :P (MassEffect 1, 2, and now Minecraft all tend to display negatives, such as right now in game, -34 FPS at 4-5ms)

Anyways thanks for the help, and sorry to have wasted your time :\
The administrator has disabled public write access.