Welcome, Guest.
Username: Password: Remember me

TOPIC: Battlefield 4

Battlefield 4 2 years 2 weeks ago #1

I can't seem to get Reshade + SweetFx 2.0 working with BF4. It launches with the 32 bit dll and x32 version of the game but nothing happens in game. There are no effects and scroll lock does not work. With the x64 version of the game and the 64 bit.dll it just crashes on start saying BF4.exe has stopped working. Do I have to disable DSR or anything else that might be conflicting with the injector?

I had a similar issue with AC Unity but I finally managed to get it working somehow.

Has anyone faced this issue with BF4 too?
The administrator has disabled public write access.

Battlefield 4 2 years 2 weeks ago #2

  • Ioxa
  • Ioxa's Avatar
  • Offline
  • Posts: 289
  • Thank you received: 287
I recently started getting crashes in BF4 with ReShade, turning off triple buffering seemed to fix it. I was able to play for 30 mins or so before crashing so not sure if its the same reason you're getting crashes. Also, the newest version of ReShade has some issues with the toggle key so that is probably why scroll lock isn't working for you.
The administrator has disabled public write access.

Battlefield 4 2 years 2 weeks ago #3

Mine either crashes immediately if I use the 64 bit or with the 32 bit it launches but doesn't do anything at all. I haven't tried singleplayer but I don't suppose multiplayer would be an issue until you join a server and punkbuster kicks you. It doesn't even start. I might try disabling everything from Afterburner to Steam and Nvidia MFAA and DSR to see if it works. If it still doesn't then I have no clue whats the reason behind it.

Whats weird is that AC Unity had the same issue but instead of crashing on startup it would crash during loading or midway in game. The last time I tried it, it didn't crash at all for a good 10 mins. There might be some other application running in my background that is conflicting with the DX11D3D API.
Last Edit: 2 years 2 weeks ago by TheBoom.
The administrator has disabled public write access.