Welcome, Guest.
Username: Password: Remember me

TOPIC: Using ReShade in Sekiro stops G-Sync in fullscreen

Using ReShade in Sekiro stops G-Sync in fullscreen 2 months 2 weeks ago #1

Hi everyone here,

I registered because I have a strange problem with Sekiro and ReShade. I'm using a MSI MAG241CR FreeSync Monitor with a GTX 1070 in G-Sync compatibility mode and G-Sync works with with ReShade in Windowed Mode although I get terrible frametimes in windowed mode so I run the game in exclusive fullscreen with Windows 10 Fullscreen Optimizations turned off and there G-Sync only triggers if I remove dxgi.dll and thus remove ReShade.

One curious thing I noticed is that if I rename ReShade's dxgi.dll to d3d11.dll ReShade and G-Sync both work in fullscreen although since Steam also uses d3d11.dll to inject its overlay I lose controller functionality this way so that's also not a solution :/

Is there anything else I can try to fix this? Thanks for help in advance!
The administrator has disabled public write access.

Using ReShade in Sekiro stops G-Sync in fullscreen 2 months 2 weeks ago #2

Skyy wrote:
Hi everyone here,

I registered because I have a strange problem with Sekiro and ReShade. I'm using a MSI MAG241CR FreeSync Monitor with a GTX 1070 in G-Sync compatibility mode and G-Sync works with with ReShade in Windowed Mode although I get terrible frametimes in windowed mode so I run the game in exclusive fullscreen with Windows 10 Fullscreen Optimizations turned off and there G-Sync only triggers if I remove dxgi.dll and thus remove ReShade.

One curious thing I noticed is that if I rename ReShade's dxgi.dll to d3d11.dll ReShade and G-Sync both work in fullscreen although since Steam also uses d3d11.dll to inject its overlay I lose controller functionality this way so that's also not a solution :/

Is there anything else I can try to fix this? Thanks for help in advance!

I never had any G-Sync issues due to ReShade and I use the latest, also the most *overlayed* version of Windows (1809-17763), RivaTuner for FPS limiting, but I do disable Steam overlay. Is Steam overlay of utmost importance to you?
The administrator has disabled public write access.

Using ReShade in Sekiro stops G-Sync in fullscreen 2 months 1 week ago #3

Hey guys. I had the same issue until i found a perfect solution. Its called Sekiro FPS unlocker. It unlocks the fps so you can choose to go above 60fps, and it adds borderless fullscreen so you can get gsync working again so there is no tearing. Link below.

github.com/uberhalit/SekiroFpsUnlockAndMore

Just click on the "releases" tab and download the latest version. Run it anytime (before or after starting Sekiro).

Here are my settings to get Gsync working.

i.imgur.com/RiNSrHe.jpg
The administrator has disabled public write access.