Welcome, Guest.
Username: Password: Remember me

TOPIC: Escape from butcher bay, DLL not loading

Escape from butcher bay, DLL not loading 2 months 2 weeks ago #1

As the title suggests I have been trying to get this game to work, but I failed.

The game uses a DLL from somewhere else on the computer and I couldn't get it to load the one placed beside it. As far as I can tell the game runs in OpenGL since the Environment.cfg file always reverts to OpenGL whenever I try to modify it to DX9 for example. The game did have some kind of Beta support for DX9 but information is very scarce on how to turn it on because of how old the game is.

There is no log created so I know the game is not loading that DLL file. Reshade works fine with The Witcher 3 so it's something isolated to this game.

I tried somehow restricting the game's access to the rest of the system, so that it has to grab the DLL file from beside it, but I didn't manage to do that as I am not that good with permissions on Windows.

There are no OpenGL files within the game's folders.

Any help is appreciated.

Edit 1: Forgot to mention. Found an old compatibility thread showing the game running with Reshade, I tried using the 0.19.2 Reshade as well, see if that would work, but that didn't work either.
Last Edit: 2 months 2 weeks ago by eurobenzin. Reason: Additional information.
The administrator has disabled public write access.

Escape from butcher bay, DLL not loading 2 months 5 days ago #2

If the game uses OpenGL, then it will pick up the opengl32.dll from ReShade, if that DLL is inside the game folder. As I understand it, OpenGL games use the opengl32.dll in some Windows system folder (such as System32 and SysWOW64). ReShade's opengl32.dll then adds the additional functionality, so they complement each other. No need to mess with other folders beside the game folder! If ReShade is not loaded, try renaming the DLL to something like dinput.dll, ddraw.dll, dinput8.dll (there is actually a list of possible names somewhere on the forum).
Xeon E3-1231 v3, MSI GTX 970 @1446/3903 MHz, 16 GB DDR3-1600
The administrator has disabled public write access.

Escape from butcher bay, DLL not loading 1 month 2 weeks ago #3

Simply installing Reshade (OpenGL) next to the SbzEngine.exe that works for you and running it seems to work.
Too bad these artifacts show up, even with the ReserveTextureNames fix.
Last Edit: 1 month 2 weeks ago by Diego0920.
The administrator has disabled public write access.