IL-2 1946 : Water problem with Gaussian Blur

  • Posts: 9
4 years 10 months ago #1 by Ethridge
I've found that having Gaussian Blur enabled in the Custom_FX.cfg messes up the water in IL-2 1946. Can someone fix this? this is my favorite game and I want to spruce up its graphics but this problem is very immersion breaking





Please Log in or Create an account to join the conversation.

  • Posts: 9
4 years 10 months ago #2 by Ethridge
Can someone help? 14 views and no replies lol I really wish this issue can be fixed

Please Log in or Create an account to join the conversation.

  • Posts: 3665
4 years 10 months ago - 4 years 10 months ago #3 by crosire
Does it happen with just the Gaussian Blur shader disabled too (everything else not modified, like SMAA still running)?

Please Log in or Create an account to join the conversation.

  • Posts: 9
4 years 10 months ago - 4 years 10 months ago #4 by Ethridge
I've found that it makes the water render in square tiles with everything disabled, something to do with vertex stuff. And when you turn on just Gaussian blur, it starts going out in lines and going completely nuts. Also, I forgot to mention it, this tool is fantastic, ive wanted something like sweetfx in my old games that needed it most for a while now and you made it :) EDIT: IL-2 renders water using vertex shaders btw

Please Log in or Create an account to join the conversation.

  • Posts: 3665
4 years 10 months ago - 4 years 10 months ago #5 by crosire
More of a shader related issue rather ReShade itself then, right? If things work fine with ReShade being active (but Gaussian Blur disabled). I'll move it to the more appropiate section.

Please Log in or Create an account to join the conversation.

  • Posts: 9
4 years 10 months ago #6 by Ethridge
Yeah true, but it does start rendering water in squares even with all effects disabled

Please Log in or Create an account to join the conversation.

  • Posts: 315
4 years 10 months ago #7 by Ioxa
It looks like there is something wrong with the water and the blur is just making it more noticeable.
In this picture you can see the lines in the water under the plane.

If those lines were being cause by the shader I would think they would be noticeable on the plane too. Could you post a similar picture with all the effects disabled?

Please Log in or Create an account to join the conversation.

  • Posts: 9
4 years 10 months ago #8 by Ethridge
I need to reinstall reshade into il2 first, but yeah. With all effects disabled it renders just the water, in square tiles. And when you turn on blur it goes crazy (like in those shots I posted)

Please Log in or Create an account to join the conversation.

  • Posts: 3665
4 years 10 months ago #9 by crosire

Ethridge wrote: With all effects disabled it renders just the water, in square tiles.

You still haven't said if that's normal or not. Could you post some comparison of the water without ReShade, with ReShade but without Gaussian Blur and with ReShade and Gaussian Blur enabled?

Please Log in or Create an account to join the conversation.

  • Posts: 9
4 years 10 months ago #10 by Ethridge
Ok sorry, haven't had time to reinstall reshade and take any screenshots. In the normal game, It does not render the water in squares, With reshade installed (all effects disabled) It renders water in square tiles, and with ONLY Gaussian blur enabled it goes crazy.

Please Log in or Create an account to join the conversation.