Red message: "Unable to save current preset.Make sure you have write permission"

More
1 year 2 months ago #1 by PKPL
I wanted to install the reshade for Farming Simulator 19 (fs19). There was no Farming Simulator2019 Game in the choice of the game or anything related to it. So I clicked browse and selected C: \ Program Files (x86) \ Farming Simulator 2019 \ x64 and FarmingSimulator2019Game. Shaders installed successfully. I started the game. Shaders are working fine, but there is a red message at the top of the screen "Unable to save current preset. Make sure you have write permissions to C: \ Programs Files (x86) \ Farming Simulator 2019 \ x64 \ DefaultPreset. Ini" I don't understand what to do to do this there was no. Please help

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #2 by Tojkar
Never install any game into the default directory the installer provides. Always make a custom folder where you install your games. That would solve your problem but will also prevent multitude of other potential problems with games.

But if that is not what you want to do, you could run the game with admin priviledges.
The following user(s) said Thank You: PKPL

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #3 by PKPL
Thanks a lot for your help, thank you very much

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #4 by imvita-_-
I have the same problem. I dont understand what to do. I need to copy all the folders of the main one and the create another one and paste all of them?

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #5 by REKT

Please Log in or Create an account to join the conversation.

More
8 months 2 days ago #6 by BlueSaints
Ok so a lot of people haven't been able to figure this out for nearly years, and honestly I think we all just missed one little step that would solve all issues. When it says "Unable to save to preset" Or somewhere along the lines like that. 1.) You need to go to your game folder where you installed the game at. 2.) You have to find the .ini where it's trying to save your reshade preset at. 3.) You have to right click on the .ini file. 4.) You have to then click properties. 5.) Then near the bottom you'll see "Attributes" it will have the options "Read-only" and "Hidden". 6.) Then UNCHECK "Read-only". 7.) Last but not least click "Apply" and that's it you've fixed your Reshade preset error that annoys you 24/7. Hoped this helped :).

Please Log in or Create an account to join the conversation.

More
5 months 4 days ago #7 by bobalazs
by default it is not read only and not hidden, so what you said isnt much help.
however:

you can take ownership of reshade.ini in the game's folder.
right click the file, properties, security tab. edit - add - change every one

In the properties window click on the Security tab then click on Edit.
- On the Permissions window click on the Add button to open the Select Users Group or Groups window.
- On the Select Users or Groups window you can enter the usernames i.e.,everyone.
- Then, click OK.
- Select Full Control by placing a check mark on “Allow”
- Apply the settings.

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #8 by Kissa101
im on fs22 andi cant even found that file from x64

Please Log in or Create an account to join the conversation.