Welcome, Guest.
Username: Password: Remember me

TOPIC: [SOLVED] Double key press problem

Double key press problem 1 year 5 months ago #1

I am was trying the witcher 2 with the latest version (ReShade 0.18.7 Public Beta with SweetFX 2.0 Beta 8.7z) on windows 8.1

Everything works as expected, but the game interprets keyboard keys twice, for example when I press the down key, the menu focus jumps two items down, when I press Esc it's the equivalent of pressing Esc two times. This happens for all the keys in the game.

When I remove the dll created by reshade, disabling sweetfx, they keyboard keys work normally in the game.

I tried to play with the keybinding txt file in sweetfx but that didn't change anything.

Err ... help??
The administrator has disabled public write access.

Double key press problem 1 year 5 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
That's the game reacting to both raw input and window input (because ReShade enables latter for its own input handling). Guess I need to find a better solution ...
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: shadilahham

Double key press problem 1 year 5 months ago #3

Thanks for replying to this quickly.
Hope you do find a solution to this, because otherwise I really like reshade and would like to use it as much as possible on the games that I play.
The administrator has disabled public write access.

Double key press problem 1 year 5 months ago #4

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
Rewrote the input system completly for the third (or fourth?) time now. Should fix these issues, available with the next update.
Cheers, crosire =)
Last Edit: 1 year 5 months ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: Wicked Sick, SpinelessJelly

Double key press problem 1 year 5 months ago #5

good luck with that.
Will be happy to gibe the next update a try and let you know how it works with the witcher 2.

I'm very happy reshade exists. It makes using sweetFx so much easier :)
The administrator has disabled public write access.

Double key press problem 1 year 5 months ago #6

any news on when the next update will be ready with this issue resolved?
Looking forward to trying it out with the witcher 2 and other games.
The administrator has disabled public write access.

Double key press problem 1 year 5 months ago #7

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
It's out. But only the core version without any shaders (you can download that one and just use the DLLs though) and the SweetFX bundle. The update to the Framework version will take a little longer.
Cheers, crosire =)
Last Edit: 1 year 5 months ago by crosire.
The administrator has disabled public write access.
The following user(s) said Thank You: Wicked Sick

Double key press problem 1 year 5 months ago #8

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
It would be awesome if you could report whether it works correctly now =).
Cheers, crosire =)
The administrator has disabled public write access.

Double key press problem 1 year 5 months ago #9

sorry didn't check here for a while.
I will try it tonight or tomorrow night and let you know.
Thanks for the good work:)
The administrator has disabled public write access.

Double key press problem 1 year 5 months ago #10

I have tested this with the Witcher 2 and this problem is solved.
Now I can finally use the latest version of everything!

Thanks a lot for the hard work on fixing this :)
The administrator has disabled public write access.
The following user(s) said Thank You: crosire

Double key press problem 1 year 5 months ago #11

I will also try it with other games later and will post here in case this problem still occurs with other games, but doubt it :)
The administrator has disabled public write access.