Welcome, Guest.
Username: Password: Remember me

TOPIC: DX11 depth buffer selection save setting

DX11 depth buffer selection save setting 1 year 2 months ago #1

In GTA V using Reshade Overlay Settings I need to go to the DX11 tab and select the 5th depth buffer to make MXAO work.

How can I save that buffer selection setting?
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

DX11 depth buffer selection save setting 1 year 2 months ago #2

Would love to know the answer too. Similar situation with Steep.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 year 1 month ago #3

Looks like MXAO got a new version which works better reshade.me/forum/shader-presentation/4393-quint
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 year 1 month ago #4

Shady wrote:
In GTA V using Reshade Overlay Settings I need to go to the DX11 tab and select the 5th depth buffer to make MXAO work.

How can I save that buffer selection setting?

In GTA V (and other games), the depth buffer selection is based on the depth texture address. This address changes at every game restart, so you cannot save it in the config files.

However, there is another way of retrieving the depth buffer, before this one is cleared. In GTA V, it is possible to use it by ticking the "Copy depth before clearing" checkbox. When this mode is enabled, you can also see additional depth buffers by ticking the "Extended depth buffer detection" checkbox.
When you select a depth buffer using the "Copy depth before clearing" option, the parameter is saved and can be retrieved at the next launch.
Last Edit: 1 year 1 month ago by thalixte.
The administrator has disabled public write access.
The following user(s) said Thank You: Aelius Maximus

DX11 depth buffer selection save setting 1 year 4 weeks ago #5

The "Copy depth before clearing" and "Extended depth buffer detection" give me other addresses not working in GTA V. But without the checkboxes it is always the first entry in the list. So even if the address changes at every game restart I wish I could save the setting "Choose the first entry in the list"
The administrator has disabled public write access.
The following user(s) said Thank You: Jesped

DX11 depth buffer selection save setting 1 year 2 weeks ago #6

Shady wrote:
The "Copy depth before clearing" and "Extended depth buffer detection" give me other addresses not working in GTA V. But without the checkboxes it is always the first entry in the list. So even if the address changes at every game restart I wish I could save the setting "Choose the first entry in the list"

Here is what i got in GTA V. Not that MSAA is not enabled in game for this to work (Franklin's mansion):



In the preprocessor options, i set RESHADE_DEPTH_INPUT_IS_REVERSED to 1.
Last Edit: 1 year 2 weeks ago by thalixte.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 11 months 3 weeks ago #7

I tried that but the "copy and extended" 5th buffer selection I get flicker every second. Without "copy and extended" the first buffer always works without flicker. I wish I could save that setting - choose the first buffer in the list automatically.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 11 months 3 weeks ago #8

Shady wrote:
I tried that but the "copy and extended" 5th buffer selection I get flicker every second. Without "copy and extended" the first buffer always works without flicker. I wish I could save that setting - choose the first buffer in the list automatically.

Strange. it does not flicker in my rig. Maybe a pb with the sync method (vsync or not). I own a gsync mmonitor. Also, do you play online ?
The administrator has disabled public write access.

DX11 depth buffer selection save setting 11 months 1 week ago #9

It is GTA V online with gsync monitor and nvidia gtx 1080ti driver 391.35 set to vsync on.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 11 months 1 week ago #10

Shady wrote:
It is GTA V online with gsync monitor and nvidia gtx 1080ti driver 391.35 set to vsync on.

The depth buffer detection only works in offline mode.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 11 months 1 week ago #11

is it possible to pick a specific texture to not appear instead of selecting a rang of textures
because i want to remove grass from a specific areas in gta 5
The administrator has disabled public write access.

DX11 depth buffer selection save setting 11 months 6 days ago #12

flyynn wrote:
is it possible to pick a specific texture to not appear instead of selecting a rang of textures
because i want to remove grass from a specific areas in gta 5

nope
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 month 1 week ago #13

Shady wrote:
I tried that but the "copy and extended" 5th buffer selection I get flicker every second. Without "copy and extended" the first buffer always works without flicker. I wish I could save that setting - choose the first buffer in the list automatically.

Exactly the same problem here with Remedy's Control: no mater which "copy and extended" buffer I choose is either not working, flashes, gets lost, gets scrambled (bad depth), etc... but without "copy and extended" is always the first buffer in the list... why isnt there an option to save the selection in this mode based just in the list order?
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 month 1 week ago #14

Jesped wrote:
Shady wrote:
I tried that but the "copy and extended" 5th buffer selection I get flicker every second. Without "copy and extended" the first buffer always works without flicker. I wish I could save that setting - choose the first buffer in the list automatically.

Exactly the same problem here with Remedy's Control: no mater which "copy and extended" buffer I choose is either not working, flashes, gets lost, gets scrambled (bad depth), etc... but without "copy and extended" is always the first buffer in the list... why isnt there an option to save the selection in this mode based just in the list order?

Of course, there is. What is the content of your Reshade.ini file ?
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 month 1 week ago #15

It's not the first option, but the fifth. I start the game and select the fifth option:


Close the game and my dxgi.ini looks like this:
[DX11_BUFFER_DETECTION]
DepthBufferRetrievalMode=0
DepthBufferMoreCopies=1
DepthBufferTextureFormat=0
ExtendedDepthBufferDetection=1
DepthBufferClearingNumber=0

Start the game again and in the menus there is only one option available, and none selected:


Once inside the game itself all options appear, but none is selected:
Last Edit: 1 month 1 week ago by Jesped.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 month 1 week ago #16

Jesped wrote:
It's not the first option, but the fifth. I start the game and select the fifth option:


Close the game and my dxgi.ini looks like this:
[DX11_BUFFER_DETECTION]
DepthBufferRetrievalMode=0
DepthBufferMoreCopies=1
DepthBufferTextureFormat=0
ExtendedDepthBufferDetection=1
DepthBufferClearingNumber=0

Start the game again and in the menus there is only one option available, and none selected:


Once inside the game itself all options appear, but none is selected:

Ok,i see. So, it happens that you use the standard depth buffer detection mode. This one displays depth buffer textures by address, so you cannot save this address in the settings, because it will change every time you will restart the game. I suggest you to try the «save depth buffer before it is cleared » mode. If the auto detect does not work with this mode, you can tick one entry in the list, and the index of this entry will be saved.
Last Edit: 1 month 1 week ago by thalixte.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 month 1 week ago #17

That's what I meant. This is the only mode with a valid Depth buffer.
If I tick the «Copy depth buffer before it is cleared » none of the 20+ Depth buffers listed work ok. Some of them work for a while, but at some point they start to glitch or just disappear and the depth is lost.
It should be easy for Reshade to save the selected Depth buffer based on the order of the list (the fifth, the first or whichever) instead of the address.
The administrator has disabled public write access.
The following user(s) said Thank You: Shady

DX11 depth buffer selection save setting 1 month 1 week ago #18

Jesped wrote:
That's what I meant. This is the only mode with a valid Depth buffer.
If I tick the «Copy depth buffer before it is cleared » none of the 20+ Depth buffers listed work ok. Some of them work for a while, but at some point they start to glitch or just disappear and the depth is lost.
It should be easy for Reshade to save the selected Depth buffer based on the order of the list (the fifth, the first or whichever) instead of the address.

Have you tested the last dll I uploaded on the "Depth Buffer Detection Modification" thread ? It should work for the dx12 version of the game... Will test it as soon as i can...
Last Edit: 1 month 1 week ago by thalixte.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 month 1 week ago #19

You mean this one?

reshade.me/forum/general-discussion/4083...ion?start=1120#35714

Game crashes when finishing loading the level.
The administrator has disabled public write access.

DX11 depth buffer selection save setting 1 month 1 week ago #20

Jesped wrote:
You mean this one?

reshade.me/forum/general-discussion/4083...ion?start=1120#35714

Game crashes when finishing loading the level.

Yes. It works perfectly for me, and some other users. I think i know what's wrong for you. You have to remove all the Reshade dlls in the game folder before reinstalling it. You should not have d3d11.dll, dxgi.dll or d3d12.dll Reshade dlls in the same folder...

However, you can try this one:
mega.nz/#!K9pUUICK!2s5MPPau1jTF26DoJrwD7yyPkWOFZRUQL0e7GPKfiw8


Last Edit: 1 month 1 week ago by thalixte.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2