Welcome, Guest.
Username: Password: Remember me

TOPIC: 4.1

4.1 2 months 4 weeks ago #1

Changelog

4.1.0:
  • Added checkbox to filter active techniques on statistics page
  • Added texture preview windows which can be opened by clicking on a texture name on the statistics page
  • Added support for preset search paths
  • Changed setup tool to work like a self-extracting archive (this means you can now open the exe with tools like 7-Zip)
  • Renamed "Home" key description to "Home / Pos 1", so it is more obvious to users with a german keyboard layout
  • De-duplicate error lines to avoid wall of text in error list because of D3DCompiler bug
  • Changed sampler binding generation to reuse samplers in shader model 4 and higher to reduce bindings
  • Fixed first click on "Show HLSL/GLSL" button not updating the text editor code
  • Fixed GLSL code generation erroneously appending interpolation qualifiers to function parameters
  • Fixed variables disappearing after disabling a technique if effect file containing multiple techniques
  • Fixed syntax error in return statements not adding an error message to the error output
  • Fixed wrong GLSL shader version (should be 430, not 450, since ReShade is running under OpenGL 4.3)
  • Fixed crash in setup tool if preset dialog was closed without accepting or canceling it
  • Fixed effects with multiple active techniques being compiled multiple times
  • Fixed switch statements not always working correctly in D3D9 due to another D3DCompiler bug
  • Fixed floating point uniforms with unknown "ui_type" not showing up in UI
  • Fixed keyboard shortcuts with modifiers not being handled correctly
  • Fixed preprocessor definition popup being displayed outside visible area sometimes
  • Fixed crash when there are no uniform variables in D3D9
  • Fixed wrong blend state in D3D10 and D3D11 when GUI is hidden
  • Fixed keyboard window navigation

4.1.1:
  • Added information on keyboard navigation to tutorial
  • Fixed window state changing when opening/closing the UI
  • Fixed editor window always scrolling when moving the cursor up or down
  • Fixed possible crash during sampler creation
Cheers, crosire =)
Last Edit: 2 months 4 weeks ago by crosire.
The topic has been locked.
The following user(s) said Thank You: Wicked Sick, CeeJay.dk, Tom Yum 72, SpinelessJelly, sajittarius, klotim, brussell, conan2k, Plyply, acknowledge and this user have 32 others thankyou

4.1 2 months 4 weeks ago #2

Thanks for the update!
However, the new version is blocked by Easy-Anticheat in Insurgency: Sandstorm
The topic has been locked.

4.1 2 months 4 weeks ago #3

That's still going to happen with all updates until they are whitelisted again. As always.
Cheers, crosire =)
The topic has been locked.

4.1 2 months 4 weeks ago #4

I am having a first time bug I've never had happen before.

After downloading the 4.1 installer, when I run it it just deletes the installer and nothing happens (installer exe literally vanishes, which is...odd). Never happened with any other version or any other exe I've ever run - gonna restart my computer and try again but figured I'd throw this out there in case it's on your end.
The topic has been locked.

4.1 2 months 4 weeks ago #5

Deleted by antivirus software because incorrect detection.
After checked the ReShade with virustotal, turn off antivirus software while installation.
or wait for updates of antivirus database.

More about of virus or not, Please search this forum.
reshade.me/forum/search?query=virus
Last Edit: 2 months 4 weeks ago by seri14.
The topic has been locked.

4.1 2 months 4 weeks ago #6

It's not my AV, trust me it's the first thing I checked. I only use Malwarebytes and Avast Cleanup anyway, and Windows Defender operations including the firewall are off. I don't like intrusive stuff.

Like I said it's an...odd issue that's never happened before and unfortunately I'm still using 4.0.2 as a result. The only popup I receive is the usual permissions to run it since it isn't recognized - which I allow to run anyway and the exe just vanishes lol. I do have an old comp so it might be something else on my end though - after a restart and so on I'll update my post, unless nothing changes, but it'll likely be later when I'm able to afford the time. Thanks for the reply though, I appreciate it.

EDIT ::: Sorry it took so long. Restarting the comp and redownloading worked, so I honestly have no clue what the issue was but it was something with my comp. Thing might finally be circling the drain. Anyway thanks as usual!
Last Edit: 2 months 4 weeks ago by Mr.Anomaly.
The topic has been locked.

4.1 2 months 4 weeks ago #7

Any news on Vulkan support? is it still planed?
The topic has been locked.

4.1 2 months 4 weeks ago #8

Woohoo! Thanks Crosire :)

I gather this doesn't include any more of thnxlite's depth-buffer detection advancements that are going on in his thread right now.
The topic has been locked.

4.1 2 months 4 weeks ago #9

Martigen wrote:
Woohoo! Thanks Crosire :)

I gather this doesn't include any more of thnxlite's depth-buffer detection advancements that are going on in his thread right now.

No, it does not include the modifications on the depth buffer detection for d3d9 for now, but i made a PR on github, and Crosire will review it.
Last Edit: 2 months 4 weeks ago by thalixte.
The topic has been locked.

4.1 2 months 4 weeks ago #10

With this update, toggleable filters are on by default. Any way to make them disabled on boot like previously?
The topic has been locked.

4.1 2 months 4 weeks ago #11

Bug found!

Max Payne 2, as well known, doesn't give the possibility to use the mouse in the UI but eagerly I bet on the now-fixed keyboard shortcut.....and here's the bug: pressing HOME I get the UI, pressing another time I get the UI lost and pressing a third time I get the DX11 tab (I'm using dgVoodoo2 as a wrapper) and no way to move away from that tab!
Last Edit: 2 months 4 weeks ago by lowenz.
The topic has been locked.

4.1 2 months 4 weeks ago #12

will someday ReShade works at DX12?
The topic has been locked.

4.1 2 months 4 weeks ago #13

lowenz wrote:
Bug found!

Max Payne 2, as well known, doesn't give the possibility to use the mouse in the UI but eagerly I bet on the now-fixed keyboard shortcut.....and here's the bug: pressing HOME I get the UI, pressing another time I get the UI lost and pressing a third time I get the DX11 tab (I'm using dgVoodoo2 as a wrapper) and no way to move away from that tab!
And the same behaviour in other wrapped games WITH mouse support (Rune).
So it's something about the interaction with dgVoodoo2.
Can you check Crosire? (lastest WIP: dege.freeweb.hu/temp/dgVoodooWIP56.zip )
Last Edit: 2 months 4 weeks ago by lowenz.
The topic has been locked.

4.1 2 months 4 weeks ago #14

Same (MIS)behaviour with your own d3d8to9 wrapper! (Now the fixed tab is of course labeled "DX9")

Tested with: github.com/crosire/d3d8to9/releases/tag/v1.9.1
Last Edit: 2 months 4 weeks ago by lowenz.
The topic has been locked.

4.1 2 months 4 weeks ago #15

Press Ctrl + Tab.
Cheers, crosire =)
The topic has been locked.

4.1 2 months 4 weeks ago #16

crosire wrote:
Press Ctrl + Tab.
Thanks!
But why this behaviour?
The topic has been locked.

4.1 2 months 4 weeks ago #17

I hoped that this version would work with my IL-2, but alas, as soon as you start setting up ReShade in a game, the screen is dark. It used to work very successfully with version 4.1.0, but after installing version 4.0.2, everything stopped working and now any version of the 4th series does not work. I can not understand the reason ???. Works only with version 3.4.1.
Thanks for the work!
The topic has been locked.

4.1 2 months 4 weeks ago #18

Hi crosire, Please, we need Vulkan support, there are really good games made with Vulkan.

Thanks
The topic has been locked.

4.1 2 months 4 weeks ago #19

Another strange behaviour observed (DX11-wrapped Unreal Gold 226f):

With the UI opened no problem:


Closing the UI you got a viewport stretching:
Last Edit: 2 months 4 weeks ago by lowenz.
The topic has been locked.

4.1 2 months 4 weeks ago #20

lowenz wrote:
lowenz wrote:
Bug found!

Max Payne 2, as well known, doesn't give the possibility to use the mouse in the UI but eagerly I bet on the now-fixed keyboard shortcut.....and here's the bug: pressing HOME I get the UI, pressing another time I get the UI lost and pressing a third time I get the DX11 tab (I'm using dgVoodoo2 as a wrapper) and no way to move away from that tab!
And the same behaviour in other wrapped games WITH mouse support (Rune).
So it's something about the interaction with dgVoodoo2.
Can you check Crosire? (lastest WIP: dege.freeweb.hu/temp/dgVoodooWIP56.zip )

I have not already reproduced the using problem of the mouse, but I have same problem of tab focusing.
I request to release a hotfix include fixed this problem.

TOPIC: Focused last tab when showing UI after second time
reshade.me/forum/general-discussion/5022...ui-after-second-time
The topic has been locked.