Welcome, Guest.
Username: Password: Remember me

TOPIC: 1.0

1.0 4 years 4 months ago #73

@Qsimil: ReShade Framework v1.0.0 has to be updated with the new Master FX ReBorn v1.1.287,
for now you can only take out the ReShade32.dll & ReShade64.dll files (from ReShade Framework v1.0.0)
and combine it with Master FX ReBorn v1.1.287 (files: MasterEffect.h etc etc..)
The topic has been locked.
The following user(s) said Thank You: Qsimil

1.0 4 years 4 months ago #74

@noxdeleo: ReShade Framework Mediator tutorial:
The topic has been locked.
The following user(s) said Thank You: robgrab, Ganossa, Quentin-Tarantino, Solano, Qsimil, noxdeleo

1.0 4 years 4 months ago #75

I'd like to report that with Nvidia Driver 355.82 (released 31st of august) the 99% core load FPS drop issue is still occuring. This happens after a random amount of time in multiple games like Arma 3 and GTA V.

Are you sure this is a driver issue? Shouldn't it be fixed by now?
I'm always learning.
The topic has been locked.

1.0 4 years 4 months ago #76

I'm sorry to be impatient but I have to ask this , is there any plan to fix the lack of depth buffer access on so many games that doesn't have it right now ??! maybe in the near future ??! :dry:
The topic has been locked.

1.0 4 years 4 months ago #77

Constantine PC wrote:
I'd like to report that with Nvidia Driver 355.82 (released 31st of august) the 99% core load FPS drop issue is still occuring. This happens after a random amount of time in multiple games like Arma 3 and GTA V.

Are you sure this is a driver issue? Shouldn't it be fixed by now?

This could possibly be related to a shader I have activated in the Framework package (1.0)
I'm always learning.
Last Edit: 4 years 4 months ago by Constantine PC.
The topic has been locked.

1.0 4 years 4 months ago #78

Constantine PC wrote:
Constantine PC wrote:
I'd like to report that with Nvidia Driver 355.82 (released 31st of august) the 99% core load FPS drop issue is still occuring. This happens after a random amount of time in multiple games like Arma 3 and GTA V.

Are you sure this is a driver issue? Shouldn't it be fixed by now?

This could possibly be related to a shader I have activated in the Framework package (1.0)

I did a little more testing and this drop does not happen with the 0.19.2 SweetFX Package hosted on the Home Page Downloads.
Something either with 1.0 or the Framework Package (possibly shaders or the actual package) is causing this GPU Core Load issue.
I'm always learning.
The topic has been locked.

1.0 4 years 4 months ago #79

Constantine PC wrote:
I did a little more testing and this drop does not happen with the 0.19.2 SweetFX Package hosted on the Home Page Downloads.
Something either with 1.0 or the Framework Package (possibly shaders or the actual package) is causing this GPU Core Load issue.
Could you check what happens with the SweetFX files, but the ReShade 1.0 DLL?
Cheers, crosire =)
The topic has been locked.

1.0 4 years 4 months ago #80

mindu wrote:
Any reason for 1.00 crashing all the time on GTA5 and 0.18.X and 0.19.X works perfect? :(
btw I use mastereffect if that matters.
Constantine PC wrote:
I did a little more testing and this drop does not happen with the 0.19.2 SweetFX Package hosted on the Home Page Downloads.
Something either with 1.0 or the Framework Package (possibly shaders or the actual package) is causing this GPU Core Load issue.
I'm not sure if we are talking about the same issue but I quote myself in case Crosire missed it :P
0.18 and 0.19 are working fine for me but not 1.0.0 (at least in GTAV)
Last Edit: 4 years 4 months ago by mindu.
The topic has been locked.

1.0 4 years 4 months ago #81

Constantine PC wrote:
Constantine PC wrote:
Constantine PC wrote:
I'd like to report that with Nvidia Driver 355.82 (released 31st of august) the 99% core load FPS drop issue is still occuring. This happens after a random amount of time in multiple games like Arma 3 and GTA V.

Are you sure this is a driver issue? Shouldn't it be fixed by now?

This could possibly be related to a shader I have activated in the Framework package (1.0)

I did a little more testing and this drop does not happen with the 0.19.2 SweetFX Package hosted on the Home Page Downloads.
Something either with 1.0 or the Framework Package (possibly shaders or the actual package) is causing this GPU Core Load issue.

I'm about 99% sure this is happening from an individual shader. Probably Embossing or something else is custom FX

It's not happening with 1.0 DL with SweetFX shaders and my currently selected Framework shaders.
I'm always learning.
The topic has been locked.

1.0 4 years 4 months ago #82

Constantine PC wrote:
I'm about 99% sure this is happening from an individual shader. Probably Embossing or something else is custom FX

It's not happening with 1.0 DL with SweetFX shaders and my currently selected Framework shaders.
That's good news. But still hard to track down, without narrowing it down to a specific shader. If a single shader is causing this, I could check if something shader compiler output triggers a driver bug or similar.
Cheers, crosire =)
The topic has been locked.

1.0 4 years 4 months ago #83

i cant get 1.00 to work with any game except skyrim and black ops 2 they worked before are there prerequisites i need installed that may be corrupted or anything ? it activates in game and i can toggle it to say enabled or disabled however not a thin will happen no reshading and i have vibrance on 0.75 so it would significantly change all the color vibrancy immediately but it isnt i run windows 10 fyi and latest amd drivers and windows updated to latest beta build
Last Edit: 4 years 4 months ago by MasterKairi0.
The topic has been locked.

1.0 4 years 4 months ago #84

any new release coming soon?
V1 is nice, but looking forward to a new release with fewer bugs :)

Maybe also a better version of the mediator?
The topic has been locked.

1.0 4 years 4 months ago #85

The mediator already received some fixes that are not deployed yet but there won't be any major changes.
On my list is a problem with "weird" file names (e.g. TM symbol) and a refresh problem in the offline preview feature.

On the shader side there will be plenty of changes which I almost stopped counting ;) (and maybe more in the doing)

Crosire also made changes to the binaries (I think mainly for DX12 compatibility, please correct me if I am wrong)

We just did not set a common date yet :)
The topic has been locked.

1.0 4 years 3 months ago #86

Will MasterEffect Reborn 1.1.287 be included in the next update? Also, is there a way to integrate MasterEffect Reborn 1.1.287 into the current version of ReShade/Mediator?
The topic has been locked.

1.0 4 years 3 months ago #87

I did a little more testing on the 1.00 99% core load issue.

This happens in GTA V with the framework pacakge with either 1.00 .dll or 0.19.2

Doesn't seem to happen with SweetFX 1.00 or 0.19.2
Something with the Framework package is causing the core load issue in this game.
I'm always learning.
The topic has been locked.

1.0 4 years 3 months ago #88

robgrab wrote:
Will MasterEffect Reborn 1.1.287 be included in the next update? Also, is there a way to integrate MasterEffect Reborn 1.1.287 into the current version of ReShade/Mediator?

All exclusive ME shader should already be included in the framework (otherwise feel free to point out whats missing).
Specific 1.1.287 changes are included in our current build and will be in the next release.


Constantine PC wrote:
I did a little more testing on the 1.00 99% core load issue.

This happens in GTA V with the framework pacakge with either 1.00 .dll or 0.19.2

Doesn't seem to happen with SweetFX 1.00 or 0.19.2
Something with the Framework package is causing the core load issue in this game.

Can you push the configuration to the app and try again (in case its a link problem). Other than that I cannot think of any difference that could cause it.
Last Edit: 4 years 3 months ago by Ganossa.
The topic has been locked.

1.0 4 years 3 months ago #89

It would be nice if ReShade Framework or at least SweetFX package could be applied to Windows 7/10 desktop by injecting into Aero renderer or some other way. This would be really good for those into calibration. There are now ways to use 3DLUT's (or I guess you can call them FULL LUT's) that include both grayscale AND colorspace / color gamut information for 2 major environments - film playback (madVR) and video games (ReShade Framework TuningPalette shader). The last major environment left to conquer is Windows desktop because Windows desktop uses only graypscale ("vcgt") portion of ICC profiles and colorspace / color gamut information is not applied. This would also be VERY helpful when it comes to streaming media, such as Netflix and / or Hulu!
Last Edit: 4 years 3 months ago by MonarchX.
The topic has been locked.
The following user(s) said Thank You: Quentin-Tarantino, Constantine PC

1.0 4 years 3 months ago #90

LuciferHawk wrote:
The mediator already received some fixes that are not deployed yet but there won't be any major changes.
On my list is a problem with "weird" file names (e.g. TM symbol) and a refresh problem in the offline preview feature.

On the shader side there will be plenty of changes which I almost stopped counting ;) (and maybe more in the doing)

Crosire also made changes to the binaries (I think mainly for DX12 compatibility, please correct me if I am wrong)

We just did not set a common date yet :)

Yeah I noticed with certain games that use a TM symbol in the .exe details like BF4, Project Cars etc always have a ? symbol in the application profile area. It also spits out an error saying "Loading Application profile failed due to the following error: Illegal Characters in path". Glad you have noticed this, it also seems to require you to click on the game window's border (Testing in Windowed mode with Mediator open) in order to get the effect to compile, hitting apply simply doesnt work after the first time installation and initial preset creation is done. This was never the case in previous testing for my when using MasterEffect and Reshade 19.0 release, I guess it just has something to do with Mediator and probably due to being in Windowed mode will testing out various effects.
Last Edit: 4 years 3 months ago by bopper2010.
The topic has been locked.

1.0 4 years 3 months ago #91

Not sure if the reload problem in window mode is related to the framework. It seems its an issue dependent on system and application. The difficulty for the Framework is the update of possibly several files at once. In the first release all files have been updated but once ReShade checks the first updated file and notices no difference it stops checking any following updated file. To fix this I already check updates within the mediator and only rewrite those that do apply changes. Therefore, this problem should not come up anymore, at least not because of the mediator.
Did you check if modifying files manually made any difference?
The topic has been locked.

1.0 4 years 3 months ago #92

No I dont think the Framework is to blame after a bit more experimenting, probably because I didnt set Mediator to sit on top of the windowed game or something. Just a question on the applying of user created Preset's, I like to make them for games and upload them to the SweetFX Database. In the past I used to just upload the MasterEffect.h config file or older SweetFX config files and people could just apply it on their end by replacing their default file with mine. However with Mediator the only way I have figured out to share a Preset I make is to copy the entire Preset folder contained within the Reshade/PersonalFiles/Presets/ location and upload that.

So basically Im wondering is there a more efficient way to do this, I have tried copying the contents of the TheLazyFrameworkPreset.cfg and then pasting it into a new preset but without the other Framework files having their values specified it doesnt seem to apply the updated settings as specified in that file. Im still such a noob with this stuff so its probably something basic Im just totally overlooking, but I was just curious if you knew of a more efficient way or am I actually doing it correctly ?.

Thanks Lucifer, gonna go play with the TransMod and see if I can port over some old presets.
The topic has been locked.