Welcome, Guest.
Username: Password: Remember me

TOPIC: [Arma 3]Real Light preset - Game Launch Issues

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #1

  • Solano
  • Solano's Avatar
  • Offline
  • Posts: 49
  • Thank you received: 6
Hi guys,

If I get error reports by users for my preset it´s 99% a game launch issue. Crosire already wrote in another post that disabling BattlEye helps.
In fact sometimes that solves it. But now even this is not the solution anymore.

I really don´t know what to do anymore and what to try so I decided to wrap the whole situation up as short as possible to make sense out of all this and hopefully eliminate this issues with you guys some people have.

We are talking about this preset of mine: sh8.videopilot.link/arma3/real-light-v6/

Here we go;

I contacted BattlEye directly and got the following reply:

Quote:
Warning: Spoiler! [ Click to expand ]


One user has a Blackscreen when trying to launch Arma and he wrote:

Warning: Spoiler! [ Click to expand ]


Another user reports that the game was running with ReShade when after two days without any change of him on the setup it suddenly failed to work:

Warning: Spoiler! [ Click to expand ]


I experienced a similar thing. I had ReShade 0.1.92 running for Arma 3 as well and all previous versions I used never caused trouble. I never had to disable BattlEye because it never denied me the usage if the dxgi.dll. When I switched over to ReShade 1.0 it suddenly did tho. So I disabled BattlEye - the game launched and I thought; ok, now I seem to have that issue too (out of nowhere to be honest).Played some Arma, closed the game, thought I´d might give it another shot with BattlEye and then it just launched! ReShade 1.0 running, BattlEye enabled - Arma 3 runs and most important starts til today without any issues and I did nothing to my system. There was no update - I used the same files from your download as before...

Then there was a User that helped another user out with this tip:

Warning: Spoiler! [ Click to expand ]


The guy tried the workaround and reported that it worked!

A user wrote me this: "I could not launch either until I simply clicked on the arma3.exe itself and ran as administrator. Shortcuts need also to run as admin and i have had mixed results with having mods in the command line. It sometimes launches and sometimes it does not."

I don´t run anything as administrator in the Arma context and it works for me.

Here is another example of how a user made it work for him:

Warning: Spoiler! [ Click to expand ]




I know this is a lot of quote to read - the reason I do this is just that I hope you guys can make sense out of that and maybe even find clues in these sometimes weird solvings. Like I wrote before I am out of ideas what is happening there and even BattlEye told me everything is whitelisted with ReShade.

Regards


Solano
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #2

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
Solano wrote:
Quote:
Warning: Spoiler! [ Click to expand ]
Solano wrote:
I experienced a similar thing. I had ReShade 0.1.92 running for Arma 3 as well and all previous versions I used never caused trouble. I never had to disable BattlEye because it never denied me the usage if the dxgi.dll. When I switched over to ReShade 1.0 it suddenly did tho. So I disabled BattlEye - the game launched
No surprise. The ReShade binaries changed between 0.19.2 and 1.0.0, so that would no longer make them whitelisted (I guess they do that using a MD5 hash or similar) and thus one needs to wait for BattlEye to add them again.
Cheers, crosire =)
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #3

  • Solano
  • Solano's Avatar
  • Offline
  • Posts: 49
  • Thank you received: 6
I understand.
All the issues I mentioned are from a longer timespan.
It seemed to fix it for many people to disable BattlEye but there are others who disabled it and can´t launch so I made this collection to make it hopefully easier to track the issue down once and for all.
It also seems that it isn´t really OS dependent in this case.
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #4

  • Solano
  • Solano's Avatar
  • Offline
  • Posts: 49
  • Thank you received: 6
BUMP
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #5

  • Solano
  • Solano's Avatar
  • Offline
  • Posts: 49
  • Thank you received: 6
I got a user who wrote me this:

"I tried it without any mods or battleye enabled and I got a combination of these two errors.

„STATUS_STATCK_BUFFER_OVERRUN“
and
„ACCESS_VIOLATION“

Both of them occur when „compiling effect.“"

Any ideas what this means?

Regards
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #6

  • Solano
  • Solano's Avatar
  • Offline
  • Posts: 49
  • Thank you received: 6
BUMP
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #7

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
Solano wrote:
Both of them occur when „compiling effect.“"
Does it work if no effects are in the folder, so that ReShade does not try to compile anything?
Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Solano, xXZexxMooreXx

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #8

When I remove ReShade.fx, it the game will load and say "Loading effect....no effect found!"

It doesn't crash when there is no ReShade.fx file.
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #9

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
Interesting, so it's something in the effect compiler that causes the crash. Could you try the same exact shaders and config in some other games to see if it crashes there too (preferably the same DirectX version and with some other DirectX version too, to see if the global parser or the target specific compilers are the problem)?
Cheers, crosire =)
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 3 months ago #10

xXZexxMooreXx wrote:
When I remove ReShade.fx, it the game will load and say "Loading effect....no effect found!"

It doesn't crash when there is no ReShade.fx file.

Through about twelve hours of Arma 3 with ReShade and no effect loaded, I had one access violation crash. With ReShade.fx present, the game crashes nearly every time when loading the effect.

I'll try out some other games and see what happens.
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #11

  • Horus
  • Horus's Avatar
  • Offline
  • Posts: 17
  • Thank you received: 1
I think problem comes from game because when game launch, in first few seconds when game initialize, arma 3.exe not respond ( check task manager) and then start well.

I used WhatIsHang and this is what I find:
Arma3 without Reshade - game start normal - in Task Manager -> Arma3.exe - Not Responding -> then - Running
Warning: Spoiler! [ Click to expand ]
Last Edit: 1 year 2 months ago by Horus.
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #12

  • Horus
  • Horus's Avatar
  • Offline
  • Posts: 17
  • Thank you received: 1
^^follow-up
Warning: Spoiler! [ Click to expand ]
Last Edit: 1 year 2 months ago by Horus.
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #13

  • Horus
  • Horus's Avatar
  • Offline
  • Posts: 17
  • Thank you received: 1
^^follow
Warning: Spoiler! [ Click to expand ]
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #14

  • Horus
  • Horus's Avatar
  • Offline
  • Posts: 17
  • Thank you received: 1
Arma3 with Reshade - game stop after "Loading effect....Succeeded!" - in Task Manager -> Arma3.exe - Not Responding
Warning: Spoiler! [ Click to expand ]
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #15

  • Horus
  • Horus's Avatar
  • Offline
  • Posts: 17
  • Thank you received: 1
Arma3 with Reshade - game stop with white screen - in Task Manager -> Arma3.exe - Not Responding
Warning: Spoiler! [ Click to expand ]


I hope this may be help to find solution how to fix this problem with Arma 3 :blush:
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #16

  • Solano
  • Solano's Avatar
  • Offline
  • Posts: 49
  • Thank you received: 6
Thanks for the effort Horus! I really appreciate this. This is a ton of Data which hopefully clears things up once and for all!
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #17

  • Horus
  • Horus's Avatar
  • Offline
  • Posts: 17
  • Thank you received: 1
I hope, too. Let's see what Crosire have to says about this.. useful data or not.
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #18

  • crosire
  • crosire's Avatar
  • Offline
  • Posts: 2437
  • Thank you received: 1385
Horus wrote:
4456 6E08D04E atidxx32.dll!AmdLiquidVrD3D11WrapDeviceContext+0xb68e
4472 77101337 ntdll.dll!RtlDestroyHandleTable+0x347
4476 6E695758 dxgi.dll!D3DKMTCloseAdapter+0x8e67
4480 6E695774 dxgi.dll!D3DKMTCloseAdapter+0x8e83
4484 6E67AED7 dxgi.dll!CreateDXGIFactory1+0x38dc
4500 022763B0 arma3.exe+0xec63b0
4504 022763B0 arma3.exe+0xec63b0
4592 6E08D04E atidxx32.dll!AmdLiquidVrD3D11WrapDeviceContext+0xb68e
4580 6E08D04E atidxx32.dll!AmdLiquidVrD3D11WrapDeviceContext+0xb68e
That AMD Liquid VR wrapper thing in there could be the culprit, though the function names might be misleading, considering that the distance from the function begin to the actual stack pointer is quite high (0xb68e = 46734 bytes = 47 kilobytes). Is your computer equiped with an AMD or NVIDIA card?
Cheers, crosire =)
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #19

  • Horus
  • Horus's Avatar
  • Offline
  • Posts: 17
  • Thank you received: 1
AMD R9 270 ... DxDiag 64bit
Warning: Spoiler! [ Click to expand ]


www.reddit.com/r/oculus/comments/2xt2w9/...ew_vr_sdk_liquid_vr/
Last Edit: 1 year 2 months ago by Horus.
The administrator has disabled public write access.

[Arma 3]Real Light preset - Game Launch Issues 1 year 2 months ago #20

  • Horus
  • Horus's Avatar
  • Offline
  • Posts: 17
  • Thank you received: 1
I try with older driver 14.12 which don't have support for Liquid VR
Warning: Spoiler! [ Click to expand ]
The administrator has disabled public write access.
  • Page:
  • 1
  • 2