Welcome, Guest.
Username: Password: Remember me

TOPIC: No shaders showing up

No shaders showing up 11 months 3 weeks ago #1

So I installed ReSahde 3.0.7 and when i go into my game no shaders or textures are showing up. Not sure if i'm doing something wrong. And when I go into the reshade-shaders/Shaders folder there are shaders in there.
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #2

Make sure the full path to reshade-shaders\Shaders is part of the effect search paths list on thr settings page.
Cheers, crosire =)
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #3

It is and when i go into the log it says, Unable to load D3DCompiler library. Make sure you have the DirectX end-user runtime (June 2010) installed. And I just installed it and still the same problem.
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #4

Ah, well, then that's still missing. You need this one: www.microsoft.com/en-us/download/details.aspx?id=8109. Let it extract itself and then run DXSETUP.exe.
Cheers, crosire =)
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #5

Should I reinstall ReShade afterwards?
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #6

No, no need for that. A reboot wouldn't hurt though.
Cheers, crosire =)
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #7

Just rebooted and it's still giving me the same message & nothing is showing up in the shaders. The Error Log also says "make sure that you have a newer version of the library in the application directory."
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #8

Any suggestions?
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #9

There is a "D3DCompiler_43.dll" file in your system32 directory after installation. If it's not there, then the DX runtime wasn't fully installed.
You can even see the "Jun2010_D3DCompiler_43_x86.cab" file among the setup files, that when opened with something like 7zip gets you the file in question. So if for some reason the setup still doesn't manage to put the files in the right places, extract it from there manually and put it into the game directory.
Cheers, crosire =)
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #10

I see "D3DCompiler_43.ll" file in my system32. And I do see that when I open the "Jun2010_D3DCompiler_32_x86.cab" file but i'm not sure what to do with it.
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #11

Strange. Try to copy the file in your game directory beside the exe where you installed ReShade to (if it's a 32-bit game, copy C:\Windows\SysWOW64\D3DCompiler_43.dll instead).
Cheers, crosire =)
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #12

I'm trying to use it with iw4x (MW2) btw. Are you saying to copy the .exe file?
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #13

The D3DCompiler DLL from system to game folder.
Cheers, crosire =)
The administrator has disabled public write access.

No shaders showing up 11 months 3 weeks ago #14

So I put the D3DCompiler in my MW2 folder like this: gyazo.com/b000ad250dbe2f657624528fd5e196d2
And it is still showing this in the log: gyazo.com/f95ed1c1cdff5f9a3fbd4831e3b8eca4
The administrator has disabled public write access.

No shaders showing up 11 months 2 weeks ago #15

Soooo
The administrator has disabled public write access.

No shaders showing up 10 months 4 weeks ago #16

Bump
The administrator has disabled public write access.