No shaders showing up

  • Posts: 10
2 years 10 months ago #1 by Cxrsxn
So I installed ReSahde 3.0.7 and when i go into my game no shaders or textures are showing up. Not sure if i'm doing something wrong. And when I go into the reshade-shaders/Shaders folder there are shaders in there.

Please Log in or Create an account to join the conversation.

  • Posts: 3669
2 years 10 months ago #2 by crosire
Make sure the full path to reshade-shaders\Shaders is part of the effect search paths list on thr settings page.

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 10 months ago #3 by Cxrsxn
It is and when i go into the log it says, Unable to load D3DCompiler library. Make sure you have the DirectX end-user runtime (June 2010) installed. And I just installed it and still the same problem.

Please Log in or Create an account to join the conversation.

  • Posts: 3669
2 years 10 months ago #4 by crosire
Ah, well, then that's still missing. You need this one: www.microsoft.com/en-us/download/details.aspx?id=8109 . Let it extract itself and then run DXSETUP.exe.

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 10 months ago #5 by Cxrsxn
Should I reinstall ReShade afterwards?

Please Log in or Create an account to join the conversation.

  • Posts: 3669
2 years 10 months ago #6 by crosire
No, no need for that. A reboot wouldn't hurt though.

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 10 months ago #7 by Cxrsxn
Just rebooted and it's still giving me the same message & nothing is showing up in the shaders. The Error Log also says "make sure that you have a newer version of the library in the application directory."

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 10 months ago #8 by Cxrsxn
Any suggestions?

Please Log in or Create an account to join the conversation.

  • Posts: 3669
2 years 10 months ago #9 by crosire
There is a "D3DCompiler_43.dll" file in your system32 directory after installation. If it's not there, then the DX runtime wasn't fully installed.
You can even see the "Jun2010_D3DCompiler_43_x86.cab" file among the setup files, that when opened with something like 7zip gets you the file in question. So if for some reason the setup still doesn't manage to put the files in the right places, extract it from there manually and put it into the game directory.

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 10 months ago #10 by Cxrsxn
I see "D3DCompiler_43.ll" file in my system32. And I do see that when I open the "Jun2010_D3DCompiler_32_x86.cab" file but i'm not sure what to do with it.

Please Log in or Create an account to join the conversation.

  • Posts: 3669
2 years 10 months ago #11 by crosire
Strange. Try to copy the file in your game directory beside the exe where you installed ReShade to (if it's a 32-bit game, copy C:\Windows\SysWOW64\D3DCompiler_43.dll instead).

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 10 months ago #12 by Cxrsxn
I'm trying to use it with iw4x (MW2) btw. Are you saying to copy the .exe file?

Please Log in or Create an account to join the conversation.

  • Posts: 3669
2 years 10 months ago #13 by crosire
The D3DCompiler DLL from system to game folder.

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 10 months ago #14 by Cxrsxn
So I put the D3DCompiler in my MW2 folder like this: gyazo.com/b000ad250dbe2f657624528fd5e196d2
And it is still showing this in the log: gyazo.com/f95ed1c1cdff5f9a3fbd4831e3b8eca4

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 10 months ago #15 by Cxrsxn
Soooo

Please Log in or Create an account to join the conversation.

  • Posts: 10
2 years 9 months ago #16 by Cxrsxn
Bump

Please Log in or Create an account to join the conversation.

  • Posts: 2
1 year 18 hours ago #17 by Neo4370
Try to change your effects and texture paths (in reshade settings) to the shaders and textures folders in [path to the witcher 3]/bin/x64/reshade-shaders. That fixed it for me

Please Log in or Create an account to join the conversation.

  • Posts: 2
1 year 18 hours ago #18 by Neo4370
lol sorry for writing this a year and a half later lol

Please Log in or Create an account to join the conversation.

  • Posts: 205
1 year 16 hours ago #19 by Duran.te
:lol:

Please Log in or Create an account to join the conversation.

  • Posts: 2
11 months 3 weeks ago - 11 months 3 weeks ago #20 by Noka
My shaders are not showing as well. Didn't want to make a new topic so I will post here. Mine is with Spintires Mudrunner. I can post a Log if it's of any help..
Spotted this but I do not know what it means: "16:45:14:047 [00692] | WARN | > IDirect3D9::CreateDevice failed with error code 0x8876086c!"


Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.