2.0

  • Posts: 3727
4 years 2 months ago #181 by crosire

Jack_Frost wrote: 1: Can't get into the shader settings tab. Even after creating a profile and a preset, it doesn't appear. It's just a blank column in the assistant.

You need to select a shader first, or else there are no settings to display there and the tab is disabled.
The topic has been locked.
  • Posts: 80
4 years 2 months ago #182 by sajittarius

Ganossa wrote: Can you post the complete ini file that you want to be used?


I just downloaded the latest 2.0.2f and it looks like its working now... :)
The topic has been locked.
  • Posts: 16
4 years 2 months ago #183 by Blackhand
Maybe this issue is dug in this thread. Since 2.0 I can't edit the settings while I'm running the game I use with reshade. I get a game crash when I try it via mediator or Notepad. With the Reshade files copied native to the gamedirectory it works (This procedure is a bit different now).
The topic has been locked.
  • Posts: 307
4 years 2 months ago - 4 years 2 months ago #184 by MonarchX
Thanks!

Assistant GUI LOOKS better, but now tabs just don't work when I click on them...Left click does nothing, right-click does nothing, keyboard arrow keys do nothing, and both left and right double clicks do nothing... WTH?

EDIT:
Grim Fandango - Remastered (GOG) - NOW WORKS! :cheer: Huge thanks!
Grim Dawn (GOG) - does NOT work with neither 2.0.1f4 nor 2.0.2f1, but DOES work with 1.1.0 :(
Dying Light - Enhanced Edition (GOG) - does NOT work with neither 2.0.1f4 nor 2.0.2f1, but DOES work with 1.1.0 :(
The topic has been locked.
  • Posts: 790
4 years 2 months ago - 4 years 2 months ago #185 by Ganossa

SilentPrayerCG wrote: I select entire value, i want to edit it, but it go in to "autofocus mode" and start chage focus by mouse over

also i checked, if select only part of value, it's fine, autofocus enabled only when i select entire value


I can change it to not enable auto-focus when you select the entire text in a field.


MonarchX wrote: Thanks!

Assistant GUI LOOKS better, but now tabs just don't work when I click on them...Left click does nothing, right-click does nothing, keyboard arrow keys do nothing, and both left and right double clicks do nothing... WTH?


Standard input for navigation is still left-click on default settings. You should be able to navigate to enabled tabs (Assistant Settings, Tools, Profiles, Presets on startup). If this does not work then you might have found a bug.



Jack_Frost wrote: Oops, perhaps this should be moved to 'Troubleshooting.' Sorry.

Hi. New here. 1st, I appreciate you developing this tool and helping the gaming community. 2nd, I could use some assistance.

Downloaded the 3/28 release and am experiencing some issues:
1: Can't get into the shader settings tab. Even after creating a profile and a preset, it doesn't appear. It's just a blank column in the assistant.

2: On most of Ganossa's shaders (bloom, ambientlight, etc.) I'm getting x3011 errors - 'Value must be a literal expression', usually in lines 48-54, but always column 21. I opened the files and navigated to the lines/columns and it seems they are just blank spaces. I've made sure they were ANSI encoded.
3: Compiling effects....Failed! So, nothing is being applied to the game.

Here's one of the logs:

Warning: Spoiler! [ Click to expand ]


Issues 2 and 3 are when playing Assassin's Creed Black Flag, haven't tried anything else this morning. Running Win7 x64. I downloaded and did a fresh reinstall 3-4 times, I've tried dx9, dx11 and dxgi (not that it matters?) and have same issues each time.

Thanks for your help.

-edit- Shader settings tab working now for some reason.
-edit2- I'm also unsure of why ReShade.fx (in the Black Flag main folder) is a .symlink file with a 0kb file size. From what I can tell, it's linking to itself. Is it meant to link to the ReShade.fx in whatever folder the assistant, etc. is in that is (currently for myself) 3kb file size?


I just found and fixed a compilation bug in one of the Grain shader. There might be more but that fix might also fix all your compiler problems. (let me know)
You can get the fix from here: github.com/crosire/reshade-shaders/tree/...eShade/Shaders/Alo81
The topic has been locked.
  • Posts: 5
4 years 2 months ago #186 by Jack_Frost
Thanks.

Updated the Grain shader file. Compiling still failing and no effects being applied. Same X3011 errors as well. I can test each shader if you want, but it seems to only happen with yours (Ganossa's). i.e. Marty's DOF giving no errors (not that I can see anyway). Sorry!
The topic has been locked.
  • Posts: 503
4 years 2 months ago #187 by Wicked Sick
I also get this error with Trine 3, 32 or 64 bits. The x3011.



the same preset I use for other games I used here.
The topic has been locked.
  • Posts: 790
4 years 2 months ago #188 by Ganossa
It appears that the error is likely related to the latest binary update.
Would you have a look at that @crosire?
The topic has been locked.
  • Posts: 60
4 years 2 months ago #189 by SilentPrayerCG

Ganossa wrote:

SilentPrayerCG wrote: I select entire value, i want to edit it, but it go in to "autofocus mode" and start chage focus by mouse over

also i checked, if select only part of value, it's fine, autofocus enabled only when i select entire value


I can change it to not enable auto-focus when you select the entire text in a field.


It will be great.
The topic has been locked.
  • Posts: 44
4 years 2 months ago - 4 years 2 months ago #190 by Bishi
I've also just downloaded Reshade 2.0.2f1 for the first time (before was using 0.19.2) and I am having big troubles with the assistant.
Seems almost completely unresponsive to mouse clicks etc.
I can click the default profile and then other tabs appear but I can't actually browse to them. If I spam click around the UI eventually I can get it to change to a tab but its basically unusable at the moment for me unfortunately :(
The topic has been locked.
  • Posts: 790
4 years 2 months ago #191 by Ganossa

Bishi wrote: I've also just downloaded Reshade 2 for the first time and I am having trouble with the assistant.
Seems almost completely unresponsive to mouse clicks etc.
I can click the default profile and then other tabs appear but I can't actually browse to them. If I spam click around the UI eventually I can get it to change to a tab but its basically unusable at the moment for me unfortunately :(


Looks like a bug then. Do you also use win10?
I will look into the issue.
The following user(s) said Thank You: Bishi
The topic has been locked.
  • Posts: 44
4 years 2 months ago #192 by Bishi
Yes, drivers 364.72 Windows 10, 980GTX SLI.

For what its worth I managed to get into the settings menu and change to software rendering but it didn't help.

Thanks for taking a look
The topic has been locked.
  • Posts: 503
4 years 2 months ago #193 by Wicked Sick
Thanks. if using the dlls from ReShade 2.0.1f4 reShade works just fine. Even with depth buffer. [link] i.imgur.com/XFyMyGv.jpg [/link]
The topic has been locked.
  • Posts: 3727
4 years 2 months ago #194 by crosire
The topic has been locked.
  • Posts: 503
4 years 2 months ago #195 by Wicked Sick
Just posted there. I am going to work now, thank you all and have a good day o//
The topic has been locked.
  • Posts: 51
4 years 2 months ago #196 by Dwill0328
The last two releases of reshade straight up do not work. Reshade 2.0.1f2 worked fine as i was able to select DX11 without issue. The last two releases the selector for the DX version just shows D3D9 as orange and no circle in box

How do you manually place the files into game directories with this new version of reshade?
The topic has been locked.
  • Posts: 790
4 years 2 months ago #197 by Ganossa

Dwill0328 wrote: The last two releases of reshade straight up do not work. Reshade 2.0.1f2 worked fine as i was able to select DX11 without issue. The last two releases the selector for the DX version just shows D3D9 as orange and no circle in box

How do you manually place the files into game directories with this new version of reshade?


You can select any API. The pre-selected one is only a suggestion. You should be able to select dxgi/d3d9/d3d11/... no matter what the initial suggestion is.
The topic has been locked.
  • Posts: 17
4 years 2 months ago - 4 years 2 months ago #198 by Zomgerd

Dwill0328 wrote: The last two releases of reshade straight up do not work. Reshade 2.0.1f2 worked fine as i was able to select DX11 without issue. The last two releases the selector for the DX version just shows D3D9 as orange and no circle in box

How do you manually place the files into game directories with this new version of reshade?


The same way you always have. You copy ReShade32.dll or ReShade64.dll (Corresponds with either 32bit or 64bit game titles), reshade.fx and the ReShade folder; Then paste it where the game's exe is, rename the ReShade dll to either d3d9, dxgi or opengl32 (whichever the game uses) and boom you're done.
The topic has been locked.
  • Posts: 3727
4 years 2 months ago #199 by crosire
Updated binaries to 2.0.3, which fixes the compiler bug that caused errors with some shaders.
The following user(s) said Thank You: brussell, Elimina, ahnion, unic0rn
The topic has been locked.
  • Posts: 307
4 years 2 months ago #200 by MonarchX
Crosire - thank you for another great update!

Dying Light - The Following - Enhanced Edition (GOG Version), as well as, Grim Dawn (GOG Version) - of course do not work with the latest version of ReShade. Its not a GAME problem, but the GOG tinkering itself, even when ALL GOG and GOG Galaxy-related files are completely removed from game directory. I also tried using cracked .exe files (I own legit GOG copy!) for the Steam version and the game would not load at all with that .exe with or without ReShade. The Steam version works fine, but I do not legally own it...

It is also true that ReShade 1.1.0 with either 1.1.0 DLL or 1.2.0 DLL (un-released Beta) files works great with the GOG version. Therefore, something in ReShade 2.0+ is different and it is not handling GOG's editions and their tinkering with .exe and .dll.

- Is it not possible for you to look through GOG version files (I assume EXE and DLL files) and compare them to the Steam version files? That would tell you the differences between the Steam version (that works with ReShade 2.0+) and the GOG version (that does not work with ReShade 2.0+) in regards to rendering.
- GOG version comes with organic/native D3D11.dll and DXGI.dll files, which are not required to run the game and can be deleted/moved, but maybe they are the key or the answer as to why ReShade 2.0+ fails to work with the GOG versions of several GOG games? These files are obviously rendering-related - maybe overlay or whatever else, but they are the organic/native files that were made for the GOG version EXE .
- What can I do to help??? Sending LOG files was not helpful. Maybe there are more advanced/thorough LOG files that ReShade can create or maybe there is a way to run it in DEBUG mode? I can send you all the EXE and DLL files - they are small in size and it would NOT be considered piracy since you wouldn't get the actual content. It would be purely for ReShade development.
The topic has been locked.