4.8

More
4 weeks 1 day ago #41 by Flashouille
Replied by Flashouille on topic 4.8
Ok.. Thanks!

Please Log in or Create an account to join the conversation.

More
4 weeks 9 hours ago #42 by esanscoopsers
Replied by esanscoopsers on topic 4.8
Is there a resource that explaines what all the shaders in the shader library do? Preferably for 4.7 since 4.8 doesn't have the pirate shaders. Also are we just waiting for those to be updated to 4.8 or are they just abandoned? Thanks to anyone who helps.

Please Log in or Create an account to join the conversation.

More
4 weeks 4 hours ago #43 by Crolug
Replied by Crolug on topic 4.8
4.8.1 crashes Dungeons & Dragons Online.
000000000.000: Initializing client - build version is [4700.0049.3779.4004.RELEASE]
000000000.000: Initializing the global event handler...
000000000.000: Creating trigger schedulers...
000000000.000: Initializing the network...
000000000.000: Initializing the cache...
000000000.000: CLCache::Init: called.
000000000.000: LookForFile trying cwd
000000000.000: Is_File_Here found 'client_general.dat' in 'c:/Games/Steam/steamapps/common/Dungeons and Dragons Online'
000000000.000:

DiskCon::InitFile:
  datfile "client_general.dat" stamped with datpack versions eng:112, game:3,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_highres.dat" stamped with datpack versions eng:112, game:3,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_gamelogic.dat" stamped with datpack versions eng:112, game:3,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_anim.dat" stamped with datpack versions eng:112, game:3,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_mesh.dat" stamped with datpack versions eng:112, game:3,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_sound.dat" stamped with datpack versions eng:112, game:3,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_surface.dat" stamped with datpack versions eng:112, game:3,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_cell_1.dat" stamped with datpack versions eng:112, game:0,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_map_1.dat" stamped with datpack versions eng:112, game:0,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_cell_2.dat" stamped with datpack versions eng:112, game:0,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_map_2.dat" stamped with datpack versions eng:112, game:0,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_cell_3.dat" stamped with datpack versions eng:112, game:0,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_map_3.dat" stamped with datpack versions eng:112, game:0,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_cell_4.dat" stamped with datpack versions eng:112, game:0,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_map_4.dat" stamped with datpack versions eng:112, game:0,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000:

DiskCon::InitFile:
  datfile "client_local_English.dat" stamped with datpack versions eng:112, game:3,
  executable supporting datpack versions eng:-1, game: -1.

000000000.000: Initializing display with title 'Dungeons and Dragons Online'...
000000000.000: Device_WIN32::Init: called.
000000000.000: Device_WIN32::InitDEVICE|  Detected operating system: Windows 7
000000000.000: Initializing the smartbox...
000000000.000: Initializing the user interface...
000000000.000: Client ready
000000004.204: ----CRASH REPORT START----
000000004.204: Program fault: ACCESS_VIOLATION (0xc0000005) trying to read from 0x0000000000000018
000000004.204: Detailed report:

Current local time: Fri Oct 30 19:13:10 2020


Version Report generated by CoreVersion : 2.0.143.1 (0x0200008F):
  Language: English (United States)
  CompanyName : Standing Stone Games, LLC.
  FileDescription :
  FileVersion : 4700.0049.3779.4004
  InternalName : dndclient64
  LegalCopyright : Copyright � 2016-2020 Standing Stone Games, LLC.
  OriginalFilename : dndclient64.exe
  ProductName : dndclient64
  ProductVersion : 4700.0049.3779.4004 dnd_live
  Comments : compiled Sun Oct 18 16:28:55 2020 : RELEASE
  TurbineBuildVersion : 4700.0049.3779.4004.RELEASE
  TurbineType : Admin External

Version information for error module C:\Games\Steam\steamapps\common\Dungeons and Dragons Online\x64\dxgi.dll:
  Language: Process Default Language
  CompanyName : crosire
  FileDescription : crosire's ReShade post-processing injector for 64-bit
  FileVersion : 4.8.1.924
  LegalCopyright : Copyright � 2014. All rights reserved.
  OriginalFilename : ReShade64.dll
  ProductName : ReShade
  ProductVersion : 4.8.1



000000004.204: ----CRASH REPORT END----

Please Log in or Create an account to join the conversation.

More
3 weeks 6 days ago - 3 weeks 6 days ago #44 by Liltheris
Replied by Liltheris on topic 4.8 - Swtor not loading Reshade

Krasius wrote:

Liltheris wrote: Hi there, i've been running Reshade with Swtor for the better part of two years now. As of recently, it no longer loads with the game. This has also occurred with every other version of reshade I have tried.
I have attempted to use Dx9, Dx10, OpenGL and Vulkan to no avail.
I'd appreciate any advice on this.

GPU: GTX 1070
Driver version: 27.21.14.5655

Windows 10 Pro 1909, build 18363.1139.

Any further info that is needed I can happily provide.


Try older Nvidia driver, Reshade doesn't work with newer Nvidia driver for Swtor. I'm using version 452.06



Hey dude, thanks for that!
That worked a charm for me.
Last edit: 3 weeks 6 days ago by Liltheris.

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago #45 by lowenz
Replied by lowenz on topic 4.8 - Swtor not loading Reshade
"Removed global settings ("ForceFullscreen", "Force10BitFormat", etc.) from ReShade.ini and instead moved those into d3d9.ini/dxgi.ini/opengl32.ini file"

Can you choose other names for those files cause other wrappers can use them.....

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago #46 by crosire
Replied by crosire on topic 4.8 - Swtor not loading Reshade
No they can't: It is the same name as the ReShade DLL. I just gave an example. Same INI as the "[INSTALL]" section.

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago #47 by BigDuck
Replied by BigDuck on topic 4.8
Hey Crosire, thought I'd let you know that OBS on AMD cards (Vega 56) doesn't capture reshade and its effects in the dolphin emulator running on the Vulkan backend. Reshade appears and works fine in the emulator now when I'm playing it in person, thank you, but it's absent in my recordings. Cemu for example on the Vulkan backend, when I record it picks up my reshade fine

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago #48 by crosire
Replied by crosire on topic 4.8
That is not under ReShade's control. It depends on the order Vulkan layers are loaded. If OBS is loaded before ReShade, it won't capture ReShade effects. If it is loaded after ReShade, it will. Changing that as a user is not trivial to do though.

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #49 by BigDuck
Replied by BigDuck on topic 4.8
Yeah, I thought that would be the case. What would you mean by changing the order, sorry for my ignorance but starting up a game in dolphin for example and after launching OBS? Or is it more complicated than that. I also wouldn't have any idea on rearranging Vulkan layers. Thank you for your help

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #50 by crosire
Replied by crosire on topic 4.8
The only way to influence the layer order from outside the app is to set an environment variable "VK_INSTANCE_LAYERS" to "VK_LAYER_reshade,VK_LAYER_OBS_hook" (they are added left to right). But never tried that.

Please Log in or Create an account to join the conversation.

More
3 weeks 3 days ago #51 by pyewacket
Replied by pyewacket on topic 4.8
Is there a way to fix mouse input in HZD? Mouse clicks still getting through while overlay is active.

Please Log in or Create an account to join the conversation.

More
3 weeks 2 days ago #52 by OtisInf
Replied by OtisInf on topic 4.8
@crosire: In WD Legion, reshade has a problem with mouse blocking/capturing again like in some earlier versions: the mouse stays in a small bounding box when the reshade overlay is opened inside the game. When the menu is up it's of course fixed.

Something I can test/check? Can't attach a debugger as the game will then exit, but perhaps test some code out to see if that works. Looks like (but wild guess!) that the mouse capturing is inside a small window, not in the game window. Happens in fullscreen/windowed borderless/windowed.

Please Log in or Create an account to join the conversation.

More
3 weeks 2 days ago #53 by OtisInf
Replied by OtisInf on topic 4.8

pyewacket wrote: Is there a way to fix mouse input in HZD? Mouse clicks still getting through while overlay is active.

The mouseclicks getting through is because of the steam SDK grabbing it, and passing them on as input to the game. In my HZD tools I blocked them at the game level but it's not possible to do so at a generic level with message blocking or raw input blocking like in most games, as the mouse event has already been registered by then. So this is unfixable (as far as I can see, I couldn't find a way to block them in any way, other than directly hooking into the game) :)

Please Log in or Create an account to join the conversation.

More
3 weeks 2 days ago #54 by crosire
Replied by crosire on topic 4.8

OtisInf wrote: Something I can test/check? Can't attach a debugger as the game will then exit, but perhaps test some code out to see if that works. Looks like (but wild guess!) that the mouse capturing is inside a small window, not in the game window. Happens in fullscreen/windowed borderless/windowed.

Sounds like the game is using ClipCursor to keep the cursor in a fixed rectangle. ReShade should already hook that: github.com/crosire/reshade/blob/30726184...ource/input.cpp#L583
But it may be that the game is not actually calling this every frame, but at some point when "is_blocking_mouse_input()" does not report "true" yet (because the overlay is not open). So I'd try removing that check (and also maybe log calls to ClipCursor to see if the game is actually using it). Can also try calling "ClipCursor(nullptr)" in the on_present hook to overwrite what the game set.

Please Log in or Create an account to join the conversation.

More
3 weeks 2 days ago #55 by OtisInf
Replied by OtisInf on topic 4.8
Adding ClipCursor(nullptr); to the on_present hook is all it takes to fix it. :) Game uses ClipCursor, but changing anything in HookClipCursor didn't help, the call to ClipCursor(nullptr); fixes it.

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #56 by BigDuck
Replied by BigDuck on topic 4.8

crosire wrote: The only way to influence the layer order from outside the app is to set an environment variable "VK_INSTANCE_LAYERS" to "VK_LAYER_reshade,VK_LAYER_OBS_hook" (they are added left to right). But never tried that.

Yikes I have no idea on this coding stuff. Thank you for your help Crosire

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago - 3 weeks 1 day ago #57 by tOXicSilence
Replied by tOXicSilence on topic 4.8

pyewacket wrote: Is there a way to fix mouse input in HZD? Mouse clicks still getting through while overlay is active.


I solved this by getting into "Photo Mode" and making my shader adjustments there.

The game also still renders when paused but I can't remember if it applies a vignette or darkens the image somewhat.
Last edit: 3 weeks 1 day ago by tOXicSilence.

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #58 by Aztec2012
Replied by Aztec2012 on topic 4.8
Red Dead Redemption 2 not starting on 4.8.2. On 4.7 all works fine.

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #59 by SpajdrEX
Replied by SpajdrEX on topic 4.8
Is there a option to disable when installing reshade a shaders that currently does not work with reshade 4.8.2? I mean like half of them shows various errors or show error later when you try to run them.

Please Log in or Create an account to join the conversation.

More
2 weeks 4 days ago #60 by OtisInf
Replied by OtisInf on topic 4.8

Aztec2012 wrote: Red Dead Redemption 2 not starting on 4.8.2. On 4.7 all works fine.

I use 4.8.2 build from source in rdr2 and it works fine when using dx12. Do you use vulkan? when you switch to dx12 does it work then?

Please Log in or Create an account to join the conversation.