4.8

More
10 months 1 week ago #61 by Aztec2012
Replied by Aztec2012 on topic 4.8

Red Dead Redemption 2 not starting on 4.8.2. On 4.7 all works fine.

I use 4.8.2 build from source in rdr2 and it works fine when using dx12. Do you use vulkan? when you switch to dx12 does it work then?


I use Vulkan. I cant switch to dx12. My videocard not full supported dx12.
The topic has been locked.
More
10 months 1 week ago - 10 months 1 week ago #62 by Skinner
Replied by Skinner on topic 4.8
I don't know if I'm doing something wrong, the engine/game simply is not suitable (depth acces) or what, but I still cann't RTGI getting to work in Far Cry 5 and Chernobylite.
Probably more, I'm still transferring all my games to this piece of art called RTGI, it enhance my games so beatifully!
Last edit: 10 months 1 week ago by Skinner.
The topic has been locked.
More
10 months 1 week ago #63 by villings
Replied by villings on topic 4.8

Is there a option to disable when installing reshade a shaders that currently does not work with reshade 4.8.2? I mean like half of them shows various errors or show error later when you try to run them.

I don't know what game are you using but -- I'm playing fallout 4, rolled back a couple versions and eveything works fine. I know it's not the ideal solution but you can always check back here and see when all the little inconveniences are finally solved.
The topic has been locked.
More
10 months 1 week ago #64 by DaelosTheCat
Replied by DaelosTheCat on topic 4.8
Would anyone happen to know how to get ReShade to remember a selected depth buffer? With some games ReShade automatically detects the correct one. But sometimes I need to manually select it in the Dx11 tab. However, upon restart (or alt-tab) it resets. How do I get ReShade to stick to the selected depth buffer after restart?
The topic has been locked.
More
10 months 6 days ago #65 by Cruhquet
Replied by Cruhquet on topic 4.8 effect values gone
Hi, when I updated to 4.8 my effect values are gone- I can't configure the values of the effects I use. Tried reloading, nothing. Help!
The topic has been locked.
More
10 months 6 days ago #66 by crosire
Replied by crosire on topic 4.8 effect values gone
Pull up the blue line at the bottom of the window.
The topic has been locked.
More
10 months 6 days ago #67 by YusufCardinal
Replied by YusufCardinal on topic 4.8
Has the way the depth buffer is being fetched changed since 4.3.0? I updated the plugin and can no longer enjoy those effects on some of my OpenGL games :(

By the way, thank you for the incredible work <3
The topic has been locked.
More
9 months 4 weeks ago - 9 months 4 weeks ago #68 by lowenz
Replied by lowenz on topic 4.8
Issue in Bloodrayne (original release from 2002, not the Terminal Cut), using d3d8to9 converter (lastest version, provided binaries or self-built ones). The issue is NOT present using dgVoodoo2 (dgVoodoo2+ReShade -> works like a charm) !

ReShade initializes but I can't see nothing on screen.
Log:

14:18:19:204 [01772] | INFO | Initializing crosire's ReShade version '4.8.2.930' (32-bit) built on '2020-10-31 14:07:19' loaded from "E:\BloodRayne\d3d9.dll" into "E:\BloodRayne\rayne.exe" ...
14:18:19:220 [01772] | INFO | Registering hooks for "user32.dll" ...
14:18:19:220 [01772] | INFO | > Libraries loaded.
14:18:19:220 [01772] | INFO | > Found 14 match(es). Installing ...
14:18:19:235 [01772] | INFO | Registering hooks for "ws2_32.dll" ...
14:18:19:235 [01772] | INFO | > Libraries loaded.
14:18:19:235 [01772] | INFO | > Found 8 match(es). Installing ...
14:18:19:251 [01772] | INFO | Registering hooks for "C:\WINDOWS\system32\d2d1.dll" ...
14:18:19:251 [01772] | INFO | > Delayed.
14:18:19:251 [01772] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d9.dll" ...
14:18:19:251 [01772] | INFO | > Delayed until first call to an exported function.
14:18:19:251 [01772] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d10.dll" ...
14:18:19:251 [01772] | INFO | > Delayed.
14:18:19:251 [01772] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d10_1.dll" ...
14:18:19:251 [01772] | INFO | > Delayed.
14:18:19:251 [01772] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d11.dll" ...
14:18:19:251 [01772] | INFO | > Delayed.
14:18:19:251 [01772] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d12.dll" ...
14:18:19:251 [01772] | INFO | > Delayed.
14:18:19:251 [01772] | INFO | Registering hooks for "C:\WINDOWS\system32\dxgi.dll" ...
14:18:19:251 [01772] | INFO | > Delayed.
14:18:19:251 [01772] | INFO | Registering hooks for "C:\WINDOWS\system32\opengl32.dll" ...
14:18:19:251 [01772] | INFO | > Delayed.
14:18:19:251 [01772] | INFO | Initialized.
14:18:19:251 [01772] | INFO | Redirecting Direct3DCreate9(SDKVersion = 32) ...
14:18:19:251 [01772] | INFO | Installing export hooks for "C:\WINDOWS\system32\d3d9.dll" ...
14:18:19:251 [01772] | INFO | > Found 9 match(es). Installing ...
14:18:19:302 [01772] | INFO | Redirecting Direct3DCreate9(SDKVersion = 32) ...
14:18:20:588 [01772] | INFO | Exiting ...
14:18:20:588 [01772] | INFO | Uninstalling 36 hook(s) ...
14:18:21:668 [01772] | INFO | Finished exiting.
Last edit: 9 months 4 weeks ago by lowenz.
The topic has been locked.
More
9 months 3 weeks ago #69 by Light5hade
Replied by Light5hade on topic 4.8
Maybe I missed something but I have not been able to find a way to deselect the Standard Effects (utility shaders) which I never use so they just always clutter things up?
The topic has been locked.
More
9 months 3 weeks ago #70 by crosire
Replied by crosire on topic 4.8
They cannot be deselected because that package contains headers that all other effects use. Not installing it would break all effects.
The topic has been locked.
More
9 months 3 weeks ago #71 by Light5hade
Replied by Light5hade on topic 4.8
Crosire, Thanks for replying. I really appreciate you and Reshade. I have been using it for most of my games since the SweetFX only days and this is my first time posting. All previous releases did not require seeing these utility shaders. Also when I install 4.82 there is an extra dx11 tab that pops up? Perhaps I will just stay with 4.7? I guess I would consider myself the average user and this is just my two cents for what it is worth.
The topic has been locked.
More
9 months 2 weeks ago #72 by dark1970
Replied by dark1970 on topic 4.8
When the game is minimized in d3d9 mode (Black Mesa and G String), all memory is sharply clogged (from 5GB to 16GB) and the crash! 8700k 1070 16GB Windows 10x64 20H2! Crashes with Reshade 4.8.0 --- 4.8.2! With Reshade 4.7.0 works fine!
The topic has been locked.
More
9 months 3 days ago - 9 months 3 days ago #73 by Torzi
Replied by Torzi on topic 4.8
Hello, I'm trying to get Cyberpunk 2077 working with SuperDepth3D, and I'm pretty sure I found the reason why it's not. I was wondering if you had any input on solutions.

I see in the aspect ratio heuristics section of \d3d12\state_tracking.cpp (at line 256), that it's picking the depth map with the greatest number of draw calls or vertices. There are typically two maps at the game's resolution for each screen, but sometimes as many as four (that I've seen). What I've found is that the proper depth map for this game typically has the second highest counts for both calls and vertices. There is also a game setting that will corrupt this map, but doesn't cause a problem if left alone (Color Precision must be left at High).

Manually selecting/locking the proper map works sporadically, but usually causes the game to crash. What's the best way to get Reshade to pick that map with the 2nd highest count automatically for each scene? And out of curiosity, has any other game ever worked like this?

Last edit: 9 months 3 days ago by Torzi. Reason: Images
The topic has been locked.
More
9 months 3 days ago #74 by Martigen
Replied by Martigen on topic 4.8

Hello, I'm trying to get Cyberpunk 2077 working with SuperDepth3D, and I'm pretty sure I found the reason why it's not. I was wondering if you had any input on solutions.

Just wanted to add that I was going to post something to see if @Crosire could create a fix, but you did a better job of explaining what appears to be happening.

I'm not using Superdepth3D, just Marty's RTGI, but the same issue applies of course with the depth buffer.
The topic has been locked.
More
9 months 2 days ago #75 by OtisInf
Replied by OtisInf on topic 4.8
If it helps, selecting the depth buffer using 4.7 doesnt crash the game.

Manually selecting the buffers is often a minigame in itself as every other frame a new one pops up and due to the sorting things flip a lot up and down so checking the right checkbox is... hard :)
The topic has been locked.
More
9 months 2 days ago - 9 months 2 days ago #76 by Tojkar
Replied by Tojkar on topic 4.8

If it helps, selecting the depth buffer using 4.7 doesnt crash the game.


I cannot agree with you on this. The crashes are seemingly more random. Sometimes it allows to play many hours, sometimes it crashes before even loading the game many times in a row. For some reason rebooting computer seems to help a little. As the crashes are more frequent and random, I cannot be 100% sure changing depth buffer crashes, but I've definitely had it crash too many times to be usable even in that situation.

4.8 is definitely more stable, but anything depth related is useless. I've had it crash even when just enabling a new shader that uses depth. When ignoring anything that uses depth buffer, the game hasn't crashed once.
Last edit: 9 months 2 days ago by Tojkar.
The topic has been locked.
More
9 months 2 days ago #77 by Torzi
Replied by Torzi on topic 4.8
I don't have any problems selecting the buffer... I think the issues arise from keeping Reshade locked to that specific buffer. Changing in-game graphics settings usually cause a crash fairly quickly. Just a guess, but I'd bet when the map get reinitialized (or dumped, and created somewhere else), that's when the crash occurs.

The bigger issue comes later. Early in the game (at least on my play-through), the locked buffer did actually get reused as I moved from screen to screen. I was able to make it a good way into the 'prologue' by not touching the settings. There's a really strange transition point though where that no longer works, and all of a sudden each new screen uses a different depth buffer. Re-using the old one corrupts the image with a lot of black area. This is makes the city map screen unusable unless you go in and select the buffer again. But if you keep that new one locked, and switch back to the world view, the game crashes.

Very odd behavior. I can even reload an old save where everything is sorta working fine, but then you hit this wall (usually causing a crash), and it no longer works past that point.
The topic has been locked.
More
8 months 4 weeks ago #78 by gottenspell
Replied by gottenspell on topic 4.8
When will the next update be, at least approximately? It's just that I don't understand anything about compiling from source.
The topic has been locked.
More
8 months 4 weeks ago - 8 months 4 weeks ago #79 by crosire
Replied by crosire on topic 4.8
First week(s) of next year approximately. I won't get to it around the holidays this year anymore.
Last edit: 8 months 4 weeks ago by crosire.
The following user(s) said Thank You: Marty, mirt81, gottenspell
The topic has been locked.
More
8 months 3 weeks ago - 8 months 3 weeks ago #80 by mirt81
Replied by mirt81 on topic 4.8
PerformanceMode lets ReShade Startup load Fail . . .
Last edit: 8 months 3 weeks ago by mirt81.
The topic has been locked.