4.5

  • Posts: 8
4 months 1 week ago #141 by xNameleSSx
Looks like depth buffer detection broken in Fallout New Vegas. Screen height always detects as 1024
imgur.com/a/LHYgzvm
With Reshade 4.3 it works fine, but 4.4 and newer looks buggy.
The topic has been locked.
  • Posts: 20
4 months 1 week ago #142 by Rayman_77
Depth buffer no work Rage 2?
The topic has been locked.
  • Posts: 1
4 months 1 week ago #143 by killakingkrow
anybody else having an issue where the dxgi.ini file will not install for dx10 games and higher?
The topic has been locked.
  • Posts: 66
4 months 1 week ago #144 by aaronth07
Amazing work, I love the new application selection UI (though maybe it should be sorted by last used like NVIDIA Control Panel does) and the repository UI. Though, is there a way to set a local folder as a repository? Or does it have to be a link/Github?
The topic has been locked.
  • Posts: 7
4 months 3 days ago #145 by Great_Dragon
I found there are 2 versions on the latest 4.5.3 release of the file. 756 and 757.

Each of them works with one games but has no effect of the others.
Like I got 756 working with "The Incredible adventues of Van Helsing" but 757 doesn't work.
At the same time 757 works fine with "Kingdom Come Deliverence" but 756 fails to load.
The topic has been locked.
  • crosire
  • crosire's Avatar Topic Author
  • Away
  • Posts: 3727
4 months 3 days ago #146 by crosire
Well yes, one is the 32-bit version, the other the 64-bit version.
The topic has been locked.
  • Posts: 7
4 months 3 days ago #147 by Great_Dragon
@crosire
Thanks. I thougt one DLL contailns both versions.
I prefer copy-paste installation of ReShade thus I usually run newest installer once just to get an updated DLL and that is it.
Do you have any plans to have just zip/7z package of the ReShade along with regular installer?
The topic has been locked.
  • crosire
  • crosire's Avatar Topic Author
  • Away
  • Posts: 3727
4 months 3 days ago #148 by crosire
You can open the setup tool with most Zip tools (7-zip, ...). It is written to act like a self-extracting archive to them
The topic has been locked.
  • Posts: 5
4 months 23 hours ago #149 by ScreamerofStars
This is Kinda an old issue but Reshade doesnt work on Warcraft 3 from 1.27 and onwards
The topic has been locked.
  • Posts: 2
3 months 4 weeks ago #150 by OlderedJohnStalvern
Is anyone having success with Rpcs3 Vulkan on AMD Radeon cards?

I'm trying everything but reshader won't hook on rpcs3 Vulkan, error "Failed to initialize Vulkan runtime environment", rpcs3 opengl hooks fine.

Warning: Spoiler! [ Click to expand ]
The topic has been locked.
  • Posts: 31
3 months 4 weeks ago - 3 months 4 weeks ago #151 by derrame
Hi

It doesn¡t work with DirectX 12 and Metro Exodus
The topic has been locked.
  • Posts: 7
3 months 4 weeks ago - 3 months 4 weeks ago #152 by Great_Dragon
"This is Kinda an old issue but Reshade doesnt work on Warcraft 3 from 1.27 and onwards"
I have Warcaft 3 (classic version) updated with 1.27b offline installer and ReShade works fine with it.

* Added warning message when access to depth buffers is disabled because of network activity
That new update for Network activity makes ReShade flickers because of missing Deapth Buffer until you Alt-Tab from the game (I'm using MXAO for The Invredible Adventure of Van Helsing). I didn't have the issue with 4.5.3
The topic has been locked.
  • Posts: 27
3 months 4 weeks ago #153 by Khronikos
Great stuff bro. I have next to zero concerns. Updating is easier, and no more crashing when selecting nothing. The only improvement would be to just update and not even see that screen. Nothing major though. Reshade has come a long way since two years ago. Congrats.

Will have to buy you a beer through Patreon soon.
The following user(s) said Thank You: crosire
The topic has been locked.
  • Posts: 8
3 months 4 weeks ago #154 by xNameleSSx
Vulkan now works on AMD with 4.5.4. That's great! RPCS3 and Surge 2 works fine.
The topic has been locked.
  • Posts: 8
3 months 4 weeks ago - 3 months 4 weeks ago #155 by solidforger
Still doesn't work (won't even start) with Steam RDR2 running on Vulkan. Maybe there's something I'm missing? I'm using an RX 580 btw.
The topic has been locked.
  • Posts: 8
3 months 4 weeks ago #156 by dddfault

solidforger wrote: Still doesn't work (won't even start) with Steam RDR2 running on Vulkan. Maybe there's something I'm missing? I'm using an RX 580 btw.


can you provide me the log ?
show it as spoiler on the reply, or use pastebin
The topic has been locked.
  • crosire
  • crosire's Avatar Topic Author
  • Away
  • Posts: 3727
3 months 4 weeks ago - 3 months 3 weeks ago #157 by crosire
You have to enable ReShade globally or leave the setup tool running (as admin) for it to work in Vulkan. The setup tool will tell you as much.
The topic has been locked.
  • Posts: 17
3 months 4 weeks ago #158 by Birdy62
Waow... all my Vulkans games are now working..
No mans sky
-Rdr2
-Rage2
-The new colossus
-Doom
Its really a great job. Thank you very much...
The following user(s) said Thank You: crosire
The topic has been locked.
  • Posts: 2
3 months 3 weeks ago #159 by OlderedJohnStalvern
Can also confirm. RPCS3 Vulkan working on Radeon cards now.
All shaders working fine.

Thanks for taming the AMD driver.
The topic has been locked.
  • Posts: 27
3 months 3 weeks ago - 3 months 3 weeks ago #160 by Khronikos
When you update, does Reshade generate a brand new ini? I noticed a few of the update notes, and does the ini matter for different APIs and new versions of Reshade? I was wondering because I am not sure if Reshade completely overwrites the ini or changes anything when updating. I am starting over, and I have everything perfect right now. I was just wondering how ini's work with updating a previous install. I thought one update reset color, but it's so easy to set back I didn't even really notice and was not sure if I changed settings. I was also curious if ini's mattered across APIs. I can't really see too much in them that would matter, but was not sure.

Thanks again for the good work.
The topic has been locked.