Compatibility list

More
5 years 8 months ago #141 by SpinelessJelly
Replied by SpinelessJelly on topic Compatibility list
The Void

Working, depth buffer working, hook d3d9.dll

Tested with Reshade 1.13.2, Master Effects 1.0.340. No luck with custom GDST though.
The following user(s) said Thank You: Omnipotus

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #142 by Omnipotus
Replied by Omnipotus on topic Compatibility list
Just updated the Compatibility List [/url] again with everyones updates, I threw in a "couple" myself :)

Should be another large list to follow, either tonight or tomorrow.

Smootches! :D

Added

Gish
Goodbye Deponia
Heroine's Quest
Homefront
Humanity Asset
I Am Vegend
Iron Grip: Warlord
Joylancer
KickBeat Steam Edition
Kill the Bad Guy
Kingdom Rush
King's Bounty: Warriors of the North
Legend of Grimrock
Luftrausers
Luxor Evovled
Manhunter
Magnetic by Nature
Mini Motor Racing
Muffin knight
Need for Speed: Hot Pursuit (2010)
Nosferatu: The Wrath of Malachi
Onikira: Demon Killer
Call of Duty: Black Ops II
Race the Sun
RADical Roach Deluxe Edition
Reaper: Tale of a Pale Swordsman
Resident Evil 6
Resident Evil: Revelations
Rush for Glory
Sacred Citadel
Saints Row: Gat out of Hell
Savant: Ascent
Scourge: Outbreak
Shadow Warrior
Shadowrun: Dragonfall Director's Cut
Shadowrun Returns
Silence of the Sleep
Sleeping Dogs
Snuggle Truck
SOL: Exodus
Stick it to the Man
Super Comboman
Super House of Dead Ninjas
Ultra Street Fighter IV
Super Toy Cars
The Book of Unwritten Tales
The Book of Unwritten Tales 2
The Book of Unwritten Tales: The Critter Chronicles
The Last Tinker City of Colors
The Shopkeeper
Vessel
Viking: Battle for Asgard
VVVVVV
Wrack
Xiotic
Zeno Clash

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #143 by strelokgunslinger
Replied by strelokgunslinger on topic Compatibility list
Dying Light
0.13.2

DirectX 11 and x64

Normal effects work + No Depthbuffer - All Black [no white :P]

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #144 by GERgta
Replied by GERgta on topic Compatibility list
I mainly played around with Underground 2 (which was tons of fun), but I also tried those unlisted games:
- Need For Speed Underground 1 (DX9, 32bit): Everything works.
- Need For Speed Pro Street (DX9, 32bit): Everything works.
- Minecraft (OpenGL, 32bit/64bit [Only tried on 64bit]): It works, although some colors seem to invert (Blue and Red). Can anyone else confirm this problem?

EDIT: Minecraft works perfectly now, I just had to upgrade my gfx drivers. There's no proper depthbuffer tho: the only thing that outputs is the HUD after closing the pause menu, but only for a short time.
Last edit: 5 years 8 months ago by GERgta.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #145 by strelokgunslinger
Replied by strelokgunslinger on topic Compatibility list
@Gergta, update your gfx drivers
The following user(s) said Thank You: GERgta

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #146 by GERgta
Replied by GERgta on topic Compatibility list
@strelokgunslinger:
Awesome, it works perfectly now :) Thank you!

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #147 by Tom Yum 72
Replied by Tom Yum 72 on topic Compatibility list

strelokgunslinger wrote: Dying Light
0.13.2

DirectX 11 and x64

Normal effects work + No Depthbuffer - All Black [no white :P]


Confirm that, got the usual things working...but SADLY not Dof.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #148 by JPulowski
Replied by JPulowski on topic Compatibility list
Grim Fandango Remastered: 32-bit, OpenGL. Good, no depth-buffer. Trying to activate depth buffer gives the following error: "ERROR | Failed to create depth texture with error code 1280".

Update:
Brothers - A Tale of Two Sons: 32-bit, D3D9. Good, no depth-buffer.
Last edit: 5 years 8 months ago by JPulowski.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #149 by strelokgunslinger
Replied by strelokgunslinger on topic Compatibility list
@Tom Yum, so you know for next time... depth buffer is what allows dof to work, so if no Depth buffer then no dof

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago - 5 years 7 months ago #150 by ninjafada
Replied by ninjafada on topic Compatibility list
heroes of might and magic 3 HD (new edition in hd) and Might & Magic Heroes VI works perfect in directx9

in the game list you have Final Fantasy XIV and World of Warcraft in perfect, should be good
Last edit: 5 years 7 months ago by ninjafada.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #151 by Tom Yum 72
Replied by Tom Yum 72 on topic Compatibility list

strelokgunslinger wrote: @Tom Yum, so you know for next time... depth buffer is what allows dof to work, so if no Depth buffer then no dof


Yeah, i know...i tried that before i saw your post and then just came here to confirm that. ;) Would be great to have dof in that game, hope its possible to do that.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #152 by SunBroDave
Replied by SunBroDave on topic Compatibility list
Star Wars: Knights of the Old Republic - v0.13.2 - OPENGL32.dll - works perfectly

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago - 5 years 7 months ago #153 by strelokgunslinger
Replied by strelokgunslinger on topic Compatibility list
does KOTOR use opengl.. wow .. I need to reinstall those 2

@TomYum

Game has dof, the only use for custom dof would be for screenshots, but we need Dev Mode unlocked Chrome Engine 6 for freecam
Last edit: 5 years 7 months ago by strelokgunslinger.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago - 5 years 7 months ago #154 by Tom Yum 72
Replied by Tom Yum 72 on topic Compatibility list

strelokgunslinger wrote: @TomYum
Game has dof, the only use for custom dof would be for screenshots, but we need Dev Mode unlocked Chrome Engine 6 for freecam


Yes, i know that the Game has Dof, but only in cutscenes and its very demanding too. Now imagine we can use for example "Magig Dof " at the cost of zero loss, for screenshots AND ingame. Autofocus dof, etc etc.

@Topic : games i tried so far:
Transformers fall of cybertron, Batman Arkham City and Origins, Castlevania LOS 1+2...all of them work perfectly.
Last edit: 5 years 7 months ago by Tom Yum 72.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago - 5 years 7 months ago #155 by Chonko
Replied by Chonko on topic Compatibility list
Beyond Good and Evil + Reshade : that's good but AO and DOF (blurry screen except with Matsodof) don't work. Maybe I made a mistake. Edit : no Depth buffer.

Darksiders 1 : Reshade works fine . Some fps drops ( I run the game in 1440p) with my settings ( i7 4770k + 16 go + gtx 970)
Last edit: 5 years 7 months ago by Chonko.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #156 by Wicked Sick
Replied by Wicked Sick on topic Compatibility list
Fahrenheit (Indigo Prophecy) crashes after selecting the profile, may crash even before that. This is the log file:

pastebin.com/7QWttPXP

However, if you disable Steam overlay, the game will boot up just fine:

i.imgur.com/TOEpjTW.jpg


PS: I am not sure if I should post this here or somewhere else. Sorry.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago - 5 years 7 months ago #157 by BillyAlt
Replied by BillyAlt on topic Compatibility list
Tested with 0.13.2

-Halo 2 for Windows Vista (tested in Windows 8 ) everything works almost perfectly, FPS hands and gun model don't show up in depthbuffer.
Last edit: 5 years 7 months ago by BillyAlt.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago - 5 years 7 months ago #158 by strelokgunslinger
Replied by strelokgunslinger on topic Compatibility list
S.T.A.L.K.E.R. - Shadow of Chernobyl [RUS/CIS]
Russian and Communist Independent States region..

Not worldwide

d3d9.dll / x86





Mod used was OGSE 0.6.9.3 Open Beta
Last edit: 5 years 7 months ago by strelokgunslinger.

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #159 by ScarecrowDM
Replied by ScarecrowDM on topic Compatibility list
"The Forest" is a D3D9 game, not an OpenGL one.
The following user(s) said Thank You: crosire

Please Log in or Create an account to join the conversation.

More
5 years 7 months ago #160 by JPulowski
Replied by JPulowski on topic Compatibility list
Life Is Strange:
Tested with 0.13.2.
32-bit, D3D9.
Good, depth buffer is empty.

Please Log in or Create an account to join the conversation.