Welcome, Guest.
Username: Password: Remember me

TOPIC: qUINT

qUINT 1 year 5 months ago #61

Scorpio82CO wrote:
thats maybe that you want to turn off the lightroom shader?, other thing is that you use other effects than lut shader.. only just going to work lut shader, the other instance is put the lut shader at the bottom of the list
If this doesn´t work try to put over the lut a shader called S-curve, and adjust the values,

I did actually turn Lightroom off. Like I said, no shader was enabled aside from the one specified for each screenshot. I also made sure to disable all other effects before taking the original screenshot containing the LUT generated by Lightroom.
The administrator has disabled public write access.

qUINT 1 year 4 months ago #62

re: Lightroom
I assume this is all internal adjustments correct? Is it possible to export a screenshot, make adjustments within Photoshop (real time) then export back into Reshade as color revised LUT?
Last Edit: 1 year 4 months ago by magicart87.
The administrator has disabled public write access.

qUINT 1 year 4 months ago #63

Alabrand wrote:
For some reason ADoF doesn't work properly in FFXIV. No matter what I do the background won't change to the intended effect. Instead what happens is that the foreground is permanently blurry, but it's not the good kind of blurry. FWIW, the older and normal DoF shaders in the regular Reshade package works perfectly fine. Do you know what the issue is?

Using the same preprocessor definitions that worked for the other DOF shaders, try reduce "auto sample radius" to 30 and the "hyperfocal depth distance" to a value between 30 and 50... I should add, I set my processor distance to 10000, because I did it one day in a fit a frustration and it has worked great for me ever since and I feel like I can hone in on a better DoF behavior much easier than dealing with the default distance value of 1000.

Using the above strategy, I have found success using Marty's excellent new Advance DoF shader in any game with a Depth buffer. It seemed nearly impossible to make the constant blurring stop before lowering the auto-sameple-radius in particular. Good luck!
Last Edit: 1 year 4 months ago by AssassinsDecree. Reason: quoted message i was responding to
The administrator has disabled public write access.

qUINT 1 year 4 months ago #64

.
Last Edit: 1 year 4 months ago by Uncle Crassius.
The administrator has disabled public write access.

qUINT 1 year 4 months ago #65

Hi, i tried to use the qUINT Shaders in No Man's Sky and everything works besides the DOF Shader ingame it wont show in the Shader List and in the ReShade Log i found this:
11:58:55:366 [02536] | INFO  | Compiling 'G:\Benutzerdateien\******\ReShade\ReShade 3.0\ReShade 3.4\Shaders\qUINT_dof.fx' ...
11:58:55:468 [02536] | ERROR | Failed to compile 'G:\Benutzerdateien\******\ReShade\ReShade 3.0\ReShade 3.4\Shaders\qUINT_dof.fx':
0(70) : error C7502: OpenGL does not allow type suffix 'x' on constant literals in versions below 120
0(70) : error C1021: operands to "%" must be integral
0(70) : error C0000: syntax error, unexpected identifier, expecting ',' or ')' at token "xx"
 G:\Benutzerdateien\Dennis\ReShade\ReShade 3.0\ReShade 3.4\Shaders\qUINT_dof.fx(571, 6): error: internal shader compilation failed
Fragment info
-------------
0(70) : error C7502: OpenGL does not allow type suffix 'x' on constant literals in versions below 120
0(70) : error C1021: operands to "%" must be integral
0(70) : error C0000: syntax error, unexpected identifier, expecting ',' or ')' at token "xx"
(0) : error C2003: incompatible options for link
 G:\Benutzerdateien\Dennis\ReShade\ReShade 3.0\ReShade 3.4\Shaders\qUINT_dof.fx(668, 1): error: program linking failed
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

qUINT 1 year 4 months ago #66

Difficult to fix this. Sure, I could restructure code so it works but in theory, ReShade transpiler is at fault here, it's supposed to translate shaders to HLSL and GLSL without any problems, where my DOF works for all DX versions, but the OpenGL translated one seems to be borked.
The administrator has disabled public write access.

qUINT 1 year 4 months ago #67

Cheers, crosire =)
The administrator has disabled public write access.
The following user(s) said Thank You: Wicked Sick, Pondural, conan2k, Zyrusticae, Qsimil, Sinclair, AssassinsDecree

qUINT 1 year 4 months ago #68

TreppenBananenHutstaender wrote:
Hi, i tried to use the qUINT Shaders in No Man's Sky and everything works besides the DOF Shader ingame it wont show in the Shader List and in the ReShade Log i found this:
11:58:55:366 [02536] | INFO  | Compiling 'G:\Benutzerdateien\******\ReShade\ReShade 3.0\ReShade 3.4\Shaders\qUINT_dof.fx' ...
11:58:55:468 [02536] | ERROR | Failed to compile 'G:\Benutzerdateien\******\ReShade\ReShade 3.0\ReShade 3.4\Shaders\qUINT_dof.fx':
0(70) : error C7502: OpenGL does not allow type suffix 'x' on constant literals in versions below 120
0(70) : error C1021: operands to "%" must be integral
0(70) : error C0000: syntax error, unexpected identifier, expecting ',' or ')' at token "xx"
 G:\Benutzerdateien\Dennis\ReShade\ReShade 3.0\ReShade 3.4\Shaders\qUINT_dof.fx(571, 6): error: internal shader compilation failed
Fragment info
-------------
0(70) : error C7502: OpenGL does not allow type suffix 'x' on constant literals in versions below 120
0(70) : error C1021: operands to "%" must be integral
0(70) : error C0000: syntax error, unexpected identifier, expecting ',' or ')' at token "xx"
(0) : error C2003: incompatible options for link
 G:\Benutzerdateien\Dennis\ReShade\ReShade 3.0\ReShade 3.4\Shaders\qUINT_dof.fx(668, 1): error: program linking failed

HELL YEAH! I just came here to ask about this very thing. Oh happy day! Thanks Crosire, and thanks Marty (of course), and thanks Treppen for asking the question and going through the log stuff. Woot woot! Also, just to spread the word, for people with integreated graphics cards, those on laptops I assume, BlueSky over on the No Mans Sky modding discord helped me figure out that you can make the game work with resahde by disabling your integrated graphics card in your device manager. You'll probably have to change your display settings to fix most programs having blurry, zoomed in text/scaling, but it's not too hard to do that and is painless enough. After two sign outs and some tweaks on the display settings, I was back to my display looking normal in just a minute or two. Now I can finally run NMS without CTD on launch.

Only drawback is that the ReShade UI seems to be constantly fighting itself. By that I mean i move the mouse cursor to change any reshade settings (cursor stuck in middle of the screen when the resahde GUI is up) and the reshade GUI will get hidden behind the border effect and obscured/warped by things like reshade's Prism effect, for example. Never seen this happen in any game before. Perhaps it's an openGL thing, I have no idea. Just a heads up to all that happen to see this.
Last Edit: 1 year 4 months ago by AssassinsDecree.
The administrator has disabled public write access.

qUINT 1 year 4 months ago #69

crosire wrote:
Not really
-------------
0(71) : error C1115: unable to find compatible overloaded function "ldexp(vec2, int)"
(0) : error C2003: incompatible options for link
 B:\Games\Re-Volt\Shaders\ReShade\qUINT_bloom.fx(378, 1): error: program linking failed
0(71) : error C1115: unable to find compatible overloaded function "ldexp(vec2, int)"
 B:\Games\Re-Volt\Shaders\ReShade\qUINT_bloom.fx(325, 6): error: internal shader compilation failed
The administrator has disabled public write access.

qUINT 1 year 4 months ago #70

crosire wrote:
Sorry to be an idiot, but what do we do with the code you posted? I visited the github link you posted (using that view button) but don't see anything to actually download. Sorry for being daft. Thanks!
The administrator has disabled public write access.

qUINT 1 year 4 months ago #71

matsilagi wrote:
Why is it always my shaders ReShade chokes on :P

@AssassinsDecree: that'd ReShade source code, either wait for a new ReShade build (which will incorporate this fix and many more) or build it yourself. But as matsilagi pointed out, this doesnt seem to be a complete fix.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

qUINT 1 year 4 months ago #72

Oh! Ok cool, i've heard of people building reshade from the githud files but never understood why someone would need/want to do that. I'll look into it. Many thanks! Also, not that it's a big deal, but do you know if qUINT will be part of the official reshade package when the next update goes live?

Have a good day!
The administrator has disabled public write access.

qUINT 1 year 4 months ago #73

matsilagi wrote:
Not really
Works fine for me with top of tree build of ReShade.
Cheers, crosire =)
The administrator has disabled public write access.

qUINT 1 year 4 months ago #74

Will test in other OGL games then return.

But im pretty sure something isn't right.
The administrator has disabled public write access.

qUINT 1 year 3 months ago #75

Marty McFly wrote:
Hey man thanks for considering! I do have a Patreon; i used to have a paypal donate button but that isn't possible anymore with a private account, everyone wants money for nothing these days... I guess I should propagate this a bit more :cheer: Hope you like the other shaders, too. And don't forget, I'm open for any suggestions, bug reports and so on.

I do not know how to donate via Patreon. Could you please guide me through it?

I do have a suggestion for Lightroom but I don't know whether or not ReShade allows you to do this: A way to Save/Export current LUT so we don't have to take a screenshot, and crop the LUT manually in Photoshop which can be a little bit annoying. That's it.
The administrator has disabled public write access.

qUINT 1 year 3 months ago #76

Hey there, I'm not entirely sure what I'm doing wrong as I'm relatively new to this, but I can't seem to get any of these shaders to show up in my toggle menu. I've extracted the files and threw them into my game's core folder > reshade-shaders > Shaders, along with all other .fx files, but not one will load up. I'm using the most recent version of Reshade (3.4.1) for Dragon Age: Inquisition if that makes any difference.
The administrator has disabled public write access.

qUINT 1 year 3 months ago #77

Thanks again, Marty! Lightroom and the ADOF shader, no others for depth-of-field or color grading. No Man's Sky Next. Oh NMS is opengl and the ADOF couldn't work before the 3.4.1 update. So thanks Crosire for updating that aspect too! Woot woot!

Last Edit: 1 year 3 months ago by AssassinsDecree.
The administrator has disabled public write access.

qUINT 1 year 3 months ago #78

You need to inject the official ReShade into the game and then add the 2 files ("ReShade.fxh" and "qUINT_lightroom.fx").
"ReShade.fxh" will replace the original "ReShade.fxh" and everything will work, at least theoretically. :)
The administrator has disabled public write access.

qUINT 1 year 3 months ago #79

That issue is solved in latest qUINT build - qUINT went github btw. See first post for updates.
Updates from previous latest:

- migrated all necessary functions etc from ReShade.fxh to proprietary common file, so no more clashes with official ReShade repo
- changed bloom blending
- added bloom adaptation
Last Edit: 1 year 3 months ago by Marty McFly.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

qUINT 1 year 3 months ago #80

Hey Marty,

Excited to try the latest version of qUINT. Just loaded it up with No Man's Sky (opengl, if that matters). All shaders compile fine except for Bloom. Error:

pastebin.com/5BHPHZT7
The administrator has disabled public write access.