Welcome, Guest.
Username: Password: Remember me

TOPIC: qUINT

qUINT 1 year 3 weeks ago #81

Crosire, I did it again :P

Martigen, this is a ReShade problem for now, it doesn't transpile something properly to OGL. I'll push a workaround later.
Last Edit: 1 year 3 weeks ago by Marty McFly.
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #82

Thats the error i've had before and crosire said it was "fixed"

However i don't remember if i posted a log or not, so i may not have been clear enough.

EDIT:Checked before and i did, apparently both No Man's Sky and Re-Volt suffers from it.
Last Edit: 1 year 3 weeks ago by matsilagi.
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #83

Marty McFly wrote:
That issue is solved in latest qUINT build - qUINT went github btw. See first post for updates.
Updates from previous latest:

- migrated all necessary functions etc from ReShade.fxh to proprietary common file, so no more clashes with official ReShade repo
- changed bloom blending
- added bloom adaptation

More updates? You're a great man Marty, a great man indeed.
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #84

I downloaded qUINT yesterday from GitHub and qUINT_Bloom.fx looks broken.
Should that shader be in a usable state, or is there some WIP-stuff going on right now?



(The uniforms are all at their default value)
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #85

That should not happen at all. Could you provide more any info about your system and the used game here?
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #86

Same happening for me too, but in No Man's Sky. Been using Quint Lightroom, DOF and Bloom in the previous version. Changed to the new; LR and DOF still work fine, but Bloom is a total white out. Changing of any bloom settings has no effect whatsoever, so had to disable bloom altogether.
Last Edit: 1 year 3 weeks ago by TheDazaster.
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #87

Marty McFly wrote:
That should not happen at all. Could you provide more any info about your system and the used game here?

Sure.
System Information from NVIDIA Control Panel:
Warning: Spoiler! [ Click to expand ]


System Information from DxDiag:
Warning: Spoiler! [ Click to expand ]


The log from ReShade:
Warning: Spoiler! [ Click to expand ]


The game from the screenshot is The Evil Within (D3D11).
Same issue with Remember Me (D3D9) and Exanima (OpenGL).

And one other error that I've never seen before is probably worth mentioning.
After starting Remember Me I got the following error message:
Your video card does not support alpha blending with floating point
render targets (D3DFMT_A16B16G16R16F), which is required to run this
game. Exiting...
I only saw this once today, and I am unable to reproduce it.
Last Edit: 1 year 3 weeks ago by Daodan.
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #88

TheDazaster wrote:
Same happening for me too, but in No Man's Sky. Been using Quint Lightroom, DOF and Bloom in the previous version. Changed to the new; LR and DOF still work fine, but Bloom is a total white out. Changing of any bloom settings has no effect whatsoever, so had to disable bloom altogether.
Just want to confirm I get the same in No Man's Sky too.
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #89

Hmm, I wasn't able to check into the file yet, does it progressively turn into white or does something else happen? What happens when you set adaptation sensitivity to 0 and reload the shader?
The administrator has disabled public write access.

qUINT 1 year 3 weeks ago #90

After some fiddling around with qUINT_bloom.fx here's a quick procedure to 'fix' the total white out:
1. Set 'Bloom Scene Adaption Sensitivity' to 0.0.
2. Set 'Bloom Scene Adaption Speed' to a non-zero value so you see the change.
3. Increase the value of 'Bloom Scene Exposure Bias' until the result looks good. Higher values result in a darker image.
Last Edit: 1 year 3 weeks ago by Daodan.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

qUINT 1 year 3 weeks ago #91

Default values are the problem.
Adapt speed 0 means the interpolation over time is always using the previous value which is the original value created at runtime start which is 0 (every texture is initialized to 0) and the adaptation code then divides by that (actually + 1^-6 but that results in full white for everything non-black either way). Should probably force other standard values, expect fix tomorrow.
Last Edit: 1 year 3 weeks ago by Marty McFly.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

qUINT 1 year 3 weeks ago #92

One question though: what should I expect when changing the exposure bias?
It's just that my first intuition would be that values below zero result in a darker image/less bloom and positive values in a brighter image/more bloom.
But it's quite the oppsosite. And if the exposure bias is set to a value below a certain threshold (depending on the brightness of the scene somewhere around zero or a bit higher) the result looks like in post #84.
The administrator has disabled public write access.

qUINT 1 year 2 weeks ago #93

Updated files, apologies for delay.

Daodan, that's exactly correct - looking back at the code, I have no idea myself what I did t here. Exposure bias now does exactly what it's supposed to, I adjusted value ranges a bit and also changed default settings so it's advised to wipe your config of the current settings and use the new ones as a baseline.

I also seized the opportunity and updated the personal info part in the file headers, since my facebook site is currently disabled until Germany reworks a specific law this information is no longer valid.
Last Edit: 1 year 2 weeks ago by Marty McFly.
The administrator has disabled public write access.
The following user(s) said Thank You: AssassinsDecree

qUINT 1 year 2 weeks ago #94

Hey Marty, thanks for the update. One thing though, not sure what you changed, but it completely borks current ADOF settings. Went from perfectly configured to covering the whole screen, like the depth buffer got flipped somehow, but from the shader itself. Not saying it's a wrong, I have no idea, just that something in the new update changed how the settings are read/outputted. Was that intended/expected?

Many thanks for all your great work!

Edit: Yea, actually no setting I change seems to be able to push the DoF to the background anymore. The only two settings that seem to cause any change at all are the bokeh maximum size, bokeh intensity, and bokeh shape quality.



Can confirm that replacing the new qUINT_dof.fx with the old one fixes the issue.
Last Edit: 1 year 2 weeks ago by AssassinsDecree.
The administrator has disabled public write access.

qUINT 1 year 2 weeks ago #95

Hi, Marty!
Is there a way to apply MXAO only to character on the scene?
I tried to reduce distance by editing Fade Out Start/End but nothing changes.
Warning: Spoiler! [ Click to expand ]
The administrator has disabled public write access.

qUINT 1 year 2 weeks ago #96

@AssassinsDecree: Oh whoops. I had to test something and edited the file to output same blur everywhere. Pushing fix any minute.

@Crystex: character masks not possible. And fade start and end do something, you just have them set very high. Set fade start to 0 and fade end to 0.1 or so, then it only applies to close objects.
Last Edit: 1 year 2 weeks ago by Marty McFly.
The administrator has disabled public write access.
The following user(s) said Thank You: Crystrex, AssassinsDecree

qUINT 1 year 2 weeks ago #97

Sweet, thanks for the fast response! Sidenote, it being over the whole screen like that really shows just how gorgeous the bokeh elements can be in the ADOF shader. My goal in life is to make that same strength/glow of the bokeh circles but in the autofocus settings.

Break it again! (jk jk) :)

Cheers!
The administrator has disabled public write access.

qUINT 1 year 2 weeks ago #98

@Marty McFly
Set fade start to 0 and fade end to 0.1 or so, then it only applies to close objects.
0.1 and nothing changed.
0.00001 = perfect character mask... but inverted to MXAO.
Any ideas?

Warning: Spoiler! [ Click to expand ]
Last Edit: 1 year 2 weeks ago by Crystrex.
The administrator has disabled public write access.

qUINT 1 year 2 weeks ago #99

@AssassinsDecree: download again, I fixed it.

@Crystrex: well, some of your depth options (RESHADE_DEPTH_INPUT_IS_REVERSED etc) are off, because that's not at all how SSAO should look like. Try adding RESHADE_DEPTH_INPUT_IS_REVERSED=1 or =0 to your preprocessor section in the UI and reload shaders. If you want to investigate further, use the DisplayDepth shader and check if it shows a transition from black(near) to white(far) and NOT vice versa.
The administrator has disabled public write access.
The following user(s) said Thank You: Crystrex, AssassinsDecree

qUINT 1 year 2 weeks ago #100

Marty McFly wrote:
@AssassinsDecree: download again, I fixed it.

@Crystrex: well, some of your depth options (RESHADE_DEPTH_INPUT_IS_REVERSED etc) are off, because that's not at all how SSAO should look like. Try adding RESHADE_DEPTH_INPUT_IS_REVERSED=1 or =0 to your preprocessor section in the UI and reload shaders. If you want to investigate further, use the DisplayDepth shader and check if it shows a transition from black(near) to white(far) and NOT vice versa.

do you can have implements RESHADE_DEPTH_INPUT_IS_REVERSED in AO code for use in these situations or dont
The administrator has disabled public write access.