Compatibility list

More
6 years 8 months ago #175 by JPulowski
Replied by JPulowski on topic Compatibility list

Any chance you can start a reshade steam group so if people want to add each other they can easily?

There is already one available: steamcommunity.com/groups/SweetFX
The following user(s) said Thank You: Omnipotus

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #176 by tybalitea
Replied by tybalitea on topic Compatibility list
some games i've tested with the last version 0.14.0 :
Drakensang (d3d9.dll) works with depthbuffer access, and i think the sequel River of Time too :

http://i.imgur.com/lgoxQd2.png?1

Divinity 2 DKS (d3d9.dll), HDR needs to be disabled in the game menu to have depthbuffer :

http://i.imgur.com/tYD9RsF.png?1
http://i.imgur.com/rScYWrj.png?1

Hitman : blood money (d3d9.dll) works with depthbuffer too (0.13.2)
Last edit: 6 years 8 months ago by tybalitea. Reason: incomplete post, i've forgotten the hook
The following user(s) said Thank You: strelokgunslinger

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #177 by NattyDread
Replied by NattyDread on topic Compatibility list
I managed to get the depth buffer in Dying Light to look like this:

by using sfx only. I couldn't manage to get a greater depth than this.
Can someone with some coding skill take a look in master effect and see if something like this is doable there?

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #178 by robgrab
Replied by robgrab on topic Compatibility list
I retried all of these games using 0.14.0 and they work fine. All the previous issues remain though (i.e. System Shock 2: Depthbuffer is partly cleared when weapon is holstered.) Go ahead and update the list.

Call of Juarez: Bound in Blood - d3d9.dll
Chronicles of Riddick: Dark Athena - opengl32.dll
Condemned: Criminal Origins - d3d9.dll
Dead Space 3 - d3d9.dll
Psychonauts - d3d9.dll
Quake 4 - opengl32.dll
Resident Evil: Revelations - d3d9.dll
Saint's Row IV - dxgi.dll
System Shock 2 - d3d9.dll
TRON 2.0 - d3d9.dll
Last edit: 6 years 8 months ago by robgrab.
The following user(s) said Thank You: Omnipotus

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #179 by strelokgunslinger
Replied by strelokgunslinger on topic Compatibility list

I retried all of these games using 0.14.0 and they work fine. All the previous issues remain though (i.e. System Shock 2: Depthbuffer is partly cleared when weapon is holstered.) Go ahead and update the list.

Call of Juarez: Bound in Blood
Chronicles of Riddick: Dark Athena
Condemned: Criminal Origins
Dead Space 3
Psychonauts
Quake 4
Resident Evil: Revelations
Saint's Row IV
System Shock 2
TRON 2.0


Try to add the hook for each game

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #180 by turboscalpeur
Replied by turboscalpeur on topic Compatibility list
KillerIsDead Win32 || d3d9.dll || ReShade 0.14.0 + SweetFX 2.0 + MasterEffect ReBorn 1.0.340 || Success, DepthBuffer Access.

Limbo d3d9.dll || ReShade 0.14.0 + SweetFX 2.0 + MasterEffect ReBorn 1.0.340 || Success, DepthBuffer Access.

The Plan OPENGL32.dll || ReShade 0.14.0 + SweetFX 2.0 + MasterEffect ReBorn 1.0.340 || Success, DepthBuffer Access.
The following user(s) said Thank You: Omnipotus

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #181 by robgrab
Replied by robgrab on topic Compatibility list

Try to add the hook for each game


Done. I updated my previous post.
Last edit: 6 years 8 months ago by robgrab.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #182 by FYKC
Replied by FYKC on topic Compatibility list
Deus Ex Human Revolution with DirectX11 enabled works just fine with ReShade 0.14.0 using dxgi.dll. Depth buffer effects like SSAO and DoF don't work though. The shader toggle key functionality seems unresponsive as well.

E.Y.E. Divine Cybermancy works with ReShade 0.14.0 using d3d9.dll. Depth buffer effects don't work, though. You need to install ReShade into the /bin/ folder located within the games root folder.
Last edit: 6 years 8 months ago by FYKC.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #183 by SiriusHours
Replied by SiriusHours on topic Compatibility list
The Saboteur, d3d9 working fine with latest release 0.14.0, without depth access it seems though.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #184 by BillyAlt
Replied by BillyAlt on topic Compatibility list
Update on Deus Ex: Human Revolution - Director's Cut

Reshade 0.14.0

Managed to get DX11 working. Need to make sure d3d9.dll is deleted. Depthbuffer is black and as far I can tell Reshade has absolutely no depthbuffer access in DX11 for this game. DX9 still only has partial depthbuffer access, as before.

Seems to crash on exit.
Last edit: 6 years 8 months ago by BillyAlt.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #185 by tybalitea
Replied by tybalitea on topic Compatibility list
Some games i tried (0.14.0) :

The Age of Decadence (d3d9.dll) : works fine with Depthbuffer
Betrayer (d3d9.dll) : Works, but depthbuffer isn't recognized
Fable 3 (d3d9.dll) : Works, Depthbuffer flickers like a stroboscope
Neverwinter Nights (opengl32.dll) : Works, Depthbuffer same problem as nwn2 and the witcher
Vampire the Masquerade Bloodlines (d3d9.dll) : Works perfectly

here is a gallery with screenshots
imgur.com/a/T7myt
Last edit: 6 years 8 months ago by tybalitea.
The following user(s) said Thank You: Omnipotus

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #186 by klotim
Replied by klotim on topic Compatibility list
Oblivion works but no depth buffer
Napoleon Total War Crashes randomly but depth buffer works without AA.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #187 by VoodaGod
Replied by VoodaGod on topic Compatibility list
Battlefield Hardline Beta works, but enabled Depth Buffer Output shows a black screen (running in DX11)

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #188 by FYKC
Replied by FYKC on topic Compatibility list
Return to Castle Wolfenstein is compatible with 0.14.0 using opengl32.dll. Depth buffer is accessible for a few moments upon ReShade being compiled and effects like DOF and SSAO work in that time but after about five or so seconds it cuts out and the depth buffer just shows up as black from then on. Non-depth buffer effects remained untouched and working, though.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #189 by Omnipotus
Replied by Omnipotus on topic Compatibility list
I'll update the lists shortly, been sucked up in Dying Light lately lol, been cleaning up PC as well, "New" GPU is expected tomorrow so I've been getting things ready for the format back to Windows 8 etc.etc. if I don't updat the list tonight I will tomorrow morning.

As always, big thanks to everyone helping out and sharing your findings, smootches!! :D
The following user(s) said Thank You: alfski

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #190 by alfski
Replied by alfski on topic Compatibility list
Google Earth 7.x UPDATE with ReShade 0.14.0

"GOOD"

- OpenGL colors are fixed with latest NVIDIA drivers (tested with QUADRO K5000 and driver 347.25)
- OpenGL DepthMap is NOT flipped
- DirectX DepthMap IS flipped!
- DepthMap is not available to shaders until ALL the scene geometry is downloaded (which is a pity)
- OpenGL seems to "black out" until DepthMap is available. May be a MasterEffectReBorn.fx problem though.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #191 by Omnipotus
Replied by Omnipotus on topic Compatibility list
I just updated the Compatibility List with the latest community updates, great j0rb guys, really appreciate the time put into testing these, also enjoying the screenshots as proof as well, please remember to put the hook used when testing, I had to input ???? for a two listings because the hook was left out, someone will eventually fill me in but in the future throw the Hook down please, thanks, smootches :D

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #192 by FYKC
Replied by FYKC on topic Compatibility list
The Wolf Among Us works with ReShade version 0.14.0 using d3d9.dll with no crashes during loading. No depth buffer access, though.
The following user(s) said Thank You: crosire

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #193 by tybalitea
Replied by tybalitea on topic Compatibility list
Tested with 0.14.0 :

Y's Origin (d3d9.dll) works perfectly
Jade Empire (d3d9.dll) works perfectly
Bound by Flame (d3d9.dll) works perfectly
The Walking Dead season 2 (d3d9.dll): Disable the antialising in the game menu to have depthbuffer access
( it should be the same for all telltale games)
The Legend of Heroes : Trails in the sky (d3d8.dll) no depthbuffer

imgur.com/a/T7myt#19
The following user(s) said Thank You: Omnipotus

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #194 by TreppenBananenHutstaender
Replied by TreppenBananenHutstaender on topic Compatibility list
Star Wars The Old Republic works with 0.14.0, no depthbuffer access and you need to use a large adress aware tool if you have a 64 bit os; hook: d3d9.dll screenshot: imgur.com/8foIZZ8
Last edit: 6 years 8 months ago by TreppenBananenHutstaender.

Please Log in or Create an account to join the conversation.