Compatibility list

More
7 years 2 months ago #361 by TreppenBananenHutstaender
Replied by TreppenBananenHutstaender on topic Compatibility list
SkySaga - Infinite Isles (32 bit), d3d9, good, no depth buffer access.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago - 7 years 2 months ago #362 by Merpitymerp
Replied by Merpitymerp on topic Compatibility list
Dead Island: Riptide works perfectly (including depth buffer), which makes sense since the original did. D3D9.

7 Days to Die works very well and breathes new life into the game. It works great, but depth buffer is flipped (although I found a way to change the code to make depth of field work regardless). Just make sure to run the version without EastAntiCheat. Opengl.

Audiosurf does work, but has no depth buffer access (white screen, so must be empty). Installing was also a little bit wonky (you need to install it into "/engine/" and when it asks for an .exe use QuestViewer.exe, but when you run the game you have to run Audiosurf.exe in the main folder.). Otherwise, great for adding SMAA. D3D9.

Contagion works well, no depth buffer. D3D9.

Gone Home works well, but depth buffer is dark (does that mean it is logarithmic?) and flipped. Opengl.
Last edit: 7 years 2 months ago by Merpitymerp. Reason: Added 7DTD listing, then added Audiosurf listing.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago - 7 years 2 months ago #363 by Janson
Replied by Janson on topic Compatibility list
It probably has been mentioned already, the compatibiity list is not really all that helpfull when newer releases undo what worked before or behave differently. E.g. a game used to work perfectly with ReShade 12.0, it's not working perfectly with the newest version though. Now downloading version 12.0 doesn't help if the shader suits are no longer available in a compatible state for that version.

For example, Enslaved: Odyseey to the West. No depthbuffer access, 'clip space clip planes?' (completely white). I've noticed this with several games now, is there any chance that ReShade can be improved regarding the clipping distances?
Last edit: 7 years 2 months ago by Janson.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #364 by FYKC
Replied by FYKC on topic Compatibility list
Fallout 2
d3d9.dll, WORKS. No Depthbuffer. - ReShade Framework 0.18.4

Use fo2 mod "sfall" and set the graphics mode to "4".
The following user(s) said Thank You: Cloudbill

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago - 7 years 2 months ago #365 by MichaelF
Replied by MichaelF on topic Compatibility list

Sims 3 with v0.14.0 d3d9.dll works for me
imgur.com/a/YloCp

Hello! what exactly settings and reshade did you use here? link to personal messages would be perfect!
imgur.com/a/YloCp
Last edit: 7 years 2 months ago by MichaelF.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #366 by SkacikPL
Replied by SkacikPL on topic Compatibility list
Hyperdimension Neptunia Re;Birth2 Sisters Generation

Incompatible.

Unable to inject, game uses OpenGL but in form of (NVIDIA's?) cgGL. Overriding standard OpenGL32.dll does nothing, replacing cgGL libraries will make the game unable to boot.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #367 by crosire
Replied by crosire on topic Compatibility list

Unable to inject, game uses OpenGL but in form of (NVIDIA's?) cgGL. Overriding standard OpenGL32.dll does nothing, replacing cgGL libraries will make the game unable to boot.

Try injecting with some tool like ENBInjector.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #368 by SkacikPL
Replied by SkacikPL on topic Compatibility list
External injection works, but it's worthless.

It has exactly same issues as the first game (3d mode is way too dark, but characters faces are lit normally), additionally it causes severe performance issues.

Also there's no depth buffer access.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #369 by aenigmat
Replied by aenigmat on topic Compatibility list
Hi guys! B)

I've been testing reshade in some games thats aren't on the list, so, here is what games and what to do that worked fine to me:

Dota 2 -> Just need to open the game root folder (mine is "C:/Program Flies(x86)/Steam/Steamapps/common/dota 2 beta") and move d3d9.dll, sweetfx folder, reshade.fx and sweet.fx (all reshade created files) to the "bin" folder.
-> DX 9

Chivalry: Medieval Warfare -> Just select the "bin" folder inside the game root folder, inside the "bin" folder select the game version folder, x32 or x64, and at last select the game .exe, CMW.exe, something like this.
-> DX 9

Chivalry: Deadliest Warrior -> Just go to the "Chivalry: Medieval Warfare" folder, select the "CDW" (Chivalry Deadliest Warrior) folder, open the "bin" folder, select the game version folder you run (x32 or x64 folder) and select the game .exe, something like CDW.exe.
-> DX 9

7 Days to Die -> Just select the game .exe on the game installation root folder, you cant play the game version with EAC activated, to play on servers with EAC you'll need to uninstall reshade.
-> DX 9

No More Room In Hell -> In the reshade setup select the "sdk" folder inside the game root folder, select the hl2.exe, after that select "DirectX 9" on reshade setup if autodetect don't select it, close the setup, go to the sdk folder where you install reshade and move d3d9.dll, sweetfx folder, reshade.fx and sweet.fx (all reshade created files) to the "bin" folder.
-> DX 9

Life Is Feudal: Your Own -> Just select the game .exe in his root folder.
-> DX 9

I'll test some more games and post the results here. :P

See ya!
The following user(s) said Thank You: crosire

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #370 by Mikan
Replied by Mikan on topic Compatibility list
Latest version tested before burning out again after 2 months :P
World of Warcraft : Still Perfect / / Version: 0.18.4 / Hook:dxgi.dll 64bit
Not tested later versions

Testing Gunner class^^
TERA Fate of Arun (Free2Play) : Issues. (No Depth Buffer access) / / Version: 0.18.2 / Hook:d3d9.dll 32bit
Affects launcher I think, so it must be turned off when changing versions to prevent driver crash.
"\Steam\SteamApps\common\TERA\Client\Binaries"
Version 0.18.3 to 0.18.7 instant crashes when trying to start game through launcher with below log, game is built on udk3 if I recall right:>
Warning: Spoiler!
The following user(s) said Thank You: Marty McFly

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago - 7 years 2 months ago #371 by jas01
Replied by jas01 on topic Compatibility list

ReShade + Framework 18.1 works with The Elder Scrolls III: Morrowind--no depth buffer, though.

Now if only I could figure out a way to use both ReShade and MGE-XE together at once...


I have solution for you. :)

/Edit:

Nevermind - My bad. Reshade 18.7 works correctly with MGE-XE. (d3d9, depth buffer access) ;)
Last edit: 7 years 2 months ago by jas01.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #372 by Psychosis
Replied by Psychosis on topic Compatibility list

I mainly played around with Underground 2 (which was tons of fun), but I also tried those unlisted games:


What version of Underground 2 did you use? 0.18.0 does not work for me.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #373 by jmx777
Replied by jmx777 on topic Compatibility list
AVATAR THE VIDEOGAME

perfect deep buffer acces

DX9 + reshade 0.15, ***** in game MSAA (8X) Works!!!! *****

PS: I can't make it work under DX10, but not realy needed (for my at least :) )

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #374 by Marty McFly
Replied by Marty McFly on topic Compatibility list

Latest version tested before burning out again after 2 months :P
World of Warcraft : Still Perfect / / Version: 0.18.4 / Hook:dxgi.dll 64bit
Not tested later versions

Testing Gunner class^^
TERA Fate of Arun (Free2Play) : Issues. (No Depth Buffer access) / / Version: 0.18.2 / Hook:d3d9.dll 32bit
Affects launcher I think, so it must be turned off when changing versions to prevent driver crash.
"\Steam\SteamApps\common\TERA\Client\Binaries"
Version 0.18.3 to 0.18.7 instant crashes when trying to start game through launcher with below log, game is built on udk3 if I recall right:>
Warning: Spoiler!


Please post a tracelog, so Crosire can find the issue easier. Rename the .log file to .tracelog, let the game start and crash and post the log here.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #375 by One3rd
Replied by One3rd on topic Compatibility list
I see that Batman: Arkham Origins is in the compatibility list but I can't seem to get the depth buffer to work. Is there anything special I need to be doing? I'm using ReShade 0.18.7.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #376 by FYKC
Replied by FYKC on topic Compatibility list
Project Snowblind is fully compatible with 0.18.7.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago - 7 years 1 month ago #377 by vladstad
Replied by vladstad on topic Compatibility list
Gun is fully compatible with .18.7 32bit d3d9.dll

sudeki is fully compatible with .18.7 32bit d3d9.dll however there is an issiue with abient occlussion and tree leave transparency. the invisible parts of leaves will be shaded which makes the invisible visible.

Rogue Trooper is fully compatible with .18.7 32 bit d3d9.dll

man this program helps these old games look great

forget what i said about tomb raider anniversary :P
Last edit: 7 years 1 month ago by vladstad.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #378 by nacy
Replied by nacy on topic Compatibility list

As this was requested, here's a game compatibility list .
If you have a game that's not on the list, please answer this topic and tell your findings with it =)


Hello
you can add IL2 Cliffs Of Dover in the ReShade list.
vous pouvez ajouter IL2 Cliffs Of Dover dans la liste ReShade.

Merci...

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #379 by chaoko99
Replied by chaoko99 on topic Compatibility list
Okay, this is my first post on this forum, this is probably gonna look messy, but it appears that ALL unreal engine games are partially incompatible with reshade, as menus and UI features such as health and stamina (For example.) refuse to render, and instead show only the background. effects do however work, only menus are nonfunctioning.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #380 by BrandonHortman
Replied by BrandonHortman on topic Compatibility list
Wolfenstein seems to be wrong in the compatability list.

Wolfenstein: The New Order does NOT have depth buffer access at all it seems, as I just played through half the game for the second time

Where as Wolfenstein: The Old Blood has perfect depth buffer access, I just finished it for the second time with DOF on.

If the depth buffer is viewed in The New Order it displays a black screen with a couple of lighter squares all over it.

Please Log in or Create an account to join the conversation.